[PATCH] Add fet

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 14 Aug 2019 17:38
(address . guix-patches@gnu.org)
87pnl7g3kd.fsf@nicolasgoaziou.fr
Hello,

The following patch adds FET.

Feedback welcome.

Regards,

--
Nicolas Goaziou
From c77ce398324f2fc90332e19820d638ed7b055c50 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Wed, 14 Aug 2019 17:35:47 +0200
Subject: [PATCH] gnu: Add fet.

* gnu/packages/education.scm (fet): New variable.
---
gnu/packages/education.scm | 40 ++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 0bb9c099fb..440746a28c 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -480,3 +480,43 @@ use the computer and at the same time teach them a little math,
letters of the alphabet, spelling, eye-hand coordination, etc.")
(home-page "http://www.schoolsplay.org")
(license license:gpl3+)))
+
+(define-public fet
+ (package
+ (name "fet")
+ (version "5.39.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
+ "fet-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "100bmggkychqs2cavqxy7015lr4icw6k99qb03im0v4jasqqmyix"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-hardcoded-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (list "fet.pro"
+ "src/src.pro"
+ "src/src-cl.pro"
+ "src/interface/fet.cpp")
+ (("/usr") (assoc-ref outputs "out")))
+ #t))
+ (replace 'configure
+ (lambda _ (invoke "qmake" "fet.pro"))))))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://www.lalescu.ro/liviu/fet/")
+ (synopsis "Timetabling software")
+ (description "FET is a program for automatically scheduling the
+timetable of a school, high-school or university. It uses a fast and
+efficient timetabling algorithm.
+
+Usually, FET is able to solve a complicated timetable in maximum 5-20
+minutes. For simpler timetables, it may take a shorter time, under
+5 minutes (in some cases, a matter of seconds). For extremely
+difficult timetables, it may take a longer time, a matter of hours.")
+ (license license:agpl3+)))
+
--
2.22.0
L
L
Ludovic Courtès wrote on 23 Aug 2019 23:34
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 37029@debbugs.gnu.org)
87imqnzhv8.fsf@gnu.org
Hi Nicolas,

Nicolas Goaziou <mail@nicolasgoaziou.fr> skribis:

Toggle quote (7 lines)
>>From c77ce398324f2fc90332e19820d638ed7b055c50 Mon Sep 17 00:00:00 2001
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Date: Wed, 14 Aug 2019 17:35:47 +0200
> Subject: [PATCH] gnu: Add fet.
>
> * gnu/packages/education.scm (fet): New variable.

LGTM, thanks!

Ludo’.
N
N
Nicolas Goaziou wrote on 24 Aug 2019 16:54
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37029-done@debbugs.gnu.org)
8736hqzk9o.fsf@nicolasgoaziou.fr
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
>> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> Date: Wed, 14 Aug 2019 17:35:47 +0200
>> Subject: [PATCH] gnu: Add fet.
>>
>> * gnu/packages/education.scm (fet): New variable.
>
> LGTM, thanks!
>
Applied. Thank you.

Regards,

--
Nicolas Goaziou
Closed
?