[PATCH 06/20] gnu: Add python2-tegaki-tools.

  • Done
  • quality assurance status badge
Details
One participant
  • Alex Vong
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 20 Aug 2019 17:48
(address . guix-patches@gnu.org)
86sgpvvnwj.fsf@gmail.com
From 693c0d7fa4e7cda42531986ffb0c5105c8082f0d Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Thu, 8 Aug 2019 13:56:56 +0800
Subject: [PATCH 06/20] gnu: Add python2-tegaki-tools.

* gnu/packages/language.scm (python2-tegaki-tools): New variable.
---
gnu/packages/language.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index bc02ff9681..d12ca7451e 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -35,7 +35,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3 gpl2 gpl2+ gpl3 perl-license zpl2.1))
+ #:select (bsd-3 gpl2 gpl2+ gpl3 gpl3+ perl-license zpl2.1))
#:use-module (guix download)
#:use-module (guix utils))
@@ -567,3 +567,30 @@ suitable for both the desktop and mobile devices.")
("python2-tegaki-python" ,python2-tegaki-python)))
(synopsis "Chinese and Japanese Handwriting Recognition (Base UI library)")
(license gpl2+))) ; all files
+
+(define-public python2-tegaki-tools
+ (package
+ (inherit python2-tegaki-wagomu)
+ (name "python2-tegaki-tools")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (tegaki-release-uri "tegaki-tools" version))
+ (sha256
+ (base32
+ "0xxv97ggh2jgldw3r7y59lv3fhz733r6l7mdn6nh4m0gvb0ja971"))
+ (modules remove-pre-compiled-files-modules)
+ (snippet (remove-pre-compiled-files "pyc"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-tegaki-wagomu)
+ ((#:phases _) '%standard-phases)))
+ (inputs
+ `(("python2-tegaki-pygtk" ,python2-tegaki-pygtk)))
+ ;; override inherited inputs
+ (native-inputs '())
+ (propagated-inputs '())
+ (synopsis "Chinese and Japanese Handwriting Recognition (Advanced tools)")
+ ;; Files in gifenc/ are licensed under gpl3+ while other files are licensed
+ ;; under gpl2+. Therefore, the combined work is licensed under gpl3+.
+ (license gpl3+)))
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVwWPAAKCRBh71Au9gJS
8ugsAP9krPW8MVJuHi6vQWi0QOgCbWgpDa/hfN2EqMzky+8FaAEAzmCmXWc+R6/7
nEGe3LgOjfSNFiTwSQe8DeNLx553OwU=
=/nsa
-----END PGP SIGNATURE-----

A
A
Alex Vong wrote on 20 Aug 2019 18:21
Close all erroneously created bugs
(address . control@debbugs.gnu.org)
8636hvvmd6.fsf@gmail.com
# Close all erroneously created bugs
# Sorry for the noise!
close 37100
close 37101
close 37102
close 37103
close 37104
close 37105
close 37106
close 37107
close 37108
close 37109
close 37110
close 37111
close 37112
close 37113
close 37114
close 37115
close 37117
close 37118
close 37119
thanks
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVweBQAKCRBh71Au9gJS
8iX/AQDvrrIjhGRhbjTLLI9GC1Da+T+Etd+cPADjUlCs2NeI5QD9F8qny/MUgmkr
6uoW0LvoKzh6JyP4FRboLw7mLxUrDwc=
=Pm3m
-----END PGP SIGNATURE-----

?