[PATCH 07/20] gnu: Add python2-tegaki-recognize.

  • Done
  • quality assurance status badge
Details
One participant
  • Alex Vong
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 20 Aug 2019 17:48
(address . guix-patches@gnu.org)
86r25fvnvn.fsf@gmail.com
From 01a3946b396a3fbd43d2b78fb7bcfda898de5c4b Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Thu, 8 Aug 2019 14:00:36 +0800
Subject: [PATCH 07/20] gnu: Add python2-tegaki-recognize.

* gnu/packages/language.scm (python2-tegaki-recognize): New variable.
---
gnu/packages/language.scm | 56 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 55 insertions(+), 1 deletion(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index d12ca7451e..ad7cf2a4b3 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -35,8 +35,10 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3 gpl2 gpl2+ gpl3 gpl3+ perl-license zpl2.1))
+ #:select
+ (bsd-3 gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 perl-license zpl2.1))
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils))
(define-public perl-lingua-en-findnumber
@@ -594,3 +596,55 @@ suitable for both the desktop and mobile devices.")
;; Files in gifenc/ are licensed under gpl3+ while other files are licensed
;; under gpl2+. Therefore, the combined work is licensed under gpl3+.
(license gpl3+)))
+
+(define-public python2-tegaki-recognize
+ (let ((commit "eceec69fe651d0733c8c8752dae569d2283d0f3c")
+ (revision "1"))
+ (package
+ (inherit python2-tegaki-tools)
+ (name "python2-tegaki-recognize")
+ ;; version copied from <https://github.com/tegaki/tegaki/releases>
+ (version (git-version "0.3.1" revision commit))
+ (source
+ (origin
+ ;; We use GIT-FETCH because 'tegaki-recognize.desktop.in' and
+ ;; 'tegaki-recognize.in' are missing in the tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tegaki/tegaki.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "09mw2if9p885phbgah5f95q3fwy7s5b46qlmpxqyzfcnj6g7afr5"))
+ (file-name (git-file-name name version))
+ (modules `((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26)
+ ,@remove-pre-compiled-files-modules))
+ (snippet
+ `(begin
+ ;; remove unnecessary files with potentially different license
+ (for-each delete-file-recursively
+ (scandir "."
+ (negate (cut member <> '("tegaki-recognize"
+ "." "..")))))
+ ,(remove-pre-compiled-files "pyc")
+ #t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-tegaki-tools)
+ ((#:phases _)
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "tegaki-recognize")
+ #t))
+ ;; 'setup.py' script does not support one of the Python build
+ ;; system's default flags, "--single-version-externally-managed"
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/")
+ #t))))))
+ (synopsis "Chinese and Japanese Handwriting Recognition (Main program)")
+ (license gpl2+)))) ; all files
--
2.22.0
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVwWXAAKCRBh71Au9gJS
8vADAQDZ1bBxVX9vsC22VQjlVOVDIU7CVeo2+fkWlDJkdzVgbgEAjWG0x0E5EZag
KoJ6g1YEOtadlIO0iwIpeO+aAkeAFA8=
=9I97
-----END PGP SIGNATURE-----

A
A
Alex Vong wrote on 20 Aug 2019 18:21
Close all erroneously created bugs
(address . control@debbugs.gnu.org)
8636hvvmd6.fsf@gmail.com
# Close all erroneously created bugs
# Sorry for the noise!
close 37100
close 37101
close 37102
close 37103
close 37104
close 37105
close 37106
close 37107
close 37108
close 37109
close 37110
close 37111
close 37112
close 37113
close 37114
close 37115
close 37117
close 37118
close 37119
thanks
-----BEGIN PGP SIGNATURE-----

iHUEARYIAB0WIQQwb8uPLAHCXSnTBVZh71Au9gJS8gUCXVweBQAKCRBh71Au9gJS
8iX/AQDvrrIjhGRhbjTLLI9GC1Da+T+Etd+cPADjUlCs2NeI5QD9F8qny/MUgmkr
6uoW0LvoKzh6JyP4FRboLw7mLxUrDwc=
=Pm3m
-----END PGP SIGNATURE-----

?