[PATCH] gnu: gcl: Enable tests.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 25 Aug 2019 17:42
(address . guix-patches@gnu.org)
20190825154206.3885-1-kkebreau@posteo.net
This patch enables tests in GNU Common Lisp and also seems to repair Maxima's
build failure on master (at least on x86_64). Review and more testing would be
appreciated.
K
K
Kei Kebreau wrote on 25 Aug 2019 17:44
(address . 37180@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190825154401.4321-1-kkebreau@posteo.net
* gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
#:test-target to "ansi-tests/test_results".
---
gnu/packages/lisp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d32f4b19bd..2c08e06a55 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -113,7 +113,7 @@
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; The build system seems not to be thread safe.
- #:tests? #f ; There does not seem to be make check or anything similar.
+ #:test-target "ansi-tests/test_results"
#:configure-flags '("--enable-ansi") ; required for use by the maxima package
#:make-flags (list
(string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")
--
2.23.0
K
K
Kei Kebreau wrote on 2 Sep 2019 20:16
(address . 37180-done@debbugs.gnu.org)
87v9uar2cc.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (20 lines)
> * gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
> #:test-target to "ansi-tests/test_results".
> ---
> gnu/packages/lisp.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
> index d32f4b19bd..2c08e06a55 100644
> --- a/gnu/packages/lisp.scm
> +++ b/gnu/packages/lisp.scm
> @@ -113,7 +113,7 @@
> (build-system gnu-build-system)
> (arguments
> `(#:parallel-build? #f ; The build system seems not to be thread safe.
> - #:tests? #f ; There does not seem to be make check or anything similar.
> + #:test-target "ansi-tests/test_results"
> #:configure-flags '("--enable-ansi") ; required for use by the maxima package
> #:make-flags (list
> (string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")

Pushed to master. The patch doesn't appear to negatively affect the
i686-linux, x86_64-linux and armhf-linux architectures.
Closed
?