[PATCH 1/2] adds the capability of importing a specified version to the crate importer

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
Merged with
M
M
Martin Becze wrote on 6 Sep 2019 17:32
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20190906153211.8613-1-mjbecze@riseup.net
---
guix/import/crate.scm | 23 ++++++++++++++++++++---
1 file changed, 20 insertions(+), 3 deletions(-)

Toggle diff (56 lines)
diff --git a/guix/import/crate.scm b/guix/import/crate.scm
index f6057dbf8b..3266ebdfec 100644
--- a/guix/import/crate.scm
+++ b/guix/import/crate.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,8 +182,8 @@ and LICENSE."
;; This regexp matches that.
(make-regexp "^(.*) OR (.*)$"))
-(define (crate->guix-package crate-name)
- "Fetch the metadata for CRATE-NAME from crates.io, and return the
+(define (crate->guix-package crate-name@version)
+ "Fetch the metadata for CRATE-NAME@VERSION from crates.io, and return the
`package' s-expression corresponding to that package, or #f on failure."
(define (string->license string)
(match (regexp-exec %dual-license-rx string)
@@ -193,13 +194,29 @@ and LICENSE."
(define (normal-dependency? dependency)
(eq? (crate-dependency-kind dependency) 'normal))
+ (define crate-name-version-list
+ (let ((lnv (string-split crate-name@version #\@)))
+ (if (= 1 (length lnv))
+ (append lnv '(#f))
+ lnv)))
+
+ (define crate-name
+ (car crate-name-version-list))
+
+
(define crate
(lookup-crate crate-name))
+ (define crate-version-string
+ (let ((version (cadr crate-name-version-list)))
+ (if version
+ version
+ (crate-latest-version crate))))
+
(and crate
(let* ((version (find (lambda (version)
(string=? (crate-version-number version)
- (crate-latest-version crate)))
+ crate-version-string))
(crate-versions crate)))
(dependencies (crate-version-dependencies version))
(dep-crates (filter normal-dependency? dependencies))
--
2.23.0
L
L
Ludovic Courtès wrote on 8 Sep 2019 14:27
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 37322@debbugs.gnu.org)
877e6j9dmj.fsf@gnu.org
Hello Martin,

So the goal is to allow users to run “guix import rust-foo@1.2.3”,
right? That’s a good idea.

Martin Becze <mjbecze@riseup.net> skribis:

Toggle quote (21 lines)
> diff --git a/guix/import/crate.scm b/guix/import/crate.scm
> index f6057dbf8b..3266ebdfec 100644
> --- a/guix/import/crate.scm
> +++ b/guix/import/crate.scm
> @@ -1,6 +1,7 @@
> ;;; GNU Guix --- Functional package management for GNU
> ;;; Copyright © 2016 David Craven <david@craven.ch>
> ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
> +;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -181,8 +182,8 @@ and LICENSE."
> ;; This regexp matches that.
> (make-regexp "^(.*) OR (.*)$"))
>
> -(define (crate->guix-package crate-name)
> - "Fetch the metadata for CRATE-NAME from crates.io, and return the
> +(define (crate->guix-package crate-name@version)
> + "Fetch the metadata for CRATE-NAME@VERSION from crates.io, and return the

The idea is that the (guix import …) modules do not contain UI-related
stuff, and that UI-related stuff is instead isolated in (guix scripts
import …).

Thus, splitting the “crate@version” string should happen in (guix
scripts import crate) rather than in this module.

Instead, you could simply change ‘crate->guix-package’ so that it takes
an optional ‘version’ field:

(define* (crate->guix-package crate-name #:optional version)
…)

In a second step, you’d change (guix scripts import crate) so that it
passes that version string to ‘crate->guix-package’.

How does that sound?

Toggle quote (19 lines)
> + (define crate-name-version-list
> + (let ((lnv (string-split crate-name@version #\@)))
> + (if (= 1 (length lnv))
> + (append lnv '(#f))
> + lnv)))
> +
> + (define crate-name
> + (car crate-name-version-list))
> +
> +
> (define crate
> (lookup-crate crate-name))
>
> + (define crate-version-string
> + (let ((version (cadr crate-name-version-list)))
> + (if version
> + version
> + (crate-latest-version crate))))

We have a policy of not using ‘cadr’ and friends:


So the code above would typically look like:

(define-values (name version)
(match (string-split crate-spec #\@)
((name version) (values name version))
((name) (values name #f))))

Could you send an updated patch (actually two patches)?

Thanks for working on the importer!

Ludo’.
L
L
Ludovic Courtès wrote on 8 Sep 2019 14:28
control message for bug #37322
(address . control@debbugs.gnu.org)
875zm39dlv.fsf@gnu.org
merge 37322 37323
quit
M
M
Martin Becze wrote on 9 Sep 2019 17:32
Re: [bug#37322] [PATCH 1/2] adds the capability of importing a specified version to the crate importer
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37322@debbugs.gnu.org)
cf9e44fe-ec28-eb40-78e1-4e147a4da8db@riseup.net
yep! thats the idea. I'll fix up the guile soon.

On 9/8/19 2:27 PM, Ludovic Courtès wrote:
Toggle quote (79 lines)
> Hello Martin,
>
> So the goal is to allow users to run “guix import rust-foo@1.2.3”,
> right? That’s a good idea.
>
> Martin Becze <mjbecze@riseup.net> skribis:
>
>> diff --git a/guix/import/crate.scm b/guix/import/crate.scm
>> index f6057dbf8b..3266ebdfec 100644
>> --- a/guix/import/crate.scm
>> +++ b/guix/import/crate.scm
>> @@ -1,6 +1,7 @@
>> ;;; GNU Guix --- Functional package management for GNU
>> ;;; Copyright © 2016 David Craven <david@craven.ch>
>> ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
>> +;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -181,8 +182,8 @@ and LICENSE."
>> ;; This regexp matches that.
>> (make-regexp "^(.*) OR (.*)$"))
>>
>> -(define (crate->guix-package crate-name)
>> - "Fetch the metadata for CRATE-NAME from crates.io, and return the
>> +(define (crate->guix-package crate-name@version)
>> + "Fetch the metadata for CRATE-NAME@VERSION from crates.io, and return the
> The idea is that the (guix import …) modules do not contain UI-related
> stuff, and that UI-related stuff is instead isolated in (guix scripts
> import …).
>
> Thus, splitting the “crate@version” string should happen in (guix
> scripts import crate) rather than in this module.
>
> Instead, you could simply change ‘crate->guix-package’ so that it takes
> an optional ‘version’ field:
>
> (define* (crate->guix-package crate-name #:optional version)
> …)
>
> In a second step, you’d change (guix scripts import crate) so that it
> passes that version string to ‘crate->guix-package’.
>
> How does that sound?
>
>> + (define crate-name-version-list
>> + (let ((lnv (string-split crate-name@version #\@)))
>> + (if (= 1 (length lnv))
>> + (append lnv '(#f))
>> + lnv)))
>> +
>> + (define crate-name
>> + (car crate-name-version-list))
>> +
>> +
>> (define crate
>> (lookup-crate crate-name))
>>
>> + (define crate-version-string
>> + (let ((version (cadr crate-name-version-list)))
>> + (if version
>> + version
>> + (crate-latest-version crate))))
> We have a policy of not using ‘cadr’ and friends:
>
> https://guix.gnu.org/manual/en/html_node/Data-Types-and-Pattern-Matching.html
>
> So the code above would typically look like:
>
> (define-values (name version)
> (match (string-split crate-spec #\@)
> ((name version) (values name version))
> ((name) (values name #f))))
>
> Could you send an updated patch (actually two patches)?
>
> Thanks for working on the importer!
>
> Ludo’.
M
M
Martin Becze wrote on 9 Sep 2019 17:36
[PATCH v2 1/2] added versoining to crate import
(name . Martin Becze)(address . mjbecze@riseup.net)
20190909153605.1484-1-mjbecze@riseup.net
---
guix/import/crate.scm | 12 +++++++++---
guix/scripts/import/crate.scm | 10 +++++++++-
2 files changed, 18 insertions(+), 4 deletions(-)

Toggle diff (84 lines)
diff --git a/guix/import/crate.scm b/guix/import/crate.scm
index f6057dbf8b..de56432e3c 100644
--- a/guix/import/crate.scm
+++ b/guix/import/crate.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,8 +182,8 @@ and LICENSE."
;; This regexp matches that.
(make-regexp "^(.*) OR (.*)$"))
-(define (crate->guix-package crate-name)
- "Fetch the metadata for CRATE-NAME from crates.io, and return the
+(define (crate->guix-package crate-name version)
+ "Fetch the metadata for CRATE-NAME@VERSION from crates.io, and return the
`package' s-expression corresponding to that package, or #f on failure."
(define (string->license string)
(match (regexp-exec %dual-license-rx string)
@@ -196,10 +197,15 @@ and LICENSE."
(define crate
(lookup-crate crate-name))
+ (define crate-version-string
+ (if version
+ version
+ (crate-latest-version crate)))
+
(and crate
(let* ((version (find (lambda (version)
(string=? (crate-version-number version)
- (crate-latest-version crate)))
+ crate-version-string))
(crate-versions crate)))
(dependencies (crate-version-dependencies version))
(dep-crates (filter normal-dependency? dependencies))
diff --git a/guix/scripts/import/crate.scm b/guix/scripts/import/crate.scm
index cab9a4397b..948b90ec15 100644
--- a/guix/scripts/import/crate.scm
+++ b/guix/scripts/import/crate.scm
@@ -2,6 +2,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <davet@gnu.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
+;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -66,6 +67,7 @@ Import and convert the crate.io package for PACKAGE-NAME.\n"))
;;;
(define (guix-import-crate . args)
+
(define (parse-options)
;; Return the alist of option values.
(args-fold* args %options
@@ -75,6 +77,7 @@ Import and convert the crate.io package for PACKAGE-NAME.\n"))
(alist-cons 'argument arg result))
%default-options))
+
(let* ((opts (parse-options))
(args (filter-map (match-lambda
(('argument . value)
@@ -83,7 +86,12 @@ Import and convert the crate.io package for PACKAGE-NAME.\n"))
(reverse opts))))
(match args
((package-name)
- (let ((sexp (crate->guix-package package-name)))
+ (define-values (name version)
+ (match (string-split package-name #\@)
+ ((name version) (values name version))
+ ((name) (values name #f))))
+
+ (let ((sexp (crate->guix-package name version)))
(unless sexp
(leave (G_ "failed to download meta-data for package '~a'~%")
package-name))
--
2.23.0
L
L
Ludovic Courtès wrote on 10 Sep 2019 00:38
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 37322-done@debbugs.gnu.org)
877e6hxfgl.fsf@gnu.org
Hi Martin,

Martin Becze <mjbecze@riseup.net> skribis:

Toggle quote (5 lines)
> ---
> guix/import/crate.scm | 12 +++++++++---
> guix/scripts/import/crate.scm | 10 +++++++++-
> 2 files changed, 18 insertions(+), 4 deletions(-)

Pushed as fd63ecbe050bf8fa7c8ff0a003d56cce97b6ded1. I tweaked quite a
few things, mostly for cosmetic reasons, and added a commit log that
follows our conventions. Please take a look!

Thank you,
Ludo’.
Closed
?