[PATCH 0/3] Add learn-to-type programs

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 10 Sep 2019 11:50
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190910095008.23860-1-efraim@flashner.co.il
I was looking for a learn-to-type program for my daughter and I found
klavaro and ktouch. Of the two I think I like ktouch better, but in any
case here they are.

Efraim Flashner (3):
gnu: Add klavaro.
gnu: Add kqtquickcharts.
gnu: Add ktouch.

gnu/packages/education.scm | 101 ++++++++++++++++++++++++++++++++++++-
gnu/packages/kde.scm | 24 +++++++++
2 files changed, 124 insertions(+), 1 deletion(-)

--
2.23.0
E
E
Efraim Flashner wrote on 10 Sep 2019 11:52
[PATCH 1/3] gnu: Add klavaro.
(address . 37367@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190910095231.24326-1-efraim@flashner.co.il
* gnu/packages/education.scm (klavaro): New variable.
---
gnu/packages/education.scm | 29 ++++++++++++++++++++++++++++-
1 file changed, 28 insertions(+), 1 deletion(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 240fc4acd8..0ec1de7b75 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -520,3 +520,30 @@ minutes. For simpler timetables, it may take a shorter time, under
difficult timetables, it may take a longer time, a matter of hours.")
(license license:agpl3+)))
+(define-public klavaro
+ (package
+ (name "klavaro")
+ (version "3.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "12gml7h45b1w9s318h0d5wxw92h7pgajn2kh57j0ak9saq0yb0wr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("pango" ,pango)))
+ (home-page "https://klavaro.sourceforge.io/en/index.html")
+ (synopsis "Touch typing tutor")
+ (description
+ "Klavaro is a simple tutor to teach correct typing, almost independently of
+language and very flexible regarding to new or unknown keyboard layouts.")
+ (license license:gpl3+)))
--
2.23.0
E
E
Efraim Flashner wrote on 10 Sep 2019 11:52
[PATCH 2/3] gnu: Add kqtquickcharts.
(address . 37367@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190910095231.24326-2-efraim@flashner.co.il
* gnu/packages/kde.scm (kqtquickcharts): New variable.
---
gnu/packages/kde.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f2261f7f98..c80da7d796 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -602,3 +602,27 @@ communicate with each other. Here's a few things KDE Connect can do:
@end enumerate")
(properties `((upstream-name . "kdeconnect-kde")))
(license (list license:gpl2 license:gpl3)))) ; dual licensed
+
+(define-public kqtquickcharts
+ (package
+ (name "kqtquickcharts")
+ (version "19.08.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/"
+ version "/src/kqtquickcharts-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j3rivvh4sa94lsd0hi4xfvcikl05zrqd7634wxyaxs718ais6dg"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
+ (synopsis "Interactive charts for Qt Quick")
+ (description
+ "A QtQuick plugin to render beautiful and interactive charts.")
+ (license license:lgpl2.1+)))
--
2.23.0
E
E
Efraim Flashner wrote on 10 Sep 2019 11:52
[PATCH 3/3] gnu: Add ktouch.
(address . 37367@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190910095231.24326-3-efraim@flashner.co.il
* gnu/packages/education.scm (ktouch): New variable.
---
gnu/packages/education.scm | 72 ++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)

Toggle diff (89 lines)
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 0ec1de7b75..3181746282 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages javascript)
+ #:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -547,3 +548,74 @@ difficult timetables, it may take a longer time, a matter of hours.")
"Klavaro is a simple tutor to teach correct typing, almost independently of
language and very flexible regarding to new or unknown keyboard layouts.")
(license license:gpl3+)))
+
+(define-public ktouch
+ (package
+ (name "ktouch")
+ (version "19.08.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/"
+ version "/src/ktouch-" version ".tar.xz"))
+ (sha256
+ (base32
+ "19rdk94pls75hdvx11hnfk3qpm6l28p9q45q5f04sknxagrfaznr"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:modules ((guix build cmake-build-system)
+ (guix build qt-utils)
+ (guix build utils))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build qt-utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'patch-makefiles
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((qtdec (assoc-ref inputs "qtdeclarative")))
+ (substitute* '("src/CMakeFiles/ktouch_autogen.dir/build.make"
+ "src/CMakeFiles/ktouch.dir/build.make")
+ (("/gnu/store/.*qmlcachegen")
+ (string-append qtdec "/bin/qmlcachegen"))))
+ #t))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-qt-program out "ktouch"))
+ #t)))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kcmutils" ,kcmutils)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdeclarative" ,kdeclarative)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kitemviews" ,kitemviews)
+ ("kqtquickcharts" ,kqtquickcharts)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("libxcb" ,libxcb)
+ ("libxkbfile" ,libxkbfile)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtx11extras" ,qtx11extras)
+ ("qtxmlpatterns" ,qtxmlpatterns)))
+ (home-page "https://edu.kde.org/ktouch/")
+ (synopsis "Touch typing tutor")
+ (description
+ "KTouch is an aid for learning how to type with speed and accuracy. It
+provides a sample text to type and indicates which fingers should be used for
+each key. A collection of lessons are included for a wide range of different
+languages and keyboard layouts, and typing statistics are used to dynamically
+adjust the level of difficulty.")
+ (license license:gpl2)))
--
2.23.0
L
L
Ludovic Courtès wrote on 16 Sep 2019 10:33
Re: [bug#37367] [PATCH 2/3] gnu: Add kqtquickcharts.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 37367@debbugs.gnu.org)
871rwgej2s.fsf@gnu.org
Hello Efraim,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (5 lines)
> + (synopsis "Interactive charts for Qt Quick")
> + (description
> + "A QtQuick plugin to render beautiful and interactive charts.")

Nitpick: please write a full sentence here.

Other than that the 3 patches LGTM, thanks!

Ludo’.
E
E
Efraim Flashner wrote on 16 Sep 2019 14:05
Re: [PATCH 0/3] Add learn-to-type programs
(address . 37367-done@debbugs.gnu.org)
20190916120527.GE499@E5400
patches pushed

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl1/eocACgkQQarn3Mo9
g1F+uRAAsm7T5xqStdmQ9Xy3v7eScPyUZKR1d43Y/b4PC4OwO/5vB0QwUaOVdjC3
5CJqZfi2TYnBQsgwo2KtyxZqvXOxCz65smXw0UcuHtcAATlffNo8BtdTaJ0WOsCV
gRAEEM2jDSqf/aN46HkZivGzq35f3FCqjv2ra6rtYUa/APXcU2Wp5HvcZeCKhZG4
+Xbk95ETdJ19bWvg8yLCN84nX4eWPsSae5iOK8SO5IT6euMdH6rrchBk/al6b3DZ
19fQm378mHa/nip4CgD0JNhSs7QJMRqZxCKDxbQIkRQAnMqrhR3g2wgznj4yeyjF
TT7k6rr6THI0uy52g3w96wl2FrD3kg31PEU3S7e1ZuqfCqHG4QdoDssMYyduLl1E
w+EGbGJc6KS60zxD1VKCwB1IeDwQqrdeg2Dn9ZkZRqVFadey1ayaS4Tq96PRlRf5
QASgAtpVY7XjLE3fnQ/ogKUlnhtEx6U6pvBXO9zZ8fh7xlC1O0+7czwjfZTrswtS
+uGSK2e5FflIM2K1V2YeDUbKjvhwq+fEe9gZK9m8gtxU7iuy1jNT291SKsZYT5yE
YpvohLci0QT7KogJ6Vj/63e4e+Ii2E6yV1DpO4s3RAfGGgfxuqTArMAtOp1mDb4z
PRWMKU/5y/LrRXUfI/LCWPSoVfUBLdhP57ZROlNpfrrguEgnbEM=
=NgDd
-----END PGP SIGNATURE-----


Closed
?