[PATCH] gnu: Add openscad.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Steve Sprang
Owner
unassigned
Submitted by
Steve Sprang
Severity
normal
S
S
Steve Sprang wrote on 11 Sep 2019 01:47
(address . guix-patches@gnu.org)
CA+xn8YC4ibPcHXJRa7i518mNfCs8bbfN_Q5Og5EuFEY_Hfuohw@mail.gmail.com
There is a lint complaint that the "source [is] not archived on
Software Heritage". I'm not sure if that's something that I need to
remedy or not.
From 20cbcd57a23a4acac83257817df0baeb3232695d Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Tue, 10 Sep 2019 16:22:57 -0700
Subject: [PATCH] gnu: Add openscad.

* gnu/packages/engineering.scm (openscad): New variable.
---
gnu/packages/engineering.scm | 69 ++++++++++++++++++++++++++++++++++++
1 file changed, 69 insertions(+)

Toggle diff (93 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7f5409c835..9852aaf667 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages groff)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -89,6 +90,7 @@
#:use-module (gnu packages tex)
#:use-module (gnu packages version-control)
#:use-module (gnu packages wxwidgets)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
(define-public librecad
@@ -2145,3 +2147,70 @@ well as conversion and validation tools for input and output data. The
specification can be downloaded at @url{http://3mf.io/specification/}.")
(home-page "https://3mf.io/")
(license license:bsd-2)))
+
+(define-public openscad
+ (package
+ (name "openscad")
+ (version "2019.05")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://files.openscad.org/openscad-" version
+ ".src.tar.gz"))
+ (sha256
+ (base32
+ "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("cgal" ,cgal)
+ ("double-conversion" ,double-conversion)
+ ("eigen" ,eigen)
+ ("fontconfig" ,fontconfig)
+ ("glew" ,glew)
+ ("gmp" ,gmp)
+ ("harfbuzz" ,harfbuzz)
+ ("lib3mf" ,lib3mf)
+ ("libxml2" ,libxml2)
+ ("libzip" ,libzip)
+ ("mpfr" ,mpfr)
+ ("opencsg" ,opencsg)
+ ("qscintilla" ,qscintilla)
+ ("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("gnu-gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)
+ ("which" ,which)
+ ;; the following are only needed for tests
+ ("imagemagick" ,imagemagick)
+ ("ps" ,procps)
+ ("python" ,python)
+ ("xvfb" ,xorg-server)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "qmake"
+ (string-append "PREFIX=" (assoc-ref outputs "out")))
+ #t))
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (invoke "cmake" ".")
+ (invoke "make")
+ (invoke "ctest"))
+ ;; strip python test files since lib dir ends up in out/share
+ (for-each delete-file
+ (find-files "libraries/MCAD" ".*\\.py"))
+ #t)))))
+ (synopsis "Script-based 3D modeling application")
+ (description
+ "OpenSCAD is a 3D Computer-aided Design (CAD) application. Unlike an
+interactive modeler, OpenSCAD generates 3D models from a script, giving you
+full programmatic control over your models.")
+ (home-page "https://www.openscad.org/")
+ (license license:gpl2+)))
--
2.23.0
E
E
Efraim Flashner wrote on 11 Sep 2019 09:57
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 37372@debbugs.gnu.org)
20190911075757.GK977@E5400
On Tue, Sep 10, 2019 at 04:47:00PM -0700, Steve Sprang wrote:
Toggle quote (4 lines)
> There is a lint complaint that the "source [is] not archived on
> Software Heritage". I'm not sure if that's something that I need to
> remedy or not.

I've been seeing it a bunch too lately. I know it was added more
explicitly as a check although I'm not sure if they're false positives
or if it's really missing. Either way, it's not something to worry about
at this point.

Toggle quote (70 lines)
> From 20cbcd57a23a4acac83257817df0baeb3232695d Mon Sep 17 00:00:00 2001
> From: Steve Sprang <scs@stevesprang.com>
> Date: Tue, 10 Sep 2019 16:22:57 -0700
> Subject: [PATCH] gnu: Add openscad.
>
> * gnu/packages/engineering.scm (openscad): New variable.
> ---
> gnu/packages/engineering.scm | 69 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 69 insertions(+)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 7f5409c835..9852aaf667 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -65,6 +65,7 @@
> #:use-module (gnu packages glib)
> #:use-module (gnu packages gnome)
> #:use-module (gnu packages gperf)
> + #:use-module (gnu packages graphics)
> #:use-module (gnu packages groff)
> #:use-module (gnu packages gtk)
> #:use-module (gnu packages guile)
> @@ -89,6 +90,7 @@
> #:use-module (gnu packages tex)
> #:use-module (gnu packages version-control)
> #:use-module (gnu packages wxwidgets)
> + #:use-module (gnu packages xml)
> #:use-module (gnu packages xorg))
>
> (define-public librecad
> @@ -2145,3 +2147,70 @@ well as conversion and validation tools for input and output data. The
> specification can be downloaded at @url{http://3mf.io/specification/}.")
> (home-page "https://3mf.io/")
> (license license:bsd-2)))
> +
> +(define-public openscad
> + (package
> + (name "openscad")
> + (version "2019.05")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://files.openscad.org/openscad-" version
> + ".src.tar.gz"))
> + (sha256
> + (base32
> + "0nbgk5q5pgnw53la0kccdcpz2f4xf6d6076rkn0q08z57hkc85ha"))))
> + (build-system cmake-build-system)
> + (inputs
> + `(("boost" ,boost)
> + ("cgal" ,cgal)
> + ("double-conversion" ,double-conversion)
> + ("eigen" ,eigen)
> + ("fontconfig" ,fontconfig)
> + ("glew" ,glew)
> + ("gmp" ,gmp)
> + ("harfbuzz" ,harfbuzz)
> + ("lib3mf" ,lib3mf)
> + ("libxml2" ,libxml2)
> + ("libzip" ,libzip)
> + ("mpfr" ,mpfr)
> + ("opencsg" ,opencsg)
> + ("qscintilla" ,qscintilla)
> + ("qtbase" ,qtbase)
> + ("qtmultimedia" ,qtmultimedia)))
> + (native-inputs
> + `(("bison" ,bison)
> + ("flex" ,flex)
> + ("gnu-gettext" ,gnu-gettext)

This should be gnu-gettext-minimial

Toggle quote (21 lines)
> + ("pkg-config" ,pkg-config)
> + ("which" ,which)
> + ;; the following are only needed for tests
> + ("imagemagick" ,imagemagick)
> + ("ps" ,procps)
> + ("python" ,python)
> + ("xvfb" ,xorg-server)))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (replace 'configure
> + (lambda* (#:key outputs #:allow-other-keys)
> + (invoke "qmake"
> + (string-append "PREFIX=" (assoc-ref outputs "out")))
> + #t))
> + (replace 'check
> + (lambda _
> + (with-directory-excursion "tests"
> + (invoke "cmake" ".")
> + (invoke "make")

I know it wouldn't get rid of all the changes to the 'check phase, but
is there a make-flag that would have it also build the tests? something
like "-DENABLE_TESTS=ON"?

Toggle quote (17 lines)
> + (invoke "ctest"))
> + ;; strip python test files since lib dir ends up in out/share
> + (for-each delete-file
> + (find-files "libraries/MCAD" ".*\\.py"))
> + #t)))))
> + (synopsis "Script-based 3D modeling application")
> + (description
> + "OpenSCAD is a 3D Computer-aided Design (CAD) application. Unlike an
> +interactive modeler, OpenSCAD generates 3D models from a script, giving you
> +full programmatic control over your models.")
> + (home-page "https://www.openscad.org/")
> + (license license:gpl2+)))
> --
> 2.23.0
>


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl14qQUACgkQQarn3Mo9
g1H84w/8CgbjCLLEPejf84Ja6CWZ39aCSPIMEEPv+/oWVtooK2u45iaP0gjPugTo
mj9ch7mdj7H/mgHx2L4VyY5Ocm1nQB/Oy8GWu824yZ1OyOyooZb8GFQXBRn6LJ4l
j7+c/OpYYs8bOn3uaspCA00Ty9XxbqLVOXLEuZLFtlIQeyjlDhqE+mGblj2QhGCt
WiqT65+l0g/lb/Kdx2drIaaaJgPWQBqvTYrRRiG+A+8t263PYjqH9yRqHvNMl1/J
9BNaEW3oVz3CnsKUiu6i1s4Ium9moAgR/qPzZOUD49r57wCVfGlo/oFboOkFANCb
V6sjf2c5h5cXi+78bR3fSKy5IwnAF2iUdC2vRRiu/HWZvZ0OSY7rDPiV3cN+qW7I
jY92hCbag5G7agLSOr4z8oI0RdNgH8fgwLbB+bWHgIufiB3cHREKQCeU+a3S+iON
qC17cXTQ9orRxBL8FsfNeAsSPZTbQrDtbVY2CS0ffaGBifg3gnPzo0uG+MUIjAAf
dqpD0vSMC4eoFV70r+ZI2hSXjyN/BPFpT0CkUcxs9wXFpAzGNBYvze5KOquHEuxp
NFGXexwaPgN8DuuknU57EwO41FQ+YX4NDx6Q/dMLsZsg580PPX0ghXtKCxZ9geXQ
XVnkP2ubqxtdoB5ezgJ/tZbeNxUkFuUY21p8i9oM0hwyFq7uEv0=
=TCW/
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 11 Sep 2019 11:08
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 37372-done@debbugs.gnu.org)
20190911090808.GL977@E5400
Attachment: file
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl14uXgACgkQQarn3Mo9
g1EiTw//ct1m3FP1IdN7iqOqM7a8E5abcHabr3rsYt1cAWE7bfk43I/TZcyNVU0G
CqbLoiaHX/+rTsnCry0qAKRu14ivqiDlh+OPPEXk8ggYJ7uy14zabBQ/Lur/wOqh
nMQ/n7LS92jQqvWXZ5AhIAy1fNT/2nllCTWJlR1ByI/nS8ceMcnlvT8ziFddSURI
htuNO904oFky0KnHDEB5eLqkLjW35jQx9JCw65lxV7o5NMxjN9kZCyLLojuhFQtz
KzusVR1u0v3/5/OEAVTfk41I9jmgj8syxOVUC2JcCDPxyK7aU306Cw3qWNFIhcJ+
PwFbZYuIr92T5Ndm43Ij67LbhgtvGhOHQ+F5jjUGSgVF9YR/nLoryfz9lUYOw2j6
0a8vPUrNusPFc7yWmAWxqa3gc6+6zDvR74SttU7hcLRLO5rPObB8WI/i1uVY0K+w
h6pQmpvnaXNFM35uvAVW07stMtaD8yV2hnHiCQWXSgpzj7CmS7QtdLjlOzXMWV2r
9Cg3fJs+Pz+sUTkDz1rfdMKrm1/nwXC9rYm97BKnCu75O4M2hir9AuGXM+44Ss0+
fIjZLt/84dpIaXvrgee8NfQ/tgJO7QfRncRIJdWde/LY5156SR9EhjcGQ8pLWCBh
+/2q98icth8VZTLGSbs5F9PRIjO/SDrkpxw6oKEn3iTNT/NutIM=
=WAcv
-----END PGP SIGNATURE-----


Closed
?