[PATCH] gnu: guile-email: Add phase to patch the module directory.

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 15 Sep 2019 14:33
(address . guix-patches@gnu.org)
20190915123331.22860-1-mail@cbaines.net
Otherwise the .go files appear within share, and Guile doesn't find them. With
this patch they appear in lib within the output. One thing this means is that
stack traces include the filenames.

* gnu/packages/guile-xyz.scm (guile-email)[arguments]: Add 'patch-module-dir
phase.
---
gnu/packages/guile-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b765ef36e1..4fa2759205 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -927,7 +927,16 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
(inputs
`(("guile" ,guile-2.2)))
(arguments
- '(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-module-dir
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^godir = ([[:graph:]]+)")
+ "godir = \
+$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
+ #t)))))
(home-page "https://guile-email.systemreboot.net")
(synopsis "Guile email parser")
(description "guile-email is a collection of email utilities implemented
--
2.23.0
L
L
Ludovic Courtès wrote on 16 Sep 2019 09:56
(name . Christopher Baines)(address . mail@cbaines.net)(address . 37409@debbugs.gnu.org)
878sqofzdc.fsf@gnu.org
Hello,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> Otherwise the .go files appear within share, and Guile doesn't find them. With
> this patch they appear in lib within the output. One thing this means is that
> stack traces include the filenames.
>
> * gnu/packages/guile-xyz.scm (guile-email)[arguments]: Add 'patch-module-dir
> phase.

LGTM!

Ludo’.
A
A
Arun Isaac wrote on 16 Sep 2019 10:37
(name . Christopher Baines)(address . mail@cbaines.net)(address . 37409@debbugs.gnu.org)
cu736gwab70.fsf@systemreboot.net
Toggle quote (4 lines)
> Otherwise the .go files appear within share, and Guile doesn't find them. With
> this patch they appear in lib within the output. One thing this means is that
> stack traces include the filenames.

LGTM! I'll also make this modification to guile-email upstream so this
phase won't be necessary after the next update of guile-email.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl1/SdMACgkQLiXui2GA
K7O9PwgArH2Rsc5QXn3OBmtrwhwbR2XPKuQIsWfuGXhkVl1rlxuMMTSmlRIQDGD4
CRfzuK28ZI3+YNKgYVH2+vzZozM1dKmiCNhvMSW9dETZn/MBfhkRgw3c45hpmK+n
UZ3/mD9sbKpLC/vA0HbQ3grhh6SG6u7JHteiS3v6PCxYMEMLq4zZN3TX+NjviSSB
Zpu9CZDLSGfcKYhoo/HwexzvFRJ63+erM4GdU/QU3+Rje39nUuScY3ulJO9tXb2u
Kw5ZSE1pPoNUHlBSwMOMWaCarJTL19Gcqr9tp95/Ws3wWGrSmWUPyXHLDkvZC5S/
fgWxR4znGPHghdprYUt61qELGO6JzQ==
=uzq/
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 21 Sep 2019 18:37
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 37409@debbugs.gnu.org)
87lfuh1u7s.fsf@cbaines.net
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (7 lines)
>> Otherwise the .go files appear within share, and Guile doesn't find them. With
>> this patch they appear in lib within the output. One thing this means is that
>> stack traces include the filenames.
>
> LGTM! I'll also make this modification to guile-email upstream so this
> phase won't be necessary after the next update of guile-email.

Awesome, thanks Arun :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2GUcdfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfsKQ/9ELp4kHhVpbUzkBZS5T0MhOGM3pjC2MELW6c7v2i78JclY9RXnI6jq7Ca
ttrMwegsWGX1Wl1xwK7IPEoVi8Ux+qrAtl+0OdUOafFN0XvmV15nUpek/fHqtUn1
HCeFtkycuRWavpT3z5RovVXHilGevGgnwypKgVQeNXeufbXQ/vEDno0p7iTzTWky
ZdY5xIrBCGK2GeuL+2TzktOs3JuYHo09n8K0A9Trfi3kv65KWqKvWjYp2aLxxCa7
WdU8phtBeLLDh/cyUW1uc0krgUjC4XFWNWuJMa4EJ3eu0x4Y9F6wqnu+JDtuAjIp
8bgNHTabI+m20xObojypXyxFNCBFb/V5wB+nPbLrvVFdeligBpwfBUJzG/NNt6zL
2r6ojneNbfzVSrJtiuFIuTkx7MeBL8XSGmnTZtfywpfFx6X2u2QmPKgT6+A5sO66
vyIxLKxP7HGfSzmYwoV84eHMofH7KvCy0YQh5jGGVEdM0FoOZ7gv9pfyBy49UNcp
rd8JneswxPoVyIZHKOH1YZQlVntTXoWCXE4vP0brz85ntTjMG3r649sLVXFP1buL
8hWEECRpahAqP682dX2OVvz1NKH+HRyW/HEPfbIigcDvCjUjwwhpP7jtki65c+v4
hJKlRRAOmgkDB9pZFigsqhRt8LtzJuD7g64kCGlO9HM+bGIpYks=
=emgE
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 21 Sep 2019 18:37
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37409-done@debbugs.gnu.org)
87muex1u8c.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (13 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Otherwise the .go files appear within share, and Guile doesn't find them. With
>> this patch they appear in lib within the output. One thing this means is that
>> stack traces include the filenames.
>>
>> * gnu/packages/guile-xyz.scm (guile-email)[arguments]: Add 'patch-module-dir
>> phase.
>
> LGTM!

Great, I've pushed this now (as
c219104c7803cd31ab1cf4bef142a8fbf8ed5b7a).
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2GUbNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xc4Mg/+J/CVkvJ5J8hxJa95mvfakraLuNV2ghOHHm5yxJah2U1fpX2eoDNwfigX
UQhcxvNs2m9Z4Gd4YTOyeKOnOM3posMCD8vLMY2Pdg/mxxIwaLINS3pbNpzxo5VY
7+/ZbZF0N/fPt8AGvvWCtkCGOT09bAeLLjvSWzi+Lr1PuaCQeEcuYTReLfapFkeB
j/RMXqwaPhpNfa9a8ZGrlDyg9HZdEm2sXSEKMwS3kqkKlmIiqML9KXBuQmMBDvXd
ny410CTZbuT5SGGXArYuDt5MAJVbCnQ+Y0F0NBTr2i8XwENUUXv4PGDh8Cji9wjf
ZYWG5WI7AJs1ez+X0X8M+DZTkZf9s4jNDMDVXOPfqOy+mtbglUkPIuhRLNYRqM4w
DTGxDon8n+8rEr4SA2WnprweZD/zR/ocZHuzg+3xYtU/ANSavCyv/qappBw15Prn
4XACZlRK5BP7OepfrIyj+lJ2iFmAryC1Bzobh2v0VpGjV0Ocz5opVVegdSKJnSmJ
pTq6brPG/Mihh8pvE/w6FVJpbT1uxMLqXdn6fwE8B98SnGp1MNGSvsXzpaHhGzAw
2yDgicqfqpTs63aBPJdmCHYOkEkVHlL4378OBNYdwotsxBRMV3xBmOaQyHrCGNNe
hVsyNDfiw+DfGliicO4v7VRn0Ce23RnPHTYbLf8jE+DqEsw+IC8=
=5fx0
-----END PGP SIGNATURE-----

Closed
?