[PATCH] import/github: Check for more version prefixes

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 17 Sep 2019 20:59
(address . guix-patches@gnu.org)
20190917185915.GA6057@E5400
'guix refresh openjpeg'
gnu/packages/image.scm:762:13: openjpeg would be upgraded from 2.3.1 to ersion.2.1

I checked the git repository, there are a number of tags reading
'version.2.1' or similar. This allows for version tags 'version2.1' or
'version-2.1' or 'version.2.1' or 'version→2.1'. (still looking for a
repo to test the last one)

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
From 1d32a908d3bdbec89420b638791960e7535a5e90 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 17 Sep 2019 21:50:36 +0300
Subject: [PATCH] import/github: Check for more version prefixes.

* guix/import/github.scm (latest-released-version): Allow the
version string to begin with the word 'version'.
---
guix/import/github.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (27 lines)
diff --git a/guix/import/github.scm b/guix/import/github.scm
index 55ea00a111..df5f6ff32f 100644
--- a/guix/import/github.scm
+++ b/guix/import/github.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -186,7 +187,12 @@ the package e.g. 'bedtools2'. Return #f if there is no releases"
(substring tag 0 (+ name-length 1))))
(substring tag (+ name-length 1)))
;; some tags start with a "v" e.g. "v0.25.0"
+ ;; or with the word "version" e.g. "version.2.1"
;; where some are just the version number
+ ((string-prefix? "version" tag)
+ (if (char-set-contains? char-set:digit (string-ref tag 7))
+ (substring tag 7)
+ (substring tag 8)))
((string-prefix? "v" tag)
(substring tag 1))
;; Finally, reject tags that don't start with a digit:
--
2.23.0
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2BLQMACgkQQarn3Mo9
g1EoWBAAvxj5ysN/xspN8oQvWGJKSHC00lx9+LwyPtMSVjy7UTlqpr8PreOdkpja
TPhd5inP0AZPRWnluxSWgsFLUL2DCQ/tMMAGRxvz5C4nJ2jscmIcOguk4pQb0vGO
kpVnV8YbcDfk9z+utAKmuU8XqWxNTJ8C69bxkwo5C1Y9J/3ZnkYyZcMKwlpeBRws
4iiLmgwMDrvyAX+aOnxJxKG0DsEiPGMy06i8shBAWAtW5NpHRWRpqFxIlOAqFC7P
MQrdXvOanRkVgoLUsWNMPk70ECBT8eJ960RhMgHAINNLvbmHKyCBs3Z3Wws1EWHG
6MAGWy2q/YSCcf2HyosgcN7+Z9RasD+E2nbL6uLdSdpVxwBupq4Gg6Tm4Al2vFWi
gEu/evT3yTIMzUUvqhrtFm0OQAM++8DVTnQoVaBumHFn+qOsgCTjSF+jY3njfe3S
phdp+aREOm/8yTFB1oL1jq1Z2ABlENI+QKRmYGvThK2DuJxo3iwiPe8L9I2kUHEc
avR8ibFiyP7rX4iGyWFNIFOJ1+k8vLoP+SZ0SLF+qpzShQ1ELtnVXcpg3+R/6t/q
sfBpYgGnWThnbqxTIzX+kH/RBSV7djNuSU7qXGjzQs6+fk9RAUBu6tK8rKtDhW4J
zZAcQQ6t/VBgiPBIJHoUJ9RyBfSG+0us5OEYH6fFYSCRrOgRoF0=
=koXf
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 19 Sep 2019 21:50
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 37442@debbugs.gnu.org)
87o8zgysjm.fsf@gnu.org
Hi!

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (3 lines)
> 'guix refresh openjpeg'
> gnu/packages/image.scm:762:13: openjpeg would be upgraded from 2.3.1 to ersion.2.1

Ouch.

Toggle quote (5 lines)
> I checked the git repository, there are a number of tags reading
> 'version.2.1' or similar. This allows for version tags 'version2.1' or
> 'version-2.1' or 'version.2.1' or 'version→2.1'. (still looking for a
> repo to test the last one)

:-)

Toggle quote (8 lines)
> From 1d32a908d3bdbec89420b638791960e7535a5e90 Mon Sep 17 00:00:00 2001
> From: Efraim Flashner <efraim@flashner.co.il>
> Date: Tue, 17 Sep 2019 21:50:36 +0300
> Subject: [PATCH] import/github: Check for more version prefixes.
>
> * guix/import/github.scm (latest-released-version): Allow the
> version string to begin with the word 'version'.

LGTM!

Thanks,
Ludo’.
E
E
Efraim Flashner wrote on 20 Sep 2019 08:07
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37442-done@debbugs.gnu.org)
20190920060745.GA16989@E5400
Thanks. Patch pushed.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2EbLEACgkQQarn3Mo9
g1HRaw/7BZuGpNsH+/dMwytGCyRT3yPc92CX35Ar3pdc04hwzO2AvNKTR7+QXANK
VOzkfEFisBMcRiPDshG52djQDrR3FVks1J+OaRROw5tZgsPygxXPtetE3qr2WAOA
sIcM6OKh1jAWC/dFER5xarfAaxmnucQR0LSma3DrozCZfPpOSyFljuSZYbW3JxQv
Y+L/PWiIAnXMvVw+oEnwdouonhtd8Qb2UfT/KQtRa1xpcNNHeR+5hz9JQvzLdgcs
uN2R3oQ+9Rl95Yb3/wAwVOVCQawWdnvPupfeVUNtZmJjvpRFwi18KdNjlaGhIBAF
olN+lkYdSV5BGlvJy1zJ/sZLzcD2GdSjbgR05BcJp1GKzAa30Wn920urMSdX1XFo
ak0ZJyY+UNudA1pf8Os5umpQnn8JCOxGmStyWV5oWAi9do/bvsYg/5Y8Kfk6ezn1
lFuy6XRr39VJO9ow275xVFyF70vTaCg1SpTIONVYnvi0nRq/dc5YezP1fZGiWegJ
95I8D+eMK0w0S13RFEuJHOyw3xBAgW1uJvgfg1hMSxmclhgEG/zICPTY8Y2u1cDr
KXYSAQ66NgfoOmfAbpKx9V48Tq/xcDQQzbJavbQUfdgahLEmyUVX0MhqTVyDDyUp
iJ/d2SwZKhE+/aVWUVmH6ScYtt+ECJbs+drmfu7RMorYwzZ5WqY=
=jHVZ
-----END PGP SIGNATURE-----


Closed
?