[PATCH] gnu: conky: Activate Pulseaudio support.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Vasile Dumitrascu
Owner
unassigned
Submitted by
Vasile Dumitrascu
Severity
normal
V
V
Vasile Dumitrascu wrote on 27 Sep 2019 22:32
(address . guix-patches@gnu.org)(name . Vasile Dumitrascu)(address . va511e@yahoo.com)
20190927203251.30974-1-va511e@yahoo.com
* gnu/packages/conky.scm (conky):
[inputs] Add pulseaudio.
---
gnu/packages/conky.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 681feb6e43..046d132a9b 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -2,6 +2,7 @@
;;; Copyright ?? 2015 Sini??a Bi??in <sinisa@bidin.eu>
;;; Copyright ?? 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright ?? 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright ?? 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages xorg))
(define-public conky
@@ -51,7 +53,8 @@
(arguments
`(#:tests? #f ; there are no tests
#:configure-flags
- (list "-DRELEASE=true")
+ (list "-DRELEASE=true"
+ "-DBUILD_PULSEAUDIO=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-freetype-to-search-path
@@ -76,6 +79,7 @@
("libxext" ,libxext)
("libxft" ,libxft)
("libxinerama" ,libxinerama)
+ ("pulseaudio", pulseaudio)
("lua" ,lua)
("ncurses" ,ncurses)
("curl" ,curl)))
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 28 Sep 2019 00:50
(name . Vasile Dumitrascu via Guix-patches)(address . guix-patches@gnu.org)
875zlde4m5.fsf@nckx
Vasile,

Vasile Dumitrascu via Guix-patches via ???
Toggle quote (9 lines)
> --- a/gnu/packages/conky.scm
> +++ b/gnu/packages/conky.scm
> @@ -2,6 +2,7 @@
> ;;; Copyright ?? 2015 Sini??a Bi??in <sinisa@bidin.eu>
> ;;; Copyright ?? 2018, 2019 Tobias Geerinckx-Rice
> <me@tobias.gr>
> ;;; Copyright ?? 2019 Pierre Neidhardt <mail@ambrevar.xyz>
> +;;; Copyright ?? 2019 Vasile Dumitrascu <va511e@yahoo.com>

Does this show up as corrupted in your mailbox as well? (‘??’
instead of ‘©’.)

Toggle quote (9 lines)
> @@ -76,6 +79,7 @@
> ("libxext" ,libxext)
> ("libxft" ,libxft)
> ("libxinerama" ,libxinerama)
> + ("pulseaudio", pulseaudio)
> ("lua" ,lua)
> ("ncurses" ,ncurses)
> ("curl" ,curl)))

I guess any hope of alphabetical ordering was lost long ago.

The change looks fine to me, but could you try fixing the text
encoding?

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl2OkiIACgkQ2Imw8BjF
STylCw/9G9JN3pwn00Alzus32FyAIyCs5SNc6dMTH8M1FgMz6rXElZ4iCCVLlpRn
oYtWZQ9qKZLw+h6BX73HJQM13OEIkwRlMerroB8DfA9sbcwIG2YttnqANzU8uovl
mKwiUnfUMawgR1L9lO5rHke4jzkB+AVoNe+Hs+xBcWbf+KgIdU83qLrqeJfIbi6Y
uWYfhW0oCdL/cEj16DaN5RbZsr6Y2oErG3DvczhwynqxkmPQBtbgwKcF5sJ2qdj+
G6u8+E6DIj1ZxVTWQhSnrdnPMhAV4q+kVDB+fwApFkMfS9kNcukV0ON1G1IPkqGK
07BM4AdTHFoqGIio9nAEcKUiqfuGGNWFqmkd55hxf+Ql3KlSxcmWIHac8IyqhM7e
UXr+FPEM1GZ5vbwPY+SKaAs/J7HEBPPUJr12A6h8lu+5wkG0ygJe1AGyHQeQbiZM
5k+F0oude9hFvyy6INDiJDAXz+GpA3ksO4mBH7iXihU3zMr5/PDlFxr0IFyQoxtu
tGszJkx9EWMAvQmIujhTmTYccBE/Nu23pVdVOvOrKK170s6dgMBNr9lOma8iKvmF
DfxBBX9PuiEx0VBujdvQcZyRprtfVDNxuLM9LzziS277eeyVYD6WpOQefU/sBxvP
NAhzFHQTj2BSZryFJFFdYAf9A+Gdnf5Dhf30LDE3DdJ1GvgAfuc=
=+k6/
-----END PGP SIGNATURE-----

D
D
Dumitrascu Vasile wrote on 28 Sep 2019 11:02
(address . 37534@debbugs.gnu.org)
1727802752.681659.1569661332406@mail.yahoo.com
  Hi Tobias
Thank you for the review and sorry to have missed the sorting.
I have re-attached the original patch as a file to this email, as I guess the encoding issues were caused by git send-mail.
  Thank you again,    Vasile

On Saturday, September 28, 2019, 12:50:15 AM GMT+2, Tobias Geerinckx-Rice <me@tobias.gr> wrote:
Vasile,

Vasile Dumitrascu via Guix-patches via ???
Toggle quote (9 lines)
> --- a/gnu/packages/conky.scm
> +++ b/gnu/packages/conky.scm
> @@ -2,6 +2,7 @@
>  ;;; Copyright ?? 2015 Sini??a Bi??in <sinisa@bidin.eu>
>  ;;; Copyright ?? 2018, 2019 Tobias Geerinckx-Rice
>  <me@tobias.gr>
>  ;;; Copyright ?? 2019 Pierre Neidhardt <mail@ambrevar.xyz>
> +;;; Copyright ?? 2019 Vasile Dumitrascu <va511e@yahoo.com>

Does this show up as corrupted in your mailbox as well?  (‘??’
instead of ‘©’.)

Toggle quote (9 lines)
> @@ -76,6 +79,7 @@
>        ("libxext" ,libxext)
>        ("libxft" ,libxft)
>        ("libxinerama" ,libxinerama)
> +      ("pulseaudio", pulseaudio)
>        ("lua" ,lua)
>        ("ncurses" ,ncurses)
>        ("curl" ,curl)))

I guess any hope of alphabetical ordering was lost long ago.

The change looks fine to me, but could you try fixing the text
encoding?

Thanks!

T G-R
Attachment: file
From ddd14f92faa6298f93ded11ff1f96b34f847a549 Mon Sep 17 00:00:00 2001
From: Vasile Dumitrascu <va511e@yahoo.com>
Date: Fri, 27 Sep 2019 22:32:05 +0200
Subject: [PATCH] gnu: conky: Activate Pulseaudio support.

* gnu/packages/conky.scm (conky):
[inputs] Add pulseaudio.
---
gnu/packages/conky.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 681feb6e43..046d132a9b 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2015 Siniša Bi?in <sinisa@bidin.eu>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages xorg))
(define-public conky
@@ -51,7 +53,8 @@
(arguments
`(#:tests? #f ; there are no tests
#:configure-flags
- (list "-DRELEASE=true")
+ (list "-DRELEASE=true"
+ "-DBUILD_PULSEAUDIO=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-freetype-to-search-path
@@ -76,6 +79,7 @@
("libxext" ,libxext)
("libxft" ,libxft)
("libxinerama" ,libxinerama)
+ ("pulseaudio", pulseaudio)
("lua" ,lua)
("ncurses" ,ncurses)
("curl" ,curl)))
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 1 Oct 2019 18:16
(address . 37534-done@debbugs.gnu.org)(name . Dumitrascu Vasile)(address . va511e@yahoo.com)
875zl8saov.fsf@nckx
Vasile,

Thanks for the patch! I've pushed it as
18edc9db02658c597695905121a9df68e9118ab8 with miniscule changes to
the commit message.

Dumitrascu Vasile ???
Toggle quote (3 lines)
> Hi Tobias
> Thank you for the review and sorry to have missed the sorting.

Oh, er, sorry you're sorry; no need to be. All I meant by ‘any
hope lost’ was that there's no way to make the entire list sorted
without moving unrelated lines around (e.g. curl). But your new
compromise is a better compromise. Thank you!

Toggle quote (3 lines)
> I have re-attached the original patch as a file to this email,
> as I guess the encoding issues were caused by git send-mail.

‘git send-email’ has one job, so it should do it really well. I
send all my patches in-line and have never had trouble.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl2Te+AACgkQ2Imw8BjF
STxHNQ/9G4cOojMmSCIqyaWYbVBh+ctfc22VyXhcI4wHm5ZbrMI4XNZLXMcydPIU
NElWqaPX1Jwhm1XeJHMEFBqt7Sk7ZXS2ATS5YPEb7sRxGL7Untdbn4gWQAcXBsSk
dfORi//sIT3t89MwgCLxnMqMjq/uduPclUI2/PZQjkWZoO3Q3QH7Ht0CKcHqVqWp
hyGnv916vDBdd7+rWJhtfR66v6/0bs5dtwW+49iDAifmdnjPC8UdIRb4j8QNZCwY
T6+sYwzzVVPfOUlbmdATOO6zUj7t0xlLnI6Zyq2re3Vbj1WdT4vFhOZ2uFxm4QxC
kp+CCa04nfwb9wK7XEAqqk+iAFn8eHkSt4Ne2r9bEXVzECOsBteM63xVTX7DuquT
kfUu4XeAAcBxVWxaqQI3wa+yYWxA22hcturFd2rMgzCSdxknpF4pOsGmiYm6IXtC
fZ09az1ExuV+NVvNp1HWwfsdh9QY/OuhZ9RMXzaLLGvSdCr9dlvU15wvDTWUy9u0
xGMN27qRfE85v1UrDX3xYgsbCO0yfbbRaCq/pDbF/XD24alcgt42pYMexiBawgqR
oSBUs1oq0fHYgJCQXkyKo8su8qqT/0s+lWKClClaE4Y2F6hbmwsmTrt78yb8y6hi
/1mU+XSGpj7vOOl0idnwmVbj3OW7jAgZJ9Du7DBN5ukh6tXtGsU=
=iZ9R
-----END PGP SIGNATURE-----

Closed
?