[PATCH] gnu: Add aha.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
Merged with
W
W
Wiktor ?elazny wrote on 3 Oct 2019 16:15
(address . guix-patches@gnu.org)
20191003141529.3940-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/textutils.scm (aha): new variable.
---
Hi, This is the first time that I’m submitting something that uses the
git-fetch method. I tried to follow the manual. Unfortunately, it does
not explain the role of this "0.9" string. I noticed that other
contributors use various values. I left it at "0.9".
gnu/packages/textutils.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 79cf172179..1bf5a4fb1b 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Yoshinori Arai <kumagusu08@gmail.com>
+;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1011,3 +1012,32 @@ instance one can add new syntax elements to markdown, etc.
This package provides Python bindings.")
(license license:bsd-3)))
+
+(define-public aha
+ (let ((commit "2592da4330b4df6d482a631f4a35543b96f4744d")
+ (revision "1")) ;Guix package revision
+ (package
+ (name "aha")
+ (version (git-version "0.9" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://github.com/theZiz/aha.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0fq81ibxqg27b3860wmqd4zym2mymkr7sgvfhsyl0kb7ck367w4q"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases (delete 'configure))
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:tests? #f)) ; no check target
+ (home-page "https://github.com/theZiz/aha")
+ (synopsis "Ansi HTML Adapter")
+ (description "@code{aha} converts ANSI escape sequences of a Unix terminal
+to HTML code.")
+ (license (list license:lgpl2.0+ license:mpl1.1)))))
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 3 Oct 2019 16:47
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 37603@debbugs.gnu.org)
87wodl51jo.fsf@nckx
Wiktor,

Thanks for the patch! This isn't a review, just an answer to your
question:

Wiktor ?elazny ???
Toggle quote (7 lines)
> Hi, This is the first time that I’m submitting something that
> uses the
> git-fetch method. I tried to follow the manual. Unfortunately,
> it does
> not explain the role of this "0.9" string. I noticed that other
> contributors use various values. I left it at "0.9".

It's not a random value; it's the last ‘real’ release, think of it
as ‘release 0.9 + some more commits that were needed for some
reason’. If the project has never seen a release, ‘0.0.0’ is
used. You'll find that this is quite common, too.

last release before this commit was ‘0.5’, so that's what you
should use.

However: we prefer packaging releases, not arbitrary commits. Why
not package 0.5? If it's because it's old (it is) and missing
cool features, consider asking the author to cut a new release.

Whatever the case, please note the reason in a comment: ‘The last
release 0.5 is missing the vital foo feature and/or crashes on
Fridays’.

Since I'm here (still not a review! :-):

Toggle quote (2 lines)
> + (revision "1")) ;Guix package revision

I know you probably copied this from elsewhere, but don't think
this comment adds anything.

Toggle quote (2 lines)
> + (url "git://github.com/theZiz/aha.git")

Please use https://instead of git://.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl2WCesACgkQ2Imw8BjF
STyjSQ/+MtkPQ6hJN21N4lwpr3CAgp0V2aR9hZL2VLSUPhsUsLdWyf22qCROAiV9
lodqm219qc0ATd+SAkC4EA0W6p8w+QecSP8C/PhklvjVChx3SyvguEENl1z0Y25E
oAiAWteURK2iKggwlHbJCMgOHpf8ok12IOEToOM+q5PNtfy57spqMG0IQox0ZZJq
YkDByqP+wLzY0cde71+Ajoj980FwMh1gr4HzyyWjoKrMOSDC3ya1apm/8f9PvEEc
KaPbw3XJwEIAbULVNms3lITshV2Sh7GjmV9JJu6Q8Xp8THlzFqw7gnJgHOE5MQNn
PZD4Tyet5r8YoaktBb0tbM8sli+0Ff9jwIkwJjt0lmsLydAJvUlKrdj03w4r6aCw
vuURIqQvbi+VhlSBtINTkns4I2ANi5Qi0Xcltp7puduADRdzROUT3MQvxOjAQkLs
vNBeqhvw7VmW3RepKAUjvF2fpeedXw8hOwhZ89uGNVlJxyDPAb8RDFPj68iTnLgL
QA6zCCBsG3Jc977R+NRaUiYe2hPOMiinGOnBwpDGWSu1d+qWd47FG/APlyl27oAK
vd34fVlO7yr5K4LhS0hQrZbozip8YRyqOvKY7StPw6ih/LrAuEpO4rke516SSqAF
LaJ7hGoXJqSROozPOsCacWLT3kKQZoDHfCAlOn9tzszVKNrmNsE=
=U5Lu
-----END PGP SIGNATURE-----

=
=
=?utf-8?q?Wiktor_=C5=BBelazny?= wrote on 4 Oct 2019 15:18
(address . 37603@debbugs.gnu.org)
20191004131857.r56nbbnqkst4zbuo@wz.localdomain
On Thu, Oct 03, 2019 at 04:47:07PM +0200, Tobias Geerinckx-Rice wrote:

Toggle quote (7 lines)
> Wiktor ?elazny ???
>
> > I tried to follow the manual. Unfortunately, it does not explain the
> > role of this "0.9" string.
>
> It's not a random value; it's the last ‘real’ release,

Hi Tobias,

Thank you for this explanation and for the other remarks. I noted them
down for future reference. The amended patch is on the way.

Have a nice weekend,

W?
-----BEGIN PGP SIGNATURE-----

iQKTBAABCgB9FiEEvcl0zdnJun12Glc9xzWoxqtgedUFAl2XRsFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldEJE
Qzk3NENERDlDOUJBN0Q3NjFBNTczREM3MzVBOEM2QUI2MDc5RDUACgkQxzWoxqtg
edUmtw//XTG0NVp9ZD6bTi2gjzaQ11unuV288Lces72f7fZ5194pIZDwEarb4UJb
9q6EzHeA4XumDrqeH00/2kttTzflmWKPEWOcClHe4WbFiv3VTuNQnA/Px8BUJEKZ
suBffZXkx9aF+X4gjH/0w28UC2iz+oM7NLrXSDL5zGrPpqbmKVHkETNZjBNfnAJK
fy7e273OXFbLwv29Ws/CKG8PNZPe6AoxuuzODlpPAcEadUwNn8asXvkhCs9+7skZ
7fLtHn8NhiBuFCIkBbNoO6sFiuvpGkUqXbKzgbriVzqNV7jhTdqX7PRYNPdbb7KJ
liX3hGNNZF7px4dU9tGq874XRpnjf5YOplHKtE5K9+yNxqbsO1j3ov6M2YHCj0Pn
B9F304CHQcNBmfIwOaMKFLNg3YnlvvXScpv0Z87Nt/cE6EsY9StPBnuKG2Tq8pOy
DeejpARVDCBrBRweT3yjETm4i62Rmyd/sGpsSctwjHomsZm5PfBOWlODu2R4Vv9G
7jr3neddrCdyZQv22h3Qp1c4CD/zV72x+UnunwW1mgmfoyYLnl8cAV8DEWXhYYh7
BstboQHTK23HD9NXQ1/Q8Lx4PSXfPyEXKukAom3i71lg9SdmK44mtkI72XInWfVv
4TEXilOWr40BNUOEtfY3GBWAFNUJjK4oET7V6VvmPQLmk+FoXcc=
=rNBp
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 6 Nov 2019 15:41
control message for bug #37603
(address . control@debbugs.gnu.org)
87d0e52hjt.fsf@gnu.org
merge 37603 37618
quit
?