[PATCH 0/1] gnu: Add python-httpie.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 4 Oct 2019 08:55
(name . Guix)(address . guix-patches@gnu.org)
20191004065520.tcuz74tsjgqfbh6q@rafflesia
Make the commands `http` available.

Warning: The tests attempt to access external web servers,
so we cannot run them.

--
Tanguy
T
T
Tanguy Le Carrour wrote on 4 Oct 2019 08:57
[PATCH 1/1] gnu: Add python-httpie.
(address . 37613@debbugs.gnu.org)
20191004065735.iy7j2at3h2l4cej7@rafflesia

From 8a60be6eb9ee4e17dc4fbc19ada22c7993841b26 Mon Sep 17 00:00:00 2001
From: "tanguy@bioneland.org" <tanguy@bioneland.org>
Date: Fri, 4 Oct 2019 08:44:59 +0200
Subject: [PATCH] gnu: Add python-httpie.

---
gnu/packages/python-web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e37ae94e18..b7d3b0aa73 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,6 +30,7 @@
;;; Copyright � 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright � 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright � 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright � 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -303,6 +304,32 @@ other HTTP libraries.")
(define-public python2-httplib2
(package-with-python2 python-httplib2))
+(define-public python-httpie
+ (package
+ (name "python-httpie")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpie" version))
+ (sha256
+ (base32
+ "103fcigpxf4nqmrdqjnyz7d9n4n16906slwmmqqc0gkxv8hnw6vd"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests attempt to access external web servers, so we cannot run them.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pygments" ,python-pygments)
+ ("python-requests" ,python-requests)))
+ (home-page "http://httpie.org/")
+ (synopsis
+ "HTTPie - a CLI, cURL-like tool for humans")
+ (description
+ "HTTPie - a CLI, cURL-like tool for humans.")
+ (license license:bsd-3)))
+
(define-public python-html2text
(package
(name "python-html2text")
--
2.23.0
T
T
T
Tanguy Le Carrour wrote on 14 Oct 2019 13:43
[PATCH] gnu: Add python-httpie.
(address . 37613@debbugs.gnu.org)
20191014114320.fmiev2vxisikagf7@rafflesia

From 13062545e9df7f9cab728f6ee17b572a88a11e31 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Fri, 4 Oct 2019 08:44:59 +0200
Subject: [PATCH] gnu: Add python-httpie.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/python-web.scm (python-httpie):�New public variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ffef3319f7..b980b83a70 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,6 +30,7 @@
;;; Copyright � 2019 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright � 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright � 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright � 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -303,6 +304,34 @@ other HTTP libraries.")
(define-public python2-httplib2
(package-with-python2 python-httplib2))
+(define-public python-httpie
+ (package
+ (name "python-httpie")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpie" version))
+ (sha256
+ (base32
+ "103fcigpxf4nqmrdqjnyz7d9n4n16906slwmmqqc0gkxv8hnw6vd"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests attempt to access external web servers, so we cannot run them.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-colorama" ,python-colorama)
+ ("python-pygments" ,python-pygments)
+ ("python-requests" ,python-requests)))
+ (home-page "https://httpie.org/")
+ (synopsis "cURL-like tool for humans")
+ (description
+ "A command line HTTP client with an intuitive UI, JSON support,
+syntax highlighting, wget-like downloads, plugins, and more. It consists of
+a single http command designed for painless debugging and interaction with
+HTTP servers, RESTful APIs, and web services.")
+ (license license:bsd-3)))
+
(define-public python-html2text
(package
(name "python-html2text")
--
2.23.0
O
O
Oleg Pykhalov wrote on 17 Oct 2019 22:13
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 37613@debbugs.gnu.org)
878spj6sfu.fsf@gmail.com
Hello,

Thank you for packaging this tool!

Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (33 lines)
> From 13062545e9df7f9cab728f6ee17b572a88a11e31 Mon Sep 17 00:00:00 2001
> From: Tanguy Le Carrour <tanguy@bioneland.org>
> Date: Fri, 4 Oct 2019 08:44:59 +0200
> Subject: [PATCH] gnu: Add python-httpie.
> MIME-Version: 1.0
> Content-Type: text/plain; charset=UTF-8
> Content-Transfer-Encoding: 8bit
>
> * gnu/packages/python-web.scm (python-httpie): New public variable.
> ---
> gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index ffef3319f7..b980b83a70 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -30,6 +30,7 @@
> ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
> ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
> +;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -303,6 +304,34 @@ other HTTP libraries.")
> (define-public python2-httplib2
> (package-with-python2 python-httplib2))
>
> +(define-public python-httpie
> + (package
> + (name "python-httpie")

[…]

LGTM.

What do you think about naming the package “httpie” instead, because
it's intended to run by calling ‘httpie’ command as in ‘youtube-dl’
package? I could change the name if you don't mind and push it.

Regards,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl2oy4UACgkQFn+OpQAa
+pxsuQ/+L/nFfpxdW2ioWQfrlB398CWqslvg/PCjVf5OuoA+UIESGn2KJDUmWPEd
8sySWRWTroAGI11qanqQLCR7p+rNtSmes6N/tCH3I1Qnc+33jEJggQpNTV4a23qc
J8nf1xvgSyJc3o9zaVRn0aQug9K2b1kVVe04XLduxH18l99pnbY0vllOkk/hpzHu
Ar16SxjzWKrAWEc1Y+DD0a+UdOsMNLiiaAKey9q71IXZKvXR0XYqDD+Q7hyXTR6A
uONX/Vdr4+7afyrAjiz/DxkWNTzeVPnEptgm3nNhObL3GrBKBoQopxMa0J431RaQ
P/hjf8Q1+A+0Pv1YvyMB+dpPaQO4wu1nB04UGPu201rGwPIb5zQfayW4XNC9sIuq
mOKtVuCLiJonainPa5OdOVUA1WHq2yT2jW+GjhZVY0yb1b8AUIVD7pmbLJ0GrvWy
BXRkW/WM8+iol8NMywmlxwn19OhBHer7YOCVZRWSx3io/0Cg04/CIchdTMnXI1zH
e1zXYrdOmBhpSthjZKWrAcZM/XhHLmNN15ahFD+h40g4+0JQg3RPrOglTqQ1oKEI
44aL+DlFD/IIvZrZB2dt6IYAkBTiN6po2l55MpVFwIwWDh8SE+2172OmbqCNo3g+
u5rn/DpXo9mjeXPDnx85Bs3TSfcFm+P6ILzbg6bGpAZV0pG03HI=
=ueuq
-----END PGP SIGNATURE-----

T
T
Tanguy Le Carrour wrote on 18 Oct 2019 14:50
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 37613@debbugs.gnu.org)
20191018125015.lawklnqyxxrljq7c@rafflesia
Hi Oleg!


Le 10/17, Oleg Pykhalov a écrit :
Toggle quote (4 lines)
> What do you think about naming the package “httpie” instead, because
> it's intended to run by calling ‘httpie’ command as in ‘youtube-dl’
> package? I could change the name if you don't mind and push it.

I have no opinion on this! I package cookiecutter as
`python-cookiecutter`, so I did the same with httpie.
The only problem is that the binary is actually called `http`.

Just do whatever you think is best!

Should I consider doing the same for the package `python-poetry` I've submitted?!

Regards,

--
Tanguy
O
O
Oleg Pykhalov wrote on 18 Oct 2019 17:09
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87bluedr9b.fsf@gmail.com
Tanguy Le Carrour <tanguy@bioneland.org> writes:

Toggle quote (12 lines)
> Hi Oleg!
>
>
> Le 10/17, Oleg Pykhalov a écrit :
>> What do you think about naming the package “httpie” instead, because
>> it's intended to run by calling ‘httpie’ command as in ‘youtube-dl’
>> package? I could change the name if you don't mind and push it.
>
> I have no opinion on this! I package cookiecutter as
> `python-cookiecutter`, so I did the same with httpie.
> The only problem is that the binary is actually called `http`.

Well, ‘http’ as a package name is not good IMO ;-)

httpie as named in Debian and Nix should be good enough.

Pushed to master.

Toggle quote (2 lines)
> Should I consider doing the same for the package `python-poetry` I've submitted?!

Yes, just a ‘poetry’.

Thanks,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAl2p1cAACgkQFn+OpQAa
+px1GA//Wn5zRjaFzF5oKWbn0mh91KwblVTKGJI24itSm73yg6vpCBH2QZJisnDV
fnubnwaGIV519ctIMFnB0GnWyvKb8d+HD53hjctvoI2Ls082tn9NdzVVOYAboXBC
eBnnyRQ1CTi5DQk/9eVhMIQphlW8ysvx+jM4IbPwNsL8tNEfvVWT9qThLUCSyxFg
BkbdHRsTgSieWyy+lOlC4fvypAZBU40RXVUoaSOUKF6I7QZQ1rxJovAbtNHi81KK
dol+o3jR4vo3YbQLLwNhXIQulaB6txscZORg4VCKEXntXmnIuC/80elqOS674IBS
Og/pz74Ok117+okLKGlk0HkM4GAmCtQVy+yQZXeFFmKuGLNEyKcuJp4zt9Nk4WNY
AhoeRD+y4BcKWjIlxKNwhYS2ZKB7yQnXL2aXtxU/Syuu8paP5DHqG8uyqE4lDpE+
SHRrtvuX7Kd3nbmryBG1DbLK7u24p3yThR/QB0AnxUyjPnqFZNuuNFB9R+jS3W1H
Qh2fuCcwjDX4lBbuPzc74nCBBLGusr4Dx8uIdLLiEhemd4v2ccMmcZsnhX2+ZfCx
VIOgLd9zxJQtFPSxtbLL0LvA/TzmL8dntbp8B9Gz7eJOT7yHPmlcfeMAPFD4DWt1
mMmBfooU6lywSmrPyGIPNx3n1VXQRfH0b+paLsmDBqiJfC6SDEE=
=h/q1
-----END PGP SIGNATURE-----

?