[PATCH] gnu: Add emacs-extempore-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 4 Oct 2019 16:22
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20191004142235.11979-1-goodoldpaul@autistici.org
* gnu/packages/emacs-xyz.scm (emacs-extempore-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 44fe73c3ef..69c3e9dd87 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18754,3 +18754,30 @@ Emacs that integrate with major modes like Org-mode.")
"Elixir-Mode Provides font-locking, indentation and navigation support
for the Elixir programming language.")
(license license:gpl3+)))
+
+(define-public emacs-extempore-mode
+ (let ((version "20190917") ; no proper tag, use date of commit
+ (commit "848ad0084f27b92d1cf98dabffbad29f959a642d")
+ (revision "1"))
+ (package
+ (name "emacs-extempore-mode")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/extemporelang/extempore-emacs-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00wr025php7nl33x541s9rjm99hj0jbdcmnw9ljx5hqpm04aqm7c"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/extemporelang/extempore-emacs-mode")
+ (synopsis
+ "Emacs major mode for Extempore source files")
+ (description
+ "A major mode for editing Extempore code. It can create an
+Extempore REPL, connect the current @code{extempore-mode} buffer
+to a running Extempore process and more.")
+ (license license:bsd-2))))
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 4 Oct 2019 17:05
87mueg4klp.fsf@nckx
Giacomo,

Thank you!

Giacomo Leidi ???
Toggle quote (22 lines)
> * gnu/packages/emacs-xyz.scm (emacs-extempore-mode): New
> variable.
> ---
> gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm
> b/gnu/packages/emacs-xyz.scm
> index 44fe73c3ef..69c3e9dd87 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -18754,3 +18754,30 @@ Emacs that integrate with major modes
> like Org-mode.")
> "Elixir-Mode Provides font-locking, indentation and
> navigation support
> for the Elixir programming language.")
> (license license:gpl3+)))
> +
> +(define-public emacs-extempore-mode
> + (let ((version "20190917") ; no proper tag, use
> date of commit

We can't do this, since upstream could decide to release 0.1
tomorrow and Guix would never consider it an upgrade: the number
20190917 is larger than almost anything.

Hence we must use ‘0.0.0’ in such situations.

Toggle quote (5 lines)
> + (home-page
> + "https://github.com/extemporelang/extempore-emacs-mode")
> + (synopsis
> + "Emacs major mode for Extempore source files")

Both of these can be single lines.

Toggle quote (3 lines)
> + "A major mode for editing Extempore code. It can create
> an

Descriptions should start with a full sentence.

I've made these changes and pushed commit
0c3cf628299458dbbbd783adca5b1d277ead0fc8.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl2XX7IACgkQ2Imw8BjF
STyKZQ//QjTmkeDLZDCS/slhIHifvfZvP4M7mKND10uXwlz+hGXxEhaOpQiYIcMF
SmzP4czRqYgSmc+qDqKe/BG2rHkDQwHlMUgOr+UFWC6GbWHmAO1OBYKaAgwskbk3
fEt5SBWOlQDsrC5MnS1HPwYJfJx30jQnzqNiYo+ti//hg0ujLphrwieKiVsXJyCr
pZyvT5LvAyVE4s0mdfklnHsXwMB2B/t8YGQDke1mmk8sLH9+3BsRq8khjqqvWpcd
jWcs3a/79MRCMtKA3Nhe7mJdm8fPXs7OHLEwTneCCmmRvVenbE0WeHj4lwGAzSX+
GM5mv2MbOt+mPXyO/y5aiaLFP8Bv8gH5mok2Lhv6uLFVDHkme+uofKJtsO01eTXs
Wqt96hu0p61iQ0zQaQWes0RQfkywXKoetyBmNBewvmZBXIZ82oA9FoAxe0YYM+YO
m9rgyWZvzqGnFFPNcYWLy5c57aiKVUTHR8a0PW3Ey1i/axcqOG5tUF9SQOSoiFkv
YqkSGLhOGh/h5DWQFTU/1Sc0Bz1DsBEtMhwjw54v1u+Nr7Kgfl5NgCcR6hnyBWt1
rslEQlJjjekpvhfbGIqb/e13KaGoSOqD/m5AjmbkNLA9i8Ls8iTQg89keTEWsY3B
dVyxZ6hoFALcZPGQW8YZegX0VAGFH4QHNIhjawv4qYZUNOuNVpQ=
=5RRK
-----END PGP SIGNATURE-----

Closed
?