[PATCH] gnu: add uchardet

  • Done
  • quality assurance status badge
Details
3 participants
  • Jonathan Brielmaier
  • Ludovic Courtès
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 11 Oct 2019 22:21
(address . guix-patches@gnu.org)
e4edc1c5-0e0b-405c-8efc-0d0e8b7667bb@pantherx.org
From 5bbab834e617c0bfb14d384e05af390d05728b6e Mon Sep 17 00:00:00 2001
From: Reza Alizadeh Majd <r.majd@pantherx.org>
Date: Fri, 11 Oct 2019 23:23:21 +0330
Subject: [PATCH] gnu: add uchardet

* gnu/packages/freedesktop.scm (uchardet) New variable.
---
gnu/packages/freedesktop.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 401f54bb14..51848be170 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanovi? <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1409,3 +1410,24 @@ This package also contains two related utilities:
their MIME type.
@end itemize")
(license license:perl-license)))
+
+(define-public uchardet
+ (package
+ (name "uchardet")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
"0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f))
+ (home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
+ (synopsis "encoding detector library")
+ (description "uchardet is an encoding detector library, which takes a
+sequence of bytes in an unknown character encoding without any additional
+information, and attempts to determine the encoding of the text. Returned
+encoding names are iconv-compatible.")
+ (license license:gpl2+)))
--
Regards
Reza Alizadeh Majd
PantherX Team
R
R
Reza Alizadeh Majd wrote on 12 Oct 2019 00:18
7721cc22-fc20-41ab-affb-3a44d0947746@pantherx.org
It seems that my mail client brokes the patch file format so I resend the
patch file
as an attachment in this message again.

--
Regards
Reza Alizadeh Majd
PantherX Team
From 5bbab834e617c0bfb14d384e05af390d05728b6e Mon Sep 17 00:00:00 2001
From: Reza Alizadeh Majd <r.majd@pantherx.org>
Date: Fri, 11 Oct 2019 23:23:21 +0330
Subject: [PATCH] gnu: add uchardet

* gnu/packages/freedesktop.scm (uchardet) New variable.
---
gnu/packages/freedesktop.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 401f54bb14..51848be170 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanovi? <stefanx2ovic@gmail.com>
+;;; Copyright © 2019 Reza Alizadeh Majd <r.majd@pantherx.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1409,3 +1410,24 @@ This package also contains two related utilities:
their MIME type.
@end itemize")
(license license:perl-license)))
+
+(define-public uchardet
+ (package
+ (name "uchardet")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f))
+ (home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
+ (synopsis "encoding detector library")
+ (description "uchardet is an encoding detector library, which takes a
+sequence of bytes in an unknown character encoding without any additional
+information, and attempts to determine the encoding of the text. Returned
+encoding names are iconv-compatible.")
+ (license license:gpl2+)))
--
2.23.0
J
J
Jonathan Brielmaier wrote on 12 Oct 2019 10:17
ac294e9e-b45c-2efc-a29d-563ad9dfea91@web.de
On 11.10.19 22:21, Reza Alizadeh Majd wrote:> +    (description
"uchardet is an encoding detector library, which takes
Toggle quote (4 lines)
> a +sequence of bytes in an unknown character encoding without any
> additional +information, and attempts to determine the encoding of the
> text. Returned +encoding names are iconv-compatible.")

What does this "+" do here? Are they broken texinfo syntax?
R
R
Reza Alizadeh Majd wrote on 12 Oct 2019 10:49
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 37708@debbugs.gnu.org)
8c8f4840-1f95-4f08-9d69-a30f41e8bea7@pantherx.org
it seems that my mail client brokes the patch content provided in first
message. please consider to check the attached patch file in my second
email.


On Saturday, October 12, 2019 11:47:15 AM +0330, Jonathan Brielmaier wrote:
Toggle quote (10 lines)
> On 11.10.19 22:21, Reza Alizadeh Majd wrote:> + (description
> "uchardet is an encoding detector library, which takes
>> a +sequence of bytes in an unknown character encoding without any
>> additional +information, and attempts to determine the encoding of the
>> text. Returned +encoding names are iconv-compatible.")
>
> What does this "+" do here? Are they broken texinfo syntax?
>
>

--
Regards
Reza Alizadeh Majd
PantherX Team
L
L
Ludovic Courtès wrote on 12 Oct 2019 15:16
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 37708-done@debbugs.gnu.org)
87ftjyf6ii.fsf@gnu.org
Hi Reza,

Reza Alizadeh Majd <r.majd@pantherx.org> skribis:

Toggle quote (7 lines)
> From 5bbab834e617c0bfb14d384e05af390d05728b6e Mon Sep 17 00:00:00 2001
> From: Reza Alizadeh Majd <r.majd@pantherx.org>
> Date: Fri, 11 Oct 2019 23:23:21 +0330
> Subject: [PATCH] gnu: add uchardet
>
> * gnu/packages/freedesktop.scm (uchardet) New variable.

Applied with the modifications below, which address ‘guix lint’ warnings
(remember to run it next time :-)), enable tests, and clarify the
license.

Thank you for the patch!

Ludo’.
Toggle diff (29 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 17736aa537..4339f14f35 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1423,16 +1423,18 @@ their MIME type.
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.freedesktop.org/software/"
+ (uri (string-append "https://www.freedesktop.org/software/"
name "/releases/" name "-" version ".tar.xz"))
(sha256
(base32 "0q9c02b6nmw41yfsiqsnphgc3f0yg3fj31wkccp47cmwvy634lc3"))))
(build-system cmake-build-system)
- (arguments `(#:tests? #f))
(home-page "https://www.freedesktop.org/wiki/Software/uchardet/")
- (synopsis "encoding detector library")
- (description "uchardet is an encoding detector library, which takes a
-sequence of bytes in an unknown character encoding without any additional
-information, and attempts to determine the encoding of the text. Returned
+ (synopsis "Encoding detector library")
+ (description "uchardet is an encoding detector library, which takes a
+sequence of bytes in an unknown character encoding without any additional
+information, and attempts to determine the encoding of the text. Returned
encoding names are iconv-compatible.")
+
+ ;; This combines code under MPL 1.1, LGPL 2.1+, and GPL 2.0+, so the
+ ;; combination is GPL 2.0+.
(license license:gpl2+)))
Closed
R
R
Reza Alizadeh Majd wrote on 12 Oct 2019 16:48
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37708-done@debbugs.gnu.org)
45feed51-dd14-42ad-9f2c-90526fefcfee@www.fastmail.com
Hi Ludo,

On Sat, Oct 12, 2019, at 4:46 PM, Ludovic Courtès wrote:
Toggle quote (4 lines)
> Applied with the modifications below, which address ‘guix lint’ warnings
> (remember to run it next time :-)), enable tests, and clarify the
> license.

Thanks for your notice about `guix lint`. I will keep that in mind for my later patch submissions.

--
Regards
Reza Alizadeh Majd
PantherX Team
Closed
?