[PATCH] gnu: Add batctl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tonton
Owner
unassigned
Submitted by
Tonton
Severity
normal
T
T
Tonton wrote on 15 Oct 2019 20:27
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
20191015202745.6952d9ae@merlin.browniehive.net
--
:)
From 1de329045545eafe7dcf25d8c76a2c516ba82a72 Mon Sep 17 00:00:00 2001
From: Tonton <tonton@riseup.net>
Date: Tue, 15 Oct 2019 19:14:16 +0200
Subject: [PATCH] gnu: Add batctl.

* gnu/packages/networking.scm (batctl): New variable.
---
gnu/packages/networking.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c0597c7e45..9c33445c64 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2019 Tonton <tonton@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2641,3 +2642,38 @@ Supplicant. It optimizes resource utilization by not depending on any external
libraries and instead utilizing features provided by the Linux kernel to the
maximum extent possible.")
(license license:lgpl2.1+)))
+
+(define-public batctl
+ (package
+ (name "batctl")
+ (version "2019.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://downloads.open-mesh.org/batman/releases/batman-adv-"
+ version "/batctl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0307a01n72kg7vcm60mi8jna6bydiin2cr3ylrixra1596hkzn9b"))))
+ (inputs
+ `(("libnl" ,libnl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ ;; Batctl only has a makefile. Thus we disable tests and
+ ;; configuration, passing in a few make-flags.
+ #:phases (modify-phases %standard-phases (delete 'configure))
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "PKG_CONFIG=" (assoc-ref %build-inputs "pkg-config")
+ "/bin/pkg-config")
+ "CC=gcc")))
+ (home-page "https://www.open-mesh.org/projects/batman-adv/wiki/Wiki")
+ (synopsis "Userspace management tool for the mesh networking
+batman-adv kernel module")
+ (description "Control tool for B.A.T.M.A.N. routing protocol in a
+linux kernel module for layer 2. On guix system use 'modprobe
+batman-adv' to load the kernel module.")
+ (license license:gpl2)))
--
2.23.0
L
L
Ludovic Courtès wrote on 18 Oct 2019 11:51
(name . Tonton)(address . tonton@riseup.net)(address . 37768-done@debbugs.gnu.org)
874l065qkv.fsf@gnu.org
Hello!

Tonton <tonton@riseup.net> skribis:

Toggle quote (10 lines)
> --
> :)
>
> From 1de329045545eafe7dcf25d8c76a2c516ba82a72 Mon Sep 17 00:00:00 2001
> From: Tonton <tonton@riseup.net>
> Date: Tue, 15 Oct 2019 19:14:16 +0200
> Subject: [PATCH] gnu: Add batctl.
>
> * gnu/packages/networking.scm (batctl): New variable.

Applied with the minor changes below.

Thanks,
Ludo’.
Toggle diff (19 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 70e010409c..d9134ff910 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2671,9 +2671,8 @@ maximum extent possible.")
"/bin/pkg-config")
"CC=gcc")))
(home-page "https://www.open-mesh.org/projects/batman-adv/wiki/Wiki")
- (synopsis "Userspace management tool for the mesh networking
-batman-adv kernel module")
- (description "Control tool for B.A.T.M.A.N. routing protocol in a
-linux kernel module for layer 2. On guix system use 'modprobe
-batman-adv' to load the kernel module.")
- (license license:gpl2)))
+ (synopsis "Management tool for the mesh networking BATMAN protocol")
+ (description "This package provides a control tool for the
+B.A.T.M.A.N. mesh networking routing protocol provided by the Linux kernel
+module @code{batman-adv}, for Layer 2.")
+ (license license:gpl2+)))
Closed
?