[PATCH] gnu: Add emacs-minibuffer-line.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • LaFreniere, Joseph
Owner
unassigned
Submitted by
LaFreniere, Joseph
Severity
normal
L
L
LaFreniere, Joseph wrote on 16 Oct 2019 05:18
(address . guix-patches@gnu.org)
87tv898jje.fsf@lafreniere.xyz
Please find the patch file attached.

--
Joseph LaFreniere
From cf7d7d0f6185d21c43b2ca5e24c54c3dae8b8dc3 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Tue, 15 Oct 2019 22:12:32 -0500
Subject: [PATCH] gnu: Add emacs-minibuffer-line.

* gnu/packages/emacs-xyz.scm (emacs-minibuffer-line): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ddaaa01727..6639fc9b6b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19382,3 +19382,29 @@ nondestructively, and computes the dimmed faces dynamically such that your
overall color scheme is shown in a muted form without requiring you to define
what is a \"dim\" version of every face.")
(license license:gpl3+)))
+
+(define-public emacs-minibuffer-line
+ (package
+ (name "emacs-minibuffer-line")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/minibuffer-line-"
+ version
+ ".el"))
+ (sha256
+ (base32 "1ny4iirp26na5118wfgxlv6fxlrdclzdbd9m0lkrv51w0qw7spil"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/minibuffer-line.html")
+ (synopsis "Display status info in the minibuffer window")
+ (description
+ "This package lets you display various status information in the
+minibuffer window instead of the mode-line. Of course, this is only displayed
+when the minibuffer window is not already used for other things (e.g. a
+minibuffer or an each area message).
+
+The contents and aspect is controlled by the @code{minibuffer-line-format}
+variable and the @code{minibuffer-line} face.")
+(license license:gpl3+)))
--
2.23.0
B
B
Brian Leung wrote on 18 Oct 2019 07:18
done
CAAc=MEyZvPZwXyOdns5XZ=JAX-RDKMd2+Uvhudqz2WN5vbBDJg@mail.gmail.com
Merged, thanks!
Attachment: file
Closed
?