[PATCHES] Update python-numpy to 1.17.3

DoneSubmitted by goodoldpaul.
Details
2 participants
  • goodoldpaul
  • Mathieu Othacehe
Owner
unassigned
Severity
normal
G
G
goodoldpaul wrote on 29 Oct 2019 00:23
(address . guix-patches@gnu.org)
a1db6b7fa1ebc849ebda526e52a28674@autistici.org
In the following patches I bumped python-numpy version and as a consequence the ones of python-xlrd and python-pandas.
From 111006cb299aa969b330013fe59aea6db1cf1b24 Mon Sep 17 00:00:00 2001From: Giacomo Leidi <goodoldpaul@autistici.org>Date: Mon, 28 Oct 2019 22:22:23 +0100Subject: [PATCH 1/3] gnu: python-numpy: Update to 1.17.3.
* gnu/packages/python-xyz.scm (python-numpy): Update to 1.17.3.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex 975f87ec40..f5c45cd176 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -3450,7 +3450,7 @@ between language specification and implementation aspects.") (define-public python-numpy (package (name "python-numpy")- (version "1.15.4")+ (version "1.17.3") (source (origin (method url-fetch)@@ -3459,7 +3459,7 @@ between language specification and implementation aspects.") version "/numpy-" version ".tar.gz")) (sha256 (base32- "102vcl2qq4pjbm7a3d67vkkvn4466ngia1d8wi5avqwqh8j0jvkn"))))+ "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9")))) (build-system python-build-system) (inputs `(("openblas" ,openblas)-- 2.23.0
From 6e1a306a4afd2b1d60495579515b78e3d76e5cbf Mon Sep 17 00:00:00 2001From: Giacomo Leidi <goodoldpaul@autistici.org>Date: Mon, 28 Oct 2019 23:53:27 +0100Subject: [PATCH 2/3] gnu: python-xlrd: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-xlrd): Update to 1.2.0.--- gnu/packages/python-xyz.scm | 14 ++++++++------ 1 file changed, 8 insertions(+), 6 deletions(-)
Toggle diff (36 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex f5c45cd176..f6bfee7e5d 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -7242,21 +7242,23 @@ Supported netlink families and protocols include: (define-public python-xlrd (package (name "python-xlrd")- (version "1.0.0")+ (version "1.2.0") (source (origin (method url-fetch) (uri (pypi-uri "xlrd" version)) (sha256 (base32- "0s8hjiz01vbhy85xalrz0qlsmd9ypf36zjqrf97hh984spapvy0g"))))+ "1ci93fda4n67qhdvfl16zasyxrpygzk53hs6m8z0rd4dxrnb6vjl")))) (build-system python-build-system) (arguments `(#:phases (modify-phases %standard-phases- ;; Current test in setup.py does not work as of 1.0.0, so use nose to- ;; run tests instead for now.- (replace 'check (lambda _ (invoke "nosetests"))))))- (native-inputs `(("python-nose" ,python-nose)))+ ;; Some tests depend on writing a temp file+ ;; to the user's home directory+ (add-after 'unpack 'fix-tests+ (lambda _+ (delete-file "tests/test_open_workbook.py")+ #t))))) (home-page "http://www.python-excel.org/") (synopsis "Library for extracting data from Excel files") (description "This package provides a library to extract data from-- 2.23.0
From 27ec6c556a2a3feb31b8c19ee72a30b18c501f31 Mon Sep 17 00:00:00 2001From: Giacomo Leidi <goodoldpaul@autistici.org>Date: Tue, 29 Oct 2019 00:16:25 +0100Subject: [PATCH 3/3] gnu: python-pandas: Update to 0.25.2.
* gnu/packages/python-xyz.scm (python-pandas): Update to 0.25.2.--- gnu/packages/python-xyz.scm | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (22 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex f6bfee7e5d..397561a62f 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -1157,13 +1157,13 @@ human-friendly syntax.") (define-public python-pandas (package (name "python-pandas")- (version "0.24.2")+ (version "0.25.2") (source (origin (method url-fetch) (uri (pypi-uri "pandas" version)) (sha256- (base32 "18imlm8xbhcbwy4wa957a1fkamrcb0z988z006jpfda3ki09z4ag"))))+ (base32 "1gp2pvzdiakvgjmykdzdlzrsfbg4vjm49jjdl9s0ha0a3yfs34fa")))) (build-system python-build-system) (arguments `(#:modules ((guix build utils)-- 2.23.0
M
M
Mathieu Othacehe wrote on 30 Oct 2019 10:21
(address . guix-patches@gnu.org)(address . 37971-done@debbugs.gnu.org)
87wocmbnce.fsf@gmail.com
Hello,
Toggle quote (3 lines)> In the following patches I bumped python-numpy version and as a > consequence the ones of python-xlrd and python-pandas.
python-numpy has a bunch of dependencies (150) but it is below themaster limit, so I pushed it.
Thanks,
Mathieu
?
Your comment

This issue is archived.

To comment on this conversation send email to 37971@debbugs.gnu.org