[PATCH] gnu: Add bemenu.

  • Done
  • quality assurance status badge
Details
2 participants
  • Josh Holland
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Josh Holland
Severity
normal
J
J
Josh Holland wrote on 29 Oct 2019 20:02
(address . guix-patches@gnu.org)(name . Josh Holland)(address . josh@inv.alid.pw)
20191029190237.311353-1-josh@inv.alid.pw
* gnu/packages/xdisorg.scm (bemenu): New public variable.
---
gnu/packages/xdisorg.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d4312f4635..71de6b4072 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;; Copyright © 2019 Kyle Andrews <kyle.c.andrews@gmail.com>
+;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1780,3 +1781,39 @@ and clipboard selection. When the clipboard is changed, it updates the
cutbuffer. When the cutbuffer is changed, it owns the clipboard selection.
The cutbuffer and clipboard selection are always synchronized.")
(license license:gpl2+)))
+
+(define-public bemenu
+ (package
+ (name "bemenu")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Cloudef/bemenu.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0piax49az5kp96r1g6dcgj87fi6p4jl286wlkxsdvljzpkn8q6gv"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags '("-DBEMENU_WAYLAND_RENDERER=ON")))
+ (inputs `(("ncurses" ,ncurses)
+ ("libx11" ,libx11)
+ ("libxinerama" ,libxinerama)
+ ("libxkbcomon" ,libxkbcommon)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)
+ ("cairo" ,cairo)
+ ("pango" ,pango)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("doxygen" ,doxygen)))
+ (home-page "https://github.com/Cloudef/bemenu")
+ (synopsis "Dynamic menu library and client program inspired by dmenu")
+ (description "@code{bemenu} is a dynamic menu which allows the user to
+flexibly select from a list of options (usually programs to launch). It
+supports rendering graphically by X11 and Wayland or in a terminal with
+ncurses.")
+ (license (list license:gpl3+ ; client program[s] and other sources
+ license:lgpl3+ ; library and bindings
+ ))))
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 29 Oct 2019 20:40
874kzruyq9.fsf@nckx
Josh,

Josh Holland ???
Toggle quote (2 lines)
> * gnu/packages/xdisorg.scm (bemenu): New public variable.

Pushed as 2f490bf3d6bb0197b4f280d7a18e9d34b7bb57c3 with the
following modifications:

- Alphabetically ordered inputs.
- Minor tweaks to the description.
- Moved orphaned brackets to the previous line.

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl24la4ACgkQ2Imw8BjF
STwsdA//XNEBjRQVuVpBLag3zviHTgB2wfcP3XFZ3Wxj0qwevSghK7yTHB/qV16c
8TK1U2+KXm1evfzhorUD4zD4a/t5pnJ5QX3ffo7e/ymbg4FlybtSZahA+Lw7lYuU
mZ/yDUnvOHgP5Id13PTF6UdY4Oac1Mijd8RM+u9ZhqN0X/9gBNresJII49hV32R/
hlVDszcWg5lo6CEyNM4u5Bq7RDp7Aw9jQZEpA5wxpWyerjVEzAT/CQX0YC76MwZP
kGNuwK31JMQXN2BUeRutqZ1031gXjzRwGlZoH5deE3rEzl+JQw+OcEhWkElnRRVR
zoGl2fwZ6qt8uOy3qSKX5LyZaw77RjjdUm3Uxz5FQWlHsa8K2Vfwo/QfpVUM1bG0
OpTawWaPXbJ1VG6gzTAxhp3LKq591l30cBM9e4x6oxhYugb+acAm8oVkfqZ8xbGj
khiJdk4iRZFpnSUEG6kYlOW2MzlnBTmgAxoDenIURd0wQzGTINcdDW+7ysVDuYDV
HEgfw+fYpP0gA963eW32fxzDQUEy0W/YXKDwle8I/CwNf6waYjqbssLUX7ALRpTw
HHmOnwHDjDxrbiH9eLNm32i8eQt+VPpYgNnvGCmv8rhMyUWPHxUD1QzitLqG5spy
wHOpm5GMZTDf/GR6vVirHRWOPEi5s2nHb9zWM8gr90wkKS0ogdQ=
=0hje
-----END PGP SIGNATURE-----

Closed
?