[PATCH] gnu: grantlee: Fix build for Qt 5.12.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Hartmut Goebel
Owner
unassigned
Submitted by
Hartmut Goebel
Severity
normal
H
H
Hartmut Goebel wrote on 5 Nov 2019 22:00
(address . guix-patches@gnu.org)
20191105210043.21445-1-h.goebel@crazy-compilers.com
Build using gnu++11 standard.

* gnu/packages/qt.scm(grantlee)[argument]<configure-flags>: New
element.
---
gnu/packages/qt.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8928c1ddd4..0ef879678f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -100,7 +100,8 @@
("qtscript" ,qtscript)))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-DCMAKE_CXX_STANDARD=11")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-broken-tests
(lambda _
--
2.21.0
E
E
Efraim Flashner wrote on 6 Nov 2019 08:09
(name . Hartmut Goebel)(address . h.goebel@crazy-compilers.com)(address . 38073@debbugs.gnu.org)
20191106070920.GI14453@E5400
Looks good to me. Assuming it builds go ahead and push it to master or
staging, whichever is better for it.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3CcaAACgkQQarn3Mo9
g1Gp2w//Uc2NwZi/Bn4gwrrqhlihQwGxCD03ywKwRJQiusiT+uYgOfU8JCRPVb2D
XUlfe9o1k5lYUSjo5OPfdo5SN0bfFSnaoY6idy7o5UjeqhvUttJQDNk84JmpRIc6
3BYkt+BsIhKEJPuoSleRx+PWnU4rYjVE1sBSK3sP3Etu6RLU28vULUCwroAnEDaK
N0abA3EvILjf27yelkUTFzvUrI2mPZ1d/VFxi9Bx+/om4rULraGS6hUlFTDwx1DA
7Wi1bAOXB3YGfwasoLa+2swU7BeJFEQVY8Ee/Mez3i40gAN48XtjGAeiETbY+o4s
ayy2qty5QJHIfg5Qmg9kB3Kqd0DM+N2z2FRcOYjzm7lm1150Y+rmJ/gvkchNj5Q9
RazqSDJEDNyWWvjsCCIBc9FM1myEEOPVMFldk9Q+TAR6/G0jhyEMIJv3wPL02pIk
BoddaDSqrQS81nPyVyNdlr4Br1zu95g5IxODf7htecDNKhgdiC88HJmFHiC119cg
LN8s+sNdkx6aDEwtNQYS3Sr4Wkpd5rta/XPLlbLC5gfdddf585A8T1IPO4dvoThH
edorXOPGBkwyX8diofWmhA2HVw3j1y8jkXVRlqFK2zNYy4f4x48SNABecHkQLVEN
Hbgz78J7PxxGHM0vBdmOWEWT01uaYvxd+VkGeyOWTmZEQ9Rsho4=
=J3WE
-----END PGP SIGNATURE-----


H
H
Hartmut Goebel wrote on 6 Nov 2019 10:31
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 38073-close@debbugs.gnu.org)
712a4dfd-06f0-3e45-0602-6fb3a6e78463@crazy-compilers.com
Am 06.11.19 um 08:09 schrieb Efraim Flashner:
Toggle quote (4 lines)
> Looks good to me. Assuming it builds go ahead and push it to master or
> staging, whichever is better for it.
>
>
Pushed to staging, as Qt 5.12 is not yet in master.

ea57bb893eeb7008064d2f511dede616d4bdcbd1

Thanks for the review.

--
Regards
Hartmut Goebel

| Hartmut Goebel | h.goebel@crazy-compilers.com |
| www.crazy-compilers.com | compilers which you thought are impossible |
?