[PATCH] gnu: Add homebank.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Sebastian Schott
Owner
unassigned
Submitted by
Sebastian Schott
Severity
normal
S
S
Sebastian Schott wrote on 6 Nov 2019 23:00
(address . guix-patches@gnu.org)(name . Sebastian Schott)(address . sschott@mailbox.org)
20191106220005.4419-1-sschott@mailbox.org
---
gnu/packages/finance.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d8190dadaf..fd29099aa3 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2019 Sebastian Schott <sschott@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -151,6 +152,31 @@ of the bitcoin protocol. This package provides the Bitcoin Core command
line client and a client based on Qt.")
(license license:expat)))
+(define-public homebank
+ (package
+ (name "homebank")
+ (version "5.2.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://homebank.free.fr/public/homebank-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13ampiv68y30kc0p2560g3yz8whqpwnidfcnb9lndv93b9ca767y"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libsoup" ,libsoup)))
+ (arguments
+ `(#:configure-flags (list "-without-ofx"))) ; libofx is not available yet
+ (home-page "http://homebank.free.fr/")
+ (synopsis "Free, easy, personal accounting for everyone")
+ (description "HomeBank is the free software you have always wanted to manage your personal accounts at home. The main concept is to be light, simple and very easy to use. It brings you many features that allows you to analyze your finances in a detailed way instantly and dynamically with powerful report tools based on filtering and graphical charts.")
+ (license license:gpl2+)))
+
(define-public ledger
(package
(name "ledger")
--
2.24.0
L
L
Ludovic Courtès wrote on 9 Nov 2019 00:35
(name . Sebastian Schott)(address . sschott@mailbox.org)(address . 38094-done@debbugs.gnu.org)
87wocaaqmn.fsf@gnu.org
Hi Sebastian,

Sebastian Schott <sschott@mailbox.org> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/finance.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)

Applied!

I took the liberty to make apply the cosmetic changes below to follow
our guidelines, in particular
I also added a commit log that follows our conventions.

Thank you!

Ludo’.
Toggle diff (39 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index fd29099aa3..c9a1637412 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -156,13 +156,13 @@ line client and a client based on Qt.")
(package
(name "homebank")
(version "5.2.8")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://homebank.free.fr/public/homebank-" version ".tar.gz"))
- (sha256
- (base32
- "13ampiv68y30kc0p2560g3yz8whqpwnidfcnb9lndv93b9ca767y"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://homebank.free.fr/public/homebank-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13ampiv68y30kc0p2560g3yz8whqpwnidfcnb9lndv93b9ca767y"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -173,8 +173,11 @@ line client and a client based on Qt.")
(arguments
`(#:configure-flags (list "-without-ofx"))) ; libofx is not available yet
(home-page "http://homebank.free.fr/")
- (synopsis "Free, easy, personal accounting for everyone")
- (description "HomeBank is the free software you have always wanted to manage your personal accounts at home. The main concept is to be light, simple and very easy to use. It brings you many features that allows you to analyze your finances in a detailed way instantly and dynamically with powerful report tools based on filtering and graphical charts.")
+ (synopsis "Graphical personal accounting application")
+ (description "HomeBank allows you to manage your personal accounts at
+home. The seeks to be lightweight, simple and easy to use. It brings
+features that allow you to analyze your finances in a detailed way instantly
+and dynamically with report tools based on filtering and graphical charts.")
(license license:gpl2+)))
(define-public ledger
Closed
?