[PATCH] gnu: packages: Add rofi-pass.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 7 Nov 2019 09:13
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20191107081336.11498-1-tanguy@bioneland.org
* gnu/packages/xdisorg.scm (rofi-pass): New public variable.
---
gnu/packages/xdisorg.scm | 45 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 772e09d5b2..df13437d3c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -56,6 +56,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages documentation)
#:use-module (gnu packages admin)
@@ -77,6 +78,7 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages password-utils)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -1269,6 +1271,49 @@ applications you regularly use and also allows you to search for an application
by name.")
(license license:expat)))
+(define-public rofi-pass
+ (package
+ (name "rofi-pass")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://raw.githubusercontent.com/carnager/rofi-pass/"
+ version "/rofi-pass"))
+ (sha256
+ (base32 "0msldkndqp40nx1s5s7ggcr97ir4nshpmnyzvj5hqw1l7m3gvw6j"))
+ (file-name name)))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (string-append (assoc-ref %build-inputs "source")))
+ (script "rofi-pass")
+ (out (assoc-ref %outputs "out")))
+ (copy-file source script)
+ (chmod script #o555)
+ (install-file script (string-append out "/bin"))))))
+ (propagated-inputs
+ `(("password-store" ,password-store)
+ ("rofi" ,rofi)
+ ("xdotool" ,xdotool)))
+ (home-page "https://github.com/carnager/rofi-pass")
+ (synopsis "Handle Simple Password Store in a convenient way using rofi")
+ (description "Rofi-pass provides a way to maniplutate information stored
+using password-store through rofi interface:
+@enumerate
+@item open URLs of entries with hotkey;
+@item type any field from entry;
+@item auto-typing of user and/or password fields;
+@item auto-typing username based on path;
+@item auto-typing of more than one field, using the autotype entry;
+@item bookmarks mode (open stored URLs in browser, default: Alt+x).
+@end enumerate")
+ (license license:gpl3)))
+
(define-public tint2
(package
(name "tint2")
--
2.23.0
M
M
Mathieu Othacehe wrote on 7 Nov 2019 11:07
(address . guix-patches@gnu.org)
87h83gatj4.fsf@gmail.com
Hello Tanguy,

Toggle quote (2 lines)
> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm

I think this should go to password-utils.scm.

Mathieu
T
T
Tanguy Le Carrour wrote on 7 Nov 2019 17:48
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20191107164857.3j3tjyf3nk5wvgbm@rafflesia
Hi Mathieu,


Le 11/07, Mathieu Othacehe a écrit :
Toggle quote (7 lines)
>
> Hello Tanguy,
>
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
>
> I think this should go to password-utils.scm.

I had a 50-50 chance… and picked the wrong one! ^_^'

I'm sending v2! Thanks for reviewing.

--
Tanguy
T
T
Tanguy Le Carrour wrote on 7 Nov 2019 17:49
[PATCH v2] gnu: packages: Add rofi-pass.
(address . 38096@debbugs.gnu.org)
20191107164908.25221-1-tanguy@bioneland.org
* gnu/packages/password-utils.scm (rofi-pass): New public variable.
---
gnu/packages/password-utils.scm | 45 +++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index bfd3c25421..54d8212fb3 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,6 +44,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -654,6 +656,49 @@ templates, clipboard handling, and per folder settings for multi-recipient
encryption.")
(license license:gpl3+)))
+(define-public rofi-pass
+ (package
+ (name "rofi-pass")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://raw.githubusercontent.com/carnager/rofi-pass/"
+ version "/rofi-pass"))
+ (sha256
+ (base32 "0msldkndqp40nx1s5s7ggcr97ir4nshpmnyzvj5hqw1l7m3gvw6j"))
+ (file-name name)))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (string-append (assoc-ref %build-inputs "source")))
+ (script "rofi-pass")
+ (out (assoc-ref %outputs "out")))
+ (copy-file source script)
+ (chmod script #o555)
+ (install-file script (string-append out "/bin"))))))
+ (propagated-inputs
+ `(("password-store" ,password-store)
+ ("rofi" ,rofi)
+ ("xdotool" ,xdotool)))
+ (home-page "https://github.com/carnager/rofi-pass")
+ (synopsis "Handle Simple Password Store in a convenient way using rofi")
+ (description "Rofi-pass provides a way to maniplutate information stored
+using password-store through rofi interface:
+@enumerate
+@item open URLs of entries with hotkey;
+@item type any field from entry;
+@item auto-typing of user and/or password fields;
+@item auto-typing username based on path;
+@item auto-typing of more than one field, using the autotype entry;
+@item bookmarks mode (open stored URLs in browser, default: Alt+x).
+@end enumerate")
+ (license license:gpl3)))
+
(define-public argon2
(package
(name "argon2")
--
2.24.0
M
M
Mathieu Othacehe wrote on 8 Nov 2019 22:01
Re: [bug#38096] [PATCH] gnu: packages: Add rofi-pass.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87h83eaxq2.fsf@gmail.com
Hello,

I pushed this patch with an edited synopsis and a small typo fixed in
description field.

Thanks,

Mathieu
?