[PATCH 0/1] Warn about etc/indent-code.el when Emacs is absent.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 7 Nov 2019 19:25
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20191107182518.9823-1-zimon.toutoune@gmail.com
Dear,

Currently, if Emacs is absent of PATH then ./configure defaults to
/usr/bin/emacs, therefore the script etc/indent-code.el fails when the user
runs it.

With the patch, the file etc/indent-code.el will not be outputed if Emacs is
absent and ./configure warns the user.

From my point of view, it avoids trivial mistake of non-Emacs-er newcomers and
ease their experience when contributing.


All the best,
simon


zimoun (1):
configure.ac: Warn about etc/indent-code.el when Emacs is absent.

configure.ac | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

--
2.23.0
Z
Z
zimoun wrote on 7 Nov 2019 19:27
[PATCH 1/1] configure.ac: Warn about etc/indent-code.el when Emacs is absent.
(address . 38107@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20191107182725.9919-1-zimon.toutoune@gmail.com
---
configure.ac | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/configure.ac b/configure.ac
index 689b28d984..599addfe59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -280,9 +280,14 @@ dnl Documentation translation.
AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
-dnl Emacs (optional), for 'etc/indent-package.el'.
-AC_PATH_PROG([EMACS], [emacs], [/usr/bin/emacs])
-AC_SUBST([EMACS])
+dnl Emacs (optional), for 'etc/indent-code.el'.
+AC_PATH_PROG([EMACS], [emacs])
+if test "x$EMACS" = x; then
+ AC_MSG_WARN([Install GNU Emacs to use etc/indent-code.el])
+else
+ AC_SUBST([EMACS])
+ AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
+fi
case "$storedir" in
/gnu/store)
--
2.23.0
L
L
Ludovic Courtès wrote on 8 Nov 2019 23:56
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 38107-done@debbugs.gnu.org)
878soqc6zp.fsf@gnu.org
zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (24 lines)
> ---
> configure.ac | 11 ++++++++---
> 1 file changed, 8 insertions(+), 3 deletions(-)
>
> diff --git a/configure.ac b/configure.ac
> index 689b28d984..599addfe59 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -280,9 +280,14 @@ dnl Documentation translation.
> AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
> AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
>
> -dnl Emacs (optional), for 'etc/indent-package.el'.
> -AC_PATH_PROG([EMACS], [emacs], [/usr/bin/emacs])
> -AC_SUBST([EMACS])
> +dnl Emacs (optional), for 'etc/indent-code.el'.
> +AC_PATH_PROG([EMACS], [emacs])
> +if test "x$EMACS" = x; then
> + AC_MSG_WARN([Install GNU Emacs to use etc/indent-code.el])
> +else
> + AC_SUBST([EMACS])
> + AC_CONFIG_FILES([etc/indent-code.el], [chmod +x etc/indent-code.el])
> +fi

I removed the redundant ‘AC_CONFIG_FILES’ from the bottom, adjusted the
commit log, and applied.

Thanks!

Ludo’.
Closed
?