[PATCH] gnu: Add artyfx

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 09:37
(name . Guix patches)(address . guix-patches@gnu.org)
26f8bba0b255d3a984bfb72f6282b4e0@posteo.net
ArtyFX LV2 plugin bundle: http://openavproductions.com/artyfx/

Tested using jalv.gtk3, jalv.gtk, jalv.qt5, jalv.qtmm and ardour

From 484bdc9feff4bbedddadeec806511c87c6886207 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 08:26:58 +0000
Subject: [PATCH] gnu: Add artyfx

* gnu/packages/music.scm: (artyfx): New variable.
---
gnu/packages/music.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..ec1c934f1e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,38 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public artyfx
+ (package
+ (name "artyfx")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
"https://github.com/openAVproductions/"
+ "openAV-ArtyFX/archive/release-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+
"002w21qgv6yd750qld74p7lnz2pn25j8qkydac04v95y8wmx1a52"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack
'remove-architecture-specific-flags
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("-msse2
-mfpmath=sse") ""))
+ #t)))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libsndfile" ,libsndfile)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "http://openavproductions.com/artyfx/")
+ (synopsis "Audio effect LV2 plugin bundle")
+ (description "ArtyFX is an LV2 plugin bundle of artistic real-time
audio effects.
+It contains a bitcrusher, delay, distortion, equalizer, compressor and
reverb.")
+ (license license:gpl2+)))
--
2.24.0
L
L
Ludovic Courtès wrote on 9 Nov 2019 23:08
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 38114-done@debbugs.gnu.org)
87mud466ut.fsf@gnu.org
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From 484bdc9feff4bbedddadeec806511c87c6886207 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 08:26:58 +0000
> Subject: [PATCH] gnu: Add artyfx
>
> * gnu/packages/music.scm: (artyfx): New variable.

Applied!

Note that your email client had mangled the patch, so I had to adjust it
by hand. Also, to address a ‘guix lint’ warning, I changed the source
from ‘url-fetch’ to ‘git-fetch’.

Thank you!

Ludo’.
Closed
?