[PATCH] gnu: Add dpf-plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 09:58
(name . Guix patches)(address . guix-patches@gnu.org)
c2f037599a6739c11ce6435941e43139@posteo.net
From aebc4cded75e51f6c453a52cae10c9224d9e7df9 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 08:55:22 +0000
Subject: [PATCH] gnu: Add dpf-plugins.

* gnu/packages/music.scm: (dpf-plugins): New variable.
---
gnu/packages/music.scm | 47 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..e78b01d4a3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,49 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public dpf-plugins
+ (package
+ (name "dpf-plugins")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/DISTRHO/DPF-Plugins.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a89hiqflg8y55aphiff64g9jli88lxzwzw4grfk48n7r1mp49hf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-dssi-binaries
+ (lambda _
+ (substitute* "Makefile"
+ (("cp -r bin.*-dssi.*$") ":;\n"))
+ #t))
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("dssi" ,dssi)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "https://github.com/DISTRHO/DPF-Plugins")
+ (synopsis "Audio plugin collection")
+ (description "Collection of DPF-based audio plugins in LADSPA,
DSSI, LV2 and VST2
+formats. This package includes the following plugins: glBars, Kars,
Max-Gen examples
+(MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift), Mini-Series
(3BandEQ. 3BandSplitter,
+PingPongPan), ndc-Plugs (Amplitude Imposer, Cycle Shifter, Soul Force),
MVerb, Nekobi,
+and ProM.")
+ (license `(license:isc license:gpl3 license:lgpl3 license:mit
license:gpl2))))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:45
87k187jqot.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From aebc4cded75e51f6c453a52cae10c9224d9e7df9 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 08:55:22 +0000
> Subject: [PATCH] gnu: Add dpf-plugins.
>
> * gnu/packages/music.scm: (dpf-plugins): New variable.

[...]

Toggle quote (12 lines)
> + (arguments
> + `(#:tests? #f ; no "check" target
> + #:make-flags
> + (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'skip-dssi-binaries
> + (lambda _
> + (substitute* "Makefile"
> + (("cp -r bin.*-dssi.*$") ":;\n"))
> + #t))

Can you expand on this comment? What are these binaries, and why do we
need to prevent them from being installed?

Toggle quote (3 lines)
> + (license `(license:isc license:gpl3 license:lgpl3 license:mit
> license:gpl2))))

Does this work? I would expect each of the license entries to have to
be 'unquoted', i.e. `(,license:isc). Alternatively you can use (list
...) here.

When a package has multiple licenses like here, please add a comment
about it. Is there a "main" license, (roughly) which files are under
what license?

Apart from that LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IkyIACgkQoqBt8qM6
VPr2ggf/eCZ2tAyyyKkDgKZKujtJ4NcsYSeJuoZ9cmjTBZw7rq6GGotC9xg/rNDU
dNAkyF4DcNp0SCkLN10elaXgqWoZE+qSxNLkUoNmF6JP07rLUrILFrP0WZ5crWlf
1zWGXA9gG2ekF/KEJjA96uVy1BRWfYoPo0f50mo6zqieL/ZdDAanifFypTPAvBxB
md8kFiF1cWLCzbyvtqvv4qJGAJnJPaLHiGEyJ8AQv4jRwDdR/phFatFL3rdhTfrQ
WuuctU9Dr4hbnKw7iri3JbkK7ix609/us6b0YFC0tOwrCAAtehPPVEjEYxY5Jtya
U+r/2RD72Rq1yYLxHFoojDMJQhxVJA==
=olNE
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 11 Nov 2019 05:48
5ec075a5ad2b9e880909217dc3d7b300bfc3ea94.camel@zrythm.org
Toggle quote (15 lines)
> > + (arguments
> > + `(#:tests? #f ; no "check" target
> > + #:make-flags
> > + (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> > + #:phases
> > + (modify-phases %standard-phases
> > + (add-after 'unpack 'skip-dssi-binaries
> > + (lambda _
> > + (substitute* "Makefile"
> > + (("cp -r bin.*-dssi.*$") ":;\n"))
> > + #t))
>
> Can you expand on this comment? What are these binaries, and why do
> we
> need to prevent them from being installed?
I was having trouble building them, but I managed to get them building
now (was missing liblo). Removed this part

Toggle quote (12 lines)
>
> > + (license `(license:isc license:gpl3 license:lgpl3 license:mit
> > license:gpl2))))
>
> Does this work? I would expect each of the license entries to have
> to
> be 'unquoted', i.e. `(,license:isc). Alternatively you can use (list
> ...) here.
>
> When a package has multiple licenses like here, please add a comment
> about it. Is there a "main" license, (roughly) which files are under
> what license?
Fixed and added more info
From 065b91fd765d8df510bcf969c9f41ae792733632 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 08:55:22 +0000
Subject: [PATCH] gnu: Add dpf-plugins.

* gnu/packages/music.scm: (dpf-plugins): New variable.
---
gnu/packages/music.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..784462e56d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,51 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public dpf-plugins
+ (package
+ (name "dpf-plugins")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/DISTRHO/DPF-Plugins.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hsfmpv3kvpiwk8nfw9xpaipzy0n27i83y2v1yr93lznwm5rqrbs"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("liblo" ,liblo) ; for dssi plugins
+ ("jack" ,jack-1) ; for standalone applications
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("dssi" ,dssi)
+ ("lv2" ,lv2)))
+ (home-page "https://github.com/DISTRHO/DPF-Plugins")
+ (synopsis "Audio plugin collection")
+ (description "Collection of audio plugins built with the DISTRHO Plugin
+Framework (DPF) available in LADSPA, DSSI, LV2 and VST2 formats. This
+package includes the following plugins: glBars, Kars, Max-Gen examples
+(MaBitcrush, MaFreeverb, MaGigaverb, MaPitchshift), Mini-Series (3BandEQ,
+3BandSplitter, PingPongPan), ndc-Plugs (Amplitude Imposer, Cycle Shifter,
+Soul Force), MVerb, Nekobi, and ProM.")
+ ;; This package consists of several plugins refactored to use the
+ ;; DISTHRO Plugin Framework (DPF). Different copyrights and licenses
+ ;; apply to different plugins. The root LICENSE file has a table with
+ ;; license information for each plugin and paths to each license
+ (license (list license:isc license:gpl3 license:lgpl3 license:expat license:gpl2))))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I6DMACgkQAi6uQjE9
cPPJuggAghARUvJ0uxnC61fESi7vE49/RPijRYmDJyogzxGoaURIOwdL61Fbo57M
6icxImU+WD7/EM6tomlsSDWskwaEbcltlWsWT3aytpgaG5/AVQeQe312+0vld2ea
Z4X7S2u9i8Q/93ed+50D4+ikgqDED4jsNRYjqYOxsFjR0nF19bK1bA2hOKyKRyHY
wXLbfvxH/641jU39Q0kteaWsv5nSoZNBD9FhhyBxaStSrezYsHY2sTN3lwkDVgSZ
1hr1g0Whh3T77lcSOlzRqtNaVa8cTPJXLo/qfZXpppLCQg6zpSBG0QV0MrJyZCAS
ctreCfTfvp25F49Nn9AMoV/hnEx8Mg==
=m4Y6
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 13 Nov 2019 23:30
87k183if3s.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 065b91fd765d8df510bcf969c9f41ae792733632 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 08:55:22 +0000
> Subject: [PATCH] gnu: Add dpf-plugins.
>
> * gnu/packages/music.scm: (dpf-plugins): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3MhAgACgkQoqBt8qM6
VPoBmQgAntFlhwiUQxGkB/GZlYwM6ItMSSTU6XrlKxFf9FNCrc3JnPO67aqgz2Mk
llV9Dyv2j+SsMK18x2XH8Gum/fMrNo4E5HQUj7HCkSCpiDrMZvUxxTPyxbfoj7NZ
0AaKE725Hh/GTZ2mz1nUlBjFQmIvboAy8tuhPCmh8eXEXC4e5v4Z/e/8lpzqFgjG
mQiL+tZcQ7L0oYF9Zt67rZcdPgulWn3N0dtm/B63AnNiKDKTq2jIQ6FKZ/oOtio2
iTqgCueLoACvHtsgmD2nxzsdOVYMV+C4BGrEJGxk3amj+f7drDiqaXzbRy9cUYMF
csNE+5ApGMMKNGjNEvarQWO6bdGEpQ==
=J74N
-----END PGP SIGNATURE-----

Closed
?