[PATCH] gnu: Add helm.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandros Theodotou
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 10:30
(name . Guix patches)(address . guix-patches@gnu.org)
443a28734ac5866ea443b9cd7366d65a@posteo.net
From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:25:08 +0000
Subject: [PATCH] gnu: Add helm.

* gnu/packages/music.scm: (helm): New variable.
---
gnu/packages/music.scm | 54 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..cf883d034f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,56 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public helm
+ (package
+ (name "helm")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mtytel/helm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "lv2" "standalone")
+ #:phases
+ (modify-phases
+ %standard-phases
+ (add-after 'unpack
'include-pnglib-code-and-remove-usr-from-paths
+ (lambda _
+ (substitute* "standalone/builds/linux/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "builds/linux/LV2/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "Makefile" (("/usr") ""))
+ #t))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("freetype2" ,freetype)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama", libxinerama)
+ ("jack", jack-1)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2", lv2)))
+ (home-page "https://tytel.org/helm/")
+ (synopsis "Polyphonic synth with lots of modulation")
+ (description "Helm is a cross-platform polyphonic synthesizer
available standalone
+and as an LV2 plugin.")
+ (license license:gpl3+)))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:29
87pnhzjrfv.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:25:08 +0000
> Subject: [PATCH] gnu: Add helm.
>
> * gnu/packages/music.scm: (helm): New variable.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3Ij1QACgkQoqBt8qM6
VPrIdgf/W6U7Nfzdr7XNaW1ZbNDUtGqcWgmG6bXIo0i/awYTwOLFelKRrI0q9f+/
OJxtoPh4uOeI7eYFsmKekdq1lCFowT4Ac1aHYO807QKrV5jro0f++acEmILAwEvU
L/Jt42KEhxU3iRi17Eu719yJER3yCTGJSes/bHrbZKy0QgnUtqFin8wLD0MB2S8Z
Us05rO/YPpYGg3f72sJWrb5h+id67EyKLoAnher5er5HtsYnQHAgJPPDygIxbAQd
aeCHC6wr6N1HFWcX/51Sq0o+6hxzE5pbgr+qCFvXSDMDF+dRfxz6oEHK+PvULJ3i
KeoaAvcFdD69OqBiOSv7b8c/Z9Nc7Q==
=njCH
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 18 Nov 2019 12:16
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 38117@debbugs.gnu.org)
87r225juyf.fsf@gnu.org
Hello,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From 3f496aa17eeb192ba363327e6cfd6fe0be533a56 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:25:08 +0000
> Subject: [PATCH] gnu: Add helm.
>
> * gnu/packages/music.scm: (helm): New variable.

I applied it but it fails for me at the end:

Toggle snippet (25 lines)
starting phase `reset-gzip-timestamps'
Backtrace:
9 (primitive-load "/gnu/store/qaparaqbwqw4v0hwfd50s37mikz…")
In ice-9/eval.scm:
191:35 8 (_ _)
In ice-9/boot-9.scm:
829:9 7 (catch _ _ #<procedure 7ffff5bc0518 at /gnu/store/w3jl…> …)
In srfi/srfi-1.scm:
863:16 6 (every1 #<procedure 7ffff4c111e0 at /gnu/store/w3jlc8p…> …)
In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-import/guix/build/gnu-build-system.scm:
839:30 5 (_ _)
594:5 4 (reset-gzip-timestamps #:outputs _)
In srfi/srfi-1.scm:
640:9 3 (for-each #<procedure process-directory (directory)> (#))
640:9 2 (for-each #<procedure reset-gzip-timestamp (file #:key…> …)
In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-import/guix/build/utils.scm:
262:14 1 (reset-gzip-timestamp "/gnu/store/04j1kvzkx8n5ldbcbckh…" …)
In unknown file:
0 (open "/gnu/store/04j1kvzkx8n5ldbcbckhcmbw4n3vzrwz-hel…" …)

ERROR: In procedure open:
In procedure open-fdes: Permission denied
builder for `/gnu/store/xj20qjw2mgp2yc59hmafmkgg780n1ci7-helm-0.9.0.drv' failed with exit code 1

Could you take a look?

As an aside, the patch had been mangled on its way. Could you send it
as an attachment or with ‘git send-email’ next time?

Thank you!

Ludo’.
L
L
Ludovic Courtès wrote on 19 Nov 2019 10:36
control message for bug #38117
(address . control@debbugs.gnu.org)
87pnhorywg.fsf@gnu.org
tags 38117 + moreinfo
quit
A
A
Alexandros Theodotou wrote on 26 Nov 2019 05:43
Re: [bug#38117] [PATCH] gnu: Add helm.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38117@debbugs.gnu.org)
99c2b8836b0cdf9ab106a669a6e41286891b56ab.camel@zrythm.org
Hi Ludo,

Toggle quote (40 lines)
> I applied it but it fails for me at the end:
>
> --8<---------------cut here---------------start------------->8---
> starting phase `reset-gzip-timestamps'
> Backtrace:
> 9 (primitive-load
> "/gnu/store/qaparaqbwqw4v0hwfd50s37mikz…")
> In ice-9/eval.scm:
> 191:35 8 (_ _)
> In ice-9/boot-9.scm:
> 829:9 7 (catch _ _ #<procedure 7ffff5bc0518 at /gnu/store/w3jl…>
> …)
> In srfi/srfi-1.scm:
> 863:16 6 (every1 #<procedure 7ffff4c111e0 at /gnu/store/w3jlc8p…>
> …)
> In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-
> import/guix/build/gnu-build-system.scm:
> 839:30 5 (_ _)
> 594:5 4 (reset-gzip-timestamps #:outputs _)
> In srfi/srfi-1.scm:
> 640:9 3 (for-each #<procedure process-directory (directory)>
> (#))
> 640:9 2 (for-each #<procedure reset-gzip-timestamp (file #:key…>
> …)
> In /gnu/store/w3jlc8pk8416m7h677r5vq92b66h8cqd-module-
> import/guix/build/utils.scm:
> 262:14 1 (reset-gzip-timestamp "/gnu/store/04j1kvzkx8n5ldbcbckh…"
> …)
> In unknown file:
> 0 (open "/gnu/store/04j1kvzkx8n5ldbcbckhcmbw4n3vzrwz-hel…"
> …)
>
> ERROR: In procedure open:
> In procedure open-fdes: Permission denied
> builder for `/gnu/store/xj20qjw2mgp2yc59hmafmkgg780n1ci7-helm-
> 0.9.0.drv' failed with exit code 1
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look?

Weird, it used to work (I even installed it and used the plugin!) but
now I get this too. I would debug it but I have no idea what the error
means or what to look for, the project seems to get built ok (I can see
the generated LV2/VST plugins in the build directory).

Toggle quote (4 lines)
> As an aside, the patch had been mangled on its way. Could you send
> it
> as an attachment or with ‘git send-email’ next time?

Reattaching it as a patch, hopefully someone with more experience can
take it from here.

Alex
From 0aeb52a0b38d32f39e92602dc5a5cc3da7363462 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:25:08 +0000
Subject: [PATCH] gnu: Add helm.

* gnu/packages/music.scm: (helm): New variable.
---
gnu/packages/music.scm | 53 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 241ede58d8..6be12360eb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5013,3 +5013,56 @@ Soul Force), MVerb, Nekobi, and ProM.")
MacArthur's AVLdrums. This plugin provides a convenient way to sequence and mix
MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(license license:gpl2+)))
+
+(define-public helm
+ (package
+ (name "helm")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mtytel/helm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "lv2" "standalone")
+ #:phases
+ (modify-phases
+ %standard-phases
+ (add-after 'unpack 'include-pnglib-code-and-remove-usr-from-paths
+ (lambda _
+ (substitute* "standalone/builds/linux/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "builds/linux/LV2/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "Makefile" (("/usr") ""))
+ #t))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("freetype2" ,freetype)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama", libxinerama)
+ ("jack", jack-1)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2", lv2)))
+ (home-page "https://tytel.org/helm/")
+ (synopsis "Polyphonic synth with lots of modulation")
+ (description "Helm is a cross-platform polyphonic synthesizer available standalone
+and as an LV2 plugin.")
+ (license license:gpl3+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3crX4ACgkQAi6uQjE9
cPMkwwf/dSEa/uFdZdteUMTbMMujdYMmcPEUACUr9VByeRyjBj8Wd753qH/NFmzi
S9aycoBtZPHgD+SOW6muRfHHeCS2LGcCWJr7m7Tdre1vcxCT2qiDDQpUfCopI/1r
WbAPWU4KfpRIpSGeDXxVgtuS/Zr6/oeEdkh64zoSa+g02RxT8lZDdgQIZ0Si1O6t
w5tMsukLkCdts1epPBz7Rop7boJYyoQqbJ4wT0faBI/5bWAJa8DAgDLs+MudJlZb
x6MlosU5zBfkhG0n08x90m5ATAY/5byyMMyBveLML3cPoQySoYsETdkN3UmG8ETH
cdDmOKjmMB8eSlaZhLLA9BGbsVjOsw==
=3ll8
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 26 Nov 2019 11:14
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 38117-done@debbugs.gnu.org)
87eexv9c6j.fsf@gnu.org
Hello,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (5 lines)
> Weird, it used to work (I even installed it and used the plugin!) but
> now I get this too. I would debug it but I have no idea what the error
> means or what to look for, the project seems to get built ok (I can see
> the generated LV2/VST plugins in the build directory).

The ‘changelog.gz’ file and man pages were read-only. I added a phase
like this:

(add-before 'reset-gzip-timestamps 'make-gz-files-writable
(lambda* (#:key outputs #:allow-other-keys)
(for-each make-file-writable
(find-files (string-append (assoc-ref outputs "out"))
".*\\.gz$"))
#t))

Now it’s all right! I will push shortly.

Thanks,
Ludo’.
Closed
?