[PATCH] gnu: Add geonkick.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 11:13
(name . Guix patches)(address . guix-patches@gnu.org)
380d1999ff43dd25ce4772899303cf5e@posteo.net
From 09c3a68bfd70d80984a5956fad0596bb7c3e07ac Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:11:50 +0000
Subject: [PATCH] gnu: Add geonkick.

* gnu/packages/music.scm: (geonkick): New variable.
---
gnu/packages/music.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..eae05499a1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,42 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public geonkick
+ (package
+ (name "geonkick")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
"https://gitlab.com/iurie/geonkick/-/archive/v"
+ version "/geonkick-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wp8w5q69c1nrcc4qkcg0slakkpzp9ngw25iih8zhcl4hrjv42fd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:configure-flags
+ (list (string-append "-DGKICK_REDKITE_SDK_PATH="
+ (assoc-ref %build-inputs "redkite"))
+ (string-append "-DCMAKE_INSTALL_PREFIX="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("jack", jack-1) ; for the standalone
+ ("libsndfile", libsndfile)
+ ("libx11", libx11)))
+ (native-inputs
+ `(("lv2", lv2)
+ ("pkg-config", pkg-config)
+ ("sord", sord)
+ ("rapidjson", rapidjson)
+ ("redkite", redkite)))
+ (synopsis "Percussion synthesizer")
+ (description "Geonkick is a synthesizer that can synthesize
elements of
+percussion such as kicks, snares, hit-hats, shakers, claps and sticks.
It can
+also play and mix samples.")
+ (home-page "https://gitlab.com/iurie/geonkick")
+ (license license:gpl3+)))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:17
87y2wnjs0e.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 09c3a68bfd70d80984a5956fad0596bb7c3e07ac Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:11:50 +0000
> Subject: [PATCH] gnu: Add geonkick.
>
> * gnu/packages/music.scm: (geonkick): New variable.

[...]

Toggle quote (2 lines)
> + ("jack", jack-1) ; for the standalone

Standalone what? :-)

Otherwise LGTM modulo indentation issues.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IjHEACgkQoqBt8qM6
VPomggf/bUQAa8C9GWAOJI6DcNYngDdaNWvN5X4FSw09kxnl81VFp4m9W5akbstA
Ye3lxIG37T06Cv1nF+EqFtcGogEfF1Ake6JMufeFnoXXQhvqNlkmU9LB0Iac9/Zu
Iu5hNQjGT07jYv2zZBm4/Ium8fbaid3RKtAdvHZfCTock8Y0PnvB/KxuLDb6clnW
KKAIWN+4ZPXivmfdoikylaFB0UxkfvE7IJD3Qj5dfzoNwIhm5s/ADOlomUARBSA9
Gk4ugSge+BYVSnBuD3M48mEBKDUUbr7MghZQKmzC0/fd7GW1/MpadvEaR1db+0i3
H/2F/5+1hYbwCwyoDDC9SYqVPxdRHQ==
=1xWn
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 11 Nov 2019 04:14
209934da4710a4d3768cf4cf06004a30be61381f.camel@zrythm.org
Updated
From 98c080f2f27d9f7a99dd635948dc062bde75ed1c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:11:50 +0000
Subject: [PATCH] gnu: Add geonkick.

* gnu/packages/music.scm: (geonkick): New variable.
---
gnu/packages/music.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..2c317db219 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,42 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public geonkick
+ (package
+ (name "geonkick")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/iurie/geonkick/-/archive/v"
+ version "/geonkick-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wp8w5q69c1nrcc4qkcg0slakkpzp9ngw25iih8zhcl4hrjv42fd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:configure-flags
+ (list (string-append "-DGKICK_REDKITE_SDK_PATH="
+ (assoc-ref %build-inputs "redkite"))
+ (string-append "-DCMAKE_INSTALL_PREFIX="
+ (assoc-ref %outputs "out")))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("jack" ,jack-1) ; for the standalone JACK application
+ ("libsndfile" ,libsndfile)
+ ("libx11" ,libx11)))
+ (native-inputs
+ `(("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)
+ ("sord" ,sord)
+ ("rapidjson" ,rapidjson)
+ ("redkite" ,redkite)))
+ (synopsis "Percussion synthesizer")
+ (description "Geonkick is a synthesizer that can synthesize elements of
+percussion such as kicks, snares, hit-hats, shakers, claps and sticks. It can
+also play and mix samples.")
+ (home-page "https://gitlab.com/iurie/geonkick")
+ (license license:gpl3+)))
--
2.24.0
M
M
Marius Bakke wrote on 13 Nov 2019 23:30
87lfsjif4g.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 98c080f2f27d9f7a99dd635948dc062bde75ed1c Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:11:50 +0000
> Subject: [PATCH] gnu: Add geonkick.
>
> * gnu/packages/music.scm: (geonkick): New variable.

[...]

Toggle quote (13 lines)
> +(define-public geonkick
> + (package
> + (name "geonkick")
> + (version "1.9.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://gitlab.com/iurie/geonkick/-/archive/v"
> + version "/geonkick-v" version ".tar.gz"))
> + (sha256
> + (base32
> + "0wp8w5q69c1nrcc4qkcg0slakkpzp9ngw25iih8zhcl4hrjv42fd"))))

As with redkite, I followed the redirect and changed to a git checkout.

Toggle quote (21 lines)
> + (build-system cmake-build-system)
> + (arguments
> + `(#:tests? #f ; no tests included
> + #:configure-flags
> + (list (string-append "-DGKICK_REDKITE_SDK_PATH="
> + (assoc-ref %build-inputs "redkite"))
> + (string-append "-DCMAKE_INSTALL_PREFIX="
> + (assoc-ref %outputs "out")))))
> + (inputs
> + `(("cairo" ,cairo)
> + ("hicolor-icon-theme" ,hicolor-icon-theme)
> + ("jack" ,jack-1) ; for the standalone JACK application
> + ("libsndfile" ,libsndfile)
> + ("libx11" ,libx11)))
> + (native-inputs
> + `(("lv2" ,lv2)
> + ("pkg-config" ,pkg-config)
> + ("sord" ,sord)
> + ("rapidjson" ,rapidjson)
> + ("redkite" ,redkite)))

I moved rapidjson and redkite to inputs, because the package embeds
their static libraries, so the architecture has to match when
cross-compiling.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3Mg+8ACgkQoqBt8qM6
VPrElQf/UUIgJkmW74uC4u17migH113eWIg7ELSihaKnBmJbCsiVuChbHk1egdVQ
kqq+rbWplFafRHrnvQppYB2CnhrQkgaF9l6JVdwmzLfmFtJu3Ke60osk83geuNSK
B1cgAmJcPEiLakgZdnO1teclBlsQkHjGfq+4XkNgr8h+ldiPq8aAMNInxWUzJlOS
bUswWirxlHo4AEYM8tq7fCEpHsC7w+YUbqaIJ32lwOra4iqqBKXuv6/z6iVnMGJo
/TYANRJnY9JaT9TMmRTwI3g83iMjKVRld+6TEj3WLojOSPMRFbUELHHB3VPyJOqG
b6sXw6dvB4nt1RpHPJclFZHbVvX6+w==
=Xl6i
-----END PGP SIGNATURE-----

Closed
?