Add test for `guix pull'

  • Done
  • quality assurance status badge
Details
4 participants
  • Ludovic Courtès
  • Pierre Neidhardt
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 8 Dec 2019 16:39
(address . bug-guix@gnu.org)
87immqu8qw.fsf@ambrevar.xyz
It would be nice to add a `guix pull' test as part of the test suite.
This was discussed in bug #38455.

The test should run `guix pull' but not apply change any symlink.

Note that `guix pull --dry-run' does not catch enough errors.

The current way to do it is to run

guix pull --url=/path/to/checkout --profile=/tmp/guix.master

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3tGTcACgkQm9z0l6S7
zH/iDgf+PcYoftt1YVncHA5Mu0TB9fcdkTZjN2DL0PjL1wqRT9wFmYLrPKKMSqSo
mUYA9ClUJGjVMekrgg5eC9YqoIY0/bMNVvhBCFZIddlW7v37+Qz4K4wkAfN9Jum6
wcKJeCAw2OdiXatFVcRkysG6+pVEnlD2DakW1IpfSBDZ9RqAH0nP/G2FZMWLxUHI
zoH0r5+xo1pb/XXEwmtXaZ2K5TnSJtQlNm7u1aE3wtOseGWLD78c30TGRINpQqIx
J7qeyN43Tjt/avN1ioSNQQm6/Vb1UGkujyknK8ItvUWtgjf0gRnt0eBa9vie1AXa
1ohMTUrg2+bR5eKdY1UciRTvCMnJOQ==
=ktba
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 8 Dec 2019 21:59
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38528@debbugs.gnu.org)
CAJ3okZ166Rc+ucAAnL5o+o9YwEGXaiKDLOWZ+tdmge+MDf7UTQ@mail.gmail.com
Hi,

Thank Pierre to raise this issue.

On Sun, 8 Dec 2019 at 16:40, Pierre Neidhardt <mail@ambrevar.xyz> wrote:

Toggle quote (4 lines)
> The current way to do it is to run
>
> guix pull --url=/path/to/checkout --profile=/tmp/guix.master

When I put that in a test -- say tests/guix-pull.sh -- troubles
arises... The main one appears because there is no user (chroot
environment I guess). Currently, Guix looks at $USER and $LOGNAME then
goes in "default" and applies "Migrating" profile code. Note that it
appears too with non login shell as reported here [1], perhaps not
related.


What is the best:
- set manually the variable USER to `whoami`?
or - change to scheme code to call `whoami`? Does Guile expose that?


All the best,
simon
L
L
Ludovic Courtès wrote on 10 Dec 2019 18:13
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38528@debbugs.gnu.org)
87v9qokssn.fsf@gnu.org
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (4 lines)
> The current way to do it is to run
>
> guix pull --url=/path/to/checkout --profile=/tmp/guix.master

“make as-derivation” achieves more or less the same.

Now, as you know, this can be CPU-intensive, so I’m afraid we cannot
have “make check” do that systematically.

Thanks,
Ludo’.
P
P
Pierre Neidhardt wrote on 11 Dec 2019 01:11
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38528@debbugs.gnu.org)
8736dren5o.fsf@ambrevar.xyz
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (2 lines)
> “make as-derivation” achieves more or less the same.

Is this be good enough to test guix pull?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3wNEMACgkQm9z0l6S7
zH+PcggAjmKzr5sazfN1XNhok7p3Wn4geCpR9fCNyYW1sWCRJBei3zZma4pIuySR
Qegr2hHkNuAZEuWXJFbSkKQqtUtoTdjFT7nguHhUd1jFqrNEZ/MLLxKJajFyxmPo
VTccYlvJXcHFX5gAqD03LmB6ytHfz/1WipGMYmH5zKv4neVc9eu4uvXx2i/d2s4j
ArN7SjNLI/WZDhMHQHDA+6sE/Ljh91YEzprPPuHMYFxlVAokT9xX7JTVlEjBJoFN
sao2iXUbPmEyvzCmky92wxrJ7RcpIPB8gFTGcTcV6oDjOuifpfdANLWkN+vezDjH
8ZYnax+V9N1wBY31pH4UIMo4u9G9PA==
=rJb3
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 12 Dec 2019 14:12
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38528@debbugs.gnu.org)
87imml8z81.fsf@gnu.org
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (6 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> “make as-derivation” achieves more or less the same.
>
> Is this be good enough to test guix pull?

It should be, though I noticed that Mark reported a bug recently so we
need to check.

Ludo’.
Z
Z
zimoun wrote on 12 Dec 2019 16:27
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
CAJ3okZ3vZSdOAFqrptE2RdyD4MLB=DbMMqu6tbG4AWKOGmE3FA@mail.gmail.com
Hi Pierre,

On Wed, 11 Dec 2019 at 01:12, Pierre Neidhardt <mail@ambrevar.xyz> wrote:
Toggle quote (7 lines)
>
> Ludovic Courtès <ludo@gnu.org> writes:
>
> > “make as-derivation” achieves more or less the same.
>
> Is this be good enough to test guix pull?

Have you tried to run the current test suite on the commit you
recently sent breaking "guix pull"?

(I do not remember which commit it was and who sent the fix. If you
indicate me the commit or patch or bug-number introducing the break of
guix pull, I can try.)

All the best,
simon
P
P
Pierre Neidhardt wrote on 13 Dec 2019 10:45
(name . zimoun)(address . zimon.toutoune@gmail.com)
875zikd0ds.fsf@ambrevar.xyz
I tried it on two recent commits
(including eb8aad6a23442cf7b23e0df88b89b4cd030dfbf5) and I get

Toggle snippet (63 lines)
$ guix environment guix -- make as-derivation
Building Guix in Guix...
warning: 'nix-server-socket' is deprecated, use 'store-connection-socket' instead
warning: 'nix-server-major-version' is deprecated, use 'store-connection-major-version' instead
warning: 'nix-server-minor-version' is deprecated, use 'store-connection-minor-version' instead
fetching path `/gnu/store/qa3sp0f1qpqhrzb0v9y5kfgyr61dh70r-xz-5.2.4.tar.gz'...
building path(s) `/gnu/store/aqv75406kbs6s1sp3z9x5fbl9c7y7psn-ld-wrapper-boot0-0'
Downloading https://ci.guix.gnu.org/nar/qa3sp0f1qpqhrzb0v9y5kfgyr61dh70r-xz-5.2.4.tar.gz...
building "/gnu/store/w8fw0vzvai0yw5akfq3gd94avb7jvd4h-binutils-cross-boot0-2.32"/bin/ld wrapper in "/gnu/store/aqv75406kbs6s1sp3z9x5fbl9c7y7psn-ld-wrapper-boot0-0"
Backtrace:
In ice-9/boot-9.scm:
157: 11 [catch #t #<catch-closure c900a0> ...]
In unknown file:
?: 10 [apply-smob/1 #<catch-closure c900a0>]
In ice-9/boot-9.scm:
63: 9 [call-with-prompt prompt0 ...]
In ice-9/eval.scm:
432: 8 [eval # #]
In ice-9/boot-9.scm:
2320: 7 [save-module-excursion #<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
3966: 6 [#<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
1645: 5 [%start-stack load-stack #<procedure cbd2e0 at ice-9/boot-9.scm:3957:10 ()>]
1650: 4 [#<procedure cc3060 ()>]
In unknown file:
?: 3 [primitive-load "/gnu/store/7pcp12416a7gjfm18pk87hradjgrnnrz-ld-wrapper-boot0-0-guile-builder"]
In ice-9/eval.scm:
387: 2 [eval # ()]
432: 1 [eval # #]
In unknown file:
?: 0 [copy-file "/gnu/store/2p4rab987bknvsqm46rxkz7d55wyqpfy-ld-wrapper.in" ...]

ERROR: In procedure copy-file:
ERROR: In procedure copy-file: No such file or directory
builder for `/gnu/store/dvrl5vf6ghxx9w70gacrcamqaxbiwlrf-ld-wrapper-boot0-0.drv' failed with exit code 1
cannot build derivation `/gnu/store/f3ip8y1kw6py0hb597yr8mklsj7wxra2-bash-minimal-5.0.7.drv': 1 dependencies couldn't be built
killing process 14973
cannot build derivation `/gnu/store/gf0ic28nrb8ydz89c5hmjzvs7ndg149n-binutils-2.32.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/f0zz87120k9sb88lijb87dcb0skw5vzz-bzip2-1.0.6.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/s1x51d8rvl845pxsmgg865z4rw6fkvlc-coreutils-8.31.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/1w2h1h84ir7hi27kgiyxm1kcfzv7yrc0-diffutils-3.7.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/w88snqxx45n9m6iyhl491kwlcpjgmqfv-file-5.33.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/dnvs0wggv8gnk27qravhnssgprc6qndc-findutils-4.6.0.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/33asax0rynrvqk9ay6z131ziibym2s9f-gawk-5.0.1.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/s37yl9v9ivhlag4drlxwffjlcmy4yygj-gcc-7.4.0.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/501b6362yp7ng5cdpqg5z08j3c80wcgq-glibc-2.29.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/my7j43l4sspjwxva6gn8jslk5qyaplqi-gmp-6.1.2.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/02dfgh08n9zsa0gkvimh9675430frll7-grep-3.3.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/fnd0k2sdqnin6p1788qjbma37fg3f85n-guile-2.2.6.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/nnp7zxpnjk01zfqm9f4kvdk18g2008ka-gzip-1.10.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/z2ndd6klhz3kl2g048krf3mq576zq7cj-gzip-1.10.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/xxns752z4znp24c46l5aq8j0lvds9s07-libgc-7.6.12.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/v35m6i04n4qbkwbahi7pa89rrlzzr49w-libltdl-2.4.6.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/hm5i7xmvv40ds9ymnnqn4cy75jb9d9y4-libunistring-0.9.10.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/5ab03vwm2hkk24r0i3xgj2q13fzxn995-make-4.2.1.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/72g1a2nhn6h055fa2aqga7mgck0fqc12-patch-2.7.6.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/c9xax133y945rszbmax006jjsadvdiyg-sed-4.7.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/c8m06xvadb4rqa8znpf16xziamh3kc7l-tar-1.32.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/6lwh9va6krsazd53y4fpid8isv0lbz7g-xz-5.2.4.drv': 1 dependencies couldn't be built
cannot build derivation `/gnu/store/yxz3jnqi0scmyp70yg4w0mwqfr6n9n9w-ghostscript-9.27.drv': 1 dependencies couldn't be built
error: build of `/gnu/store/yxz3jnqi0scmyp70yg4w0mwqfr6n9n9w-ghostscript-9.27.drv' failed
make: *** [Makefile:5712: as-derivation] Error 1

Any idea?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3zXdAACgkQm9z0l6S7
zH+rQwf+LDQNfCd0K5Gok97u8M/F+y46WeyuR2SL9T57a8nO/p1zyD6pb713SeSM
qv8W8CVvj2Ot8d/xRulNfpjoRKwKR5OYRGgw86RmIlPKj4h2ZZqtlFpcmWowSx2O
JFqN4TGHZ8j9IRDssEUO3+fjepgVghWnEBkFzCQX8XaP1Mddr6n/rHN/ceOXFGJj
rgkjleZDq1r8LChGm37Puwcd4TGFtNzSTh6F2LyRZxesh5qO1iBXbHdfrE7x+nIX
0MpGG1nB3Tp5SCj6GbOlKpoHJ50FnogRVM6HDgRu0gVGBzQQG2oMF0VzyxaVY//4
0sUu/EM4qLucq17+yLSRUAFOb0sgAA==
=EoZL
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 13 Dec 2019 12:20
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
CAJ3okZ2s9o8z+9YN1jbxrw8Ua7edci0C83xtN7FuR8dFNcRuXg@mail.gmail.com
Hi Pierre,

On Fri, 13 Dec 2019 at 10:45, Pierre Neidhardt <mail@ambrevar.xyz> wrote:

Toggle quote (3 lines)
> I tried it on two recent commits
> (including eb8aad6a23442cf7b23e0df88b89b4cd030dfbf5) and I get

Is it a pushed commit? Or a local one?

[...]

Toggle quote (2 lines)
> Any idea?

I have no idea. It can only propose to try to reproduce. If you send
what is your Guix commit (to know in which environment you run) and
your Git commit in which you run "make as-derivation".


Cheers,
simon
Z
Z
zimoun wrote on 13 Dec 2019 13:19
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
CAJ3okZ3q+SjskoBjuUWqbH23Gv8X0JNH+fqOZ=uiKZapQv9Fgg@mail.gmail.com
On Fri, 13 Dec 2019 at 12:20, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (7 lines)
> On Fri, 13 Dec 2019 at 10:45, Pierre Neidhardt <mail@ambrevar.xyz> wrote:
>
> > I tried it on two recent commits
> > (including eb8aad6a23442cf7b23e0df88b89b4cd030dfbf5) and I get
>
> Is it a pushed commit? Or a local one?

My bad. I find the commit. :-)
But I do not experiment the issue you described.
No idea...

Cheers,
simon
P
P
Pierre Neidhardt wrote on 13 Dec 2019 13:27
(name . zimoun)(address . zimon.toutoune@gmail.com)
87wob0bec3.fsf@ambrevar.xyz
guix commit: 9fcf282.

Toggle quote (2 lines)
> Is it a pushed commit? Or a local one?

Yes, it is pushed of course! :)

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3zg6wACgkQm9z0l6S7
zH83SQgAh0ACbFe4Hiuzd9T11eMImRKD+69kbiXuD9ehfU57JU2OpcMUFa4JaETa
0cWDyYFzC6bks9+D6Ynd8QLXuAF0WZB1qcqCdCMdZ/gU3zODsW1vgRCIyNaAqRh+
zxyey4qCEwsWxPLoWWeT9WGosbKrsklEuu4cPZXV4HOkaiBVhDOcT55zoxyFp3a4
ITJv/dzp2XxYsDzr6BHQaLq//ZcV+myd4AtSoYccyutI6h7agJOIzCA3M6yktFYC
gtRhwQfqlKOqsy78IjkgcJvT+VSKvQVTPOiy3SINgMtCJtF2g4X59WBrzuyEu7+J
5PRvTkzHVKGjSzwvsnv3WuRPE2jN+w==
=npR5
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 14 Dec 2019 15:11
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87mubvyp3a.fsf@gnu.org
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (35 lines)
> $ guix environment guix -- make as-derivation
> Building Guix in Guix...
> warning: 'nix-server-socket' is deprecated, use 'store-connection-socket' instead
> warning: 'nix-server-major-version' is deprecated, use 'store-connection-major-version' instead
> warning: 'nix-server-minor-version' is deprecated, use 'store-connection-minor-version' instead
> fetching path `/gnu/store/qa3sp0f1qpqhrzb0v9y5kfgyr61dh70r-xz-5.2.4.tar.gz'...
> building path(s) `/gnu/store/aqv75406kbs6s1sp3z9x5fbl9c7y7psn-ld-wrapper-boot0-0'
> Downloading https://ci.guix.gnu.org/nar/qa3sp0f1qpqhrzb0v9y5kfgyr61dh70r-xz-5.2.4.tar.gz...
> building "/gnu/store/w8fw0vzvai0yw5akfq3gd94avb7jvd4h-binutils-cross-boot0-2.32"/bin/ld wrapper in "/gnu/store/aqv75406kbs6s1sp3z9x5fbl9c7y7psn-ld-wrapper-boot0-0"
> Backtrace:
> In ice-9/boot-9.scm:
> 157: 11 [catch #t #<catch-closure c900a0> ...]
> In unknown file:
> ?: 10 [apply-smob/1 #<catch-closure c900a0>]
> In ice-9/boot-9.scm:
> 63: 9 [call-with-prompt prompt0 ...]
> In ice-9/eval.scm:
> 432: 8 [eval # #]
> In ice-9/boot-9.scm:
> 2320: 7 [save-module-excursion #<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
> 3966: 6 [#<procedure cc1b80 at ice-9/boot-9.scm:3961:3 ()>]
> 1645: 5 [%start-stack load-stack #<procedure cbd2e0 at ice-9/boot-9.scm:3957:10 ()>]
> 1650: 4 [#<procedure cc3060 ()>]
> In unknown file:
> ?: 3 [primitive-load "/gnu/store/7pcp12416a7gjfm18pk87hradjgrnnrz-ld-wrapper-boot0-0-guile-builder"]
> In ice-9/eval.scm:
> 387: 2 [eval # ()]
> 432: 1 [eval # #]
> In unknown file:
> ?: 0 [copy-file "/gnu/store/2p4rab987bknvsqm46rxkz7d55wyqpfy-ld-wrapper.in" ...]
>
> ERROR: In procedure copy-file:
> ERROR: In procedure copy-file: No such file or directory
> builder for `/gnu/store/dvrl5vf6ghxx9w70gacrcamqaxbiwlrf-ld-wrapper-boot0-0.drv' failed with exit code 1

This is weird… All I can say it that it works for me. :-)

Could you find out (1) why it’s trying to rebuild ‘ld-wrapper-boot0’
(which means rebuilding the world), and (2) why this particular build is
failing?

Thanks,
Ludo’.
P
P
Pierre Neidhardt wrote on 16 Dec 2019 14:19
(name . Ludovic Courtès)(address . ludo@gnu.org)
87lfrcqufa.fsf@ambrevar.xyz
It works now, however it does not detect breakages like "guix pull -p
..." does.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl33hHkACgkQm9z0l6S7
zH+GGwf+Ny2Er32cZaCQxgw9hCwUU6o/m4yqONJYOzxdmb/zyZT8PKuW/kE9VOJW
azkG0vFXwgd/8+2lAkdiNM5tkdfJrIDzZpOjidsK4bqMNWg4BtX8PlCEIMgiLfQJ
Q38bSTyXo/POF27ec6Ge0ZWJ3WKbZsJ+2u/rW3D30W3RBAjjobh8RX9b6ERjxqRM
3dDqu3AGWGdeLWAqIX69dHLjV3QNQtT/ZgEw4s+r4fmzwafRJZ8Qgcr5QGwGUTPH
0+HSufkwmysHJQXvSpD3KMaRORioTS+WjZxg4qbLVzzDup4hKG3Z6AVAY0K8kitK
Yx09N4vewdMmQOcXx5/39qbyHT4k4w==
=WHwh
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 16 Dec 2019 15:36
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87v9qgfic8.fsf@gnu.org
Hi Pierre,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (3 lines)
> It works now, however it does not detect breakages like "guix pull -p
> ..." does.

Do you have a specific example in mind? They normally build the exact
same thing.

All that said, I think it’s fine to recommend “guix pull -p” in the
manual, but I just wanted to make sure people know about “make
as-derivation”, which can be slightly more convenient in cases where you
don’t want to commit the change to test it.

Thanks,
Ludo’.
P
P
Pierre Neidhardt wrote on 16 Dec 2019 15:39
(name . Ludovic Courtès)(address . ludo@gnu.org)
87v9qgpc6n.fsf@ambrevar.xyz
Yes, I testsed on commit
614a1e3fa2d731d4719f03912b1b87fb4fd309cb, which should be broken.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl33lxAACgkQm9z0l6S7
zH/6IAf/Q1DHE4YPckvelycdh5VsWbcrVxACmxV3pfeM5na/akeN63rDdoSOA0/4
y/TA6LmkCopjtBqmrPxF5FnJrHn3R/sBWXubvIxbzP6E2c9gBmggCF1lr81cUcQ6
i9LYazr3873Xvhgd2TWGZ9d2ctu8JkUvQ+m9PKZcOsV2M6gKkerqZ/vgxDP6rHY3
6K8/rse7dXkD14Eie+m/bcje8ahd2iIIBKmBwx3lQvZAjEXm6pxp2C1WDKBW3YQt
UYQiuFQxBzv343CH/bM7f9egcesTaZw4XX63aLOBFxcFZ4bTbTwupIbQBeWlAg6u
poiYlfhk24Q0b0PJXPNa53MdeiAJiA==
=bnyR
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 16 Dec 2019 16:27
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJ3okZ3mxFrm5H8LFi8a2O7PFkcC_AeVOLaSJ_oBWEc=iAU19w@mail.gmail.com
Hi Ludo,

On Mon, 16 Dec 2019 at 15:36, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (5 lines)
> All that said, I think it’s fine to recommend “guix pull -p” in the
> manual, but I just wanted to make sure people know about “make
> as-derivation”, which can be slightly more convenient in cases where you
> don’t want to commit the change to test it.

Both can be mentioned in the manual because they target different usage, IMHO.


All the best,
simon
M
M
Maxim Cournoyer wrote on 19 Aug 2022 16:31
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87v8qoxq3a.fsf@gmail.com
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (3 lines)
> Yes, I testsed on commit
> 614a1e3fa2d731d4719f03912b1b87fb4fd309cb, which should be broken.

Closing this forgotten "bug".

Please do submit a patch if you'd like to document this.

Thanks,

Maxim
Closed
?