[PATCH] gnu: make-bootstrap: Add cross-libc:static to the inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Mathieu Othacehe
Severity
normal
M
M
Mathieu Othacehe wrote on 3 Jan 2020 15:30
(address . guix-patches@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20200103143010.15985-1-m.othacehe@gmail.com
This is a follow-up of 4610ab7c9a5327df0d475262817bc081a5891aa8. 'getpw' & co
fail with a cross-compiled statically-linked guile.

* gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
Add "cross-libc:static".
---
gnu/packages/make-bootstrap.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d149a7ec1a..0144a6e9a2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -137,7 +138,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define (inputs)
(if (%current-target-system) ; is this package cross built?
`(("cross-libc"
- ,(cross-bootstrap-libc (%current-target-system))))
+ ,(cross-bootstrap-libc (%current-target-system)))
+ ("cross-libc:static"
+ ,(cross-bootstrap-libc (%current-target-system))
+ "static"))
'()))
(define (native-inputs)
--
2.24.1
L
L
Ludovic Courtès wrote on 15 Jan 2020 22:10
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 38893@debbugs.gnu.org)
875zhcpgrk.fsf@gnu.org
Hello,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

Toggle quote (6 lines)
> This is a follow-up of 4610ab7c9a5327df0d475262817bc081a5891aa8. 'getpw' & co
> fail with a cross-compiled statically-linked guile.
>
> * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
> Add "cross-libc:static".

Good catch, LGTM!

Thanks,
Ludo’.
M
M
Mathieu Othacehe wrote on 16 Jan 2020 10:17
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38893-done@debbugs.gnu.org)
87sgkfbvzs.fsf@gmail.com
Hey,

Toggle quote (5 lines)
>> * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
>> Add "cross-libc:static".
>
> Good catch, LGTM!

Thanks for reviewing, pushed on core-updates!

Mathieu
Closed
?