[PATCH] * gnu/packages/docker.scm (docker-compose): update to 1.25.4

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 19 Mar 2020 19:54
(address . guix-patches@gnu.org)
871rpoxjih.fsf@rohleder.de

I tested this only briefly. I could build and run containers from
compose files, so its at least less broken than before where one couldnt
even start docker-compose.

This doesnt need the old jsonschema-2.6 and seems to work with our
current 3.0.1 version, so we can remove it (as stated in the comment).

Now, I am wondering if we need all the python-request versions...


* gnu/packages/docker.scm (docker-compose): update to 1.25.4
From a234bbe7a61f9595ce4ecc0e6367496093f72788 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 19 Mar 2020 18:48:21 +0100
Subject: [PATCH] * gnu/packages/docker.scm (docker-compose): update to 1.25.4

---
gnu/packages/docker.scm | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 7524a0dc1b..69dee2b856 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -98,19 +99,17 @@ pseudo-terminal (PTY) allocated to a Docker container using the Python
client.")
(license license:asl2.0)))
-;; When updating, check whether python-jsonschema-2.6 can be removed from Guix
-;; entirely.
(define-public docker-compose
(package
(name "docker-compose")
- (version "1.24.1")
+ (version "1.25.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "docker-compose" version))
(sha256
(base32
- "0lx7bx6jvhydbab8vwry0bclhdf0dfj6jrns1m5y45yp9ybqxmd5"))))
+ "1ww8ckpj3n5jdg63qvmiqx3gk0fsrnynnnqj17fppymbwjzf5fps"))))
(build-system python-build-system)
;; TODO: Tests require running Docker daemon.
(arguments '(#:tests? #f))
@@ -120,9 +119,9 @@ client.")
("python-docker-py" ,python-docker-py)
("python-dockerpty" ,python-dockerpty)
("python-docopt" ,python-docopt)
- ("python-jsonschema" ,python-jsonschema-2.6)
+ ("python-jsonschema" ,python-jsonschema)
("python-pyyaml" ,python-pyyaml)
- ("python-requests" ,python-requests-2.20)
+ ("python-requests" ,python-requests)
("python-six" ,python-six)
("python-texttable" ,python-texttable)
("python-websocket-client" ,python-websocket-client)))
--
2.25.2
* gnu/packages/python-xyz.scm (python-jsonschema-2.6): remove variable.
From 69518dd1935db9ad58e43572688e8d72d645f501 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Thu, 19 Mar 2020 18:56:58 +0100
Subject: [PATCH] * gnu/packages/python-xyz.scm (python-jsonschema-2.6): remove
variable.

---
gnu/packages/python-xyz.scm | 26 --------------------------
1 file changed, 26 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07199aa7ca..8271e1ff7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2306,32 +2306,6 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
`(("python2-functools32" ,python2-functools32)
,@(package-propagated-inputs jsonschema))))))
-;; This old version is still required by docker-compose as of 1.24.0.
-(define-public python-jsonschema-2.6
- (package
- (name "python-jsonschema")
- (version "2.6.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "jsonschema" version))
- (sha256
- (base32
- "00kf3zmpp9ya4sydffpifn0j0mzm342a2vzh82p6r0vh10cg7xbg"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check (lambda _ (invoke "nosetests"))))))
- (native-inputs
- `(("python-nose" ,python-nose)
- ("python-vcversioner" ,python-vcversioner)))
- (home-page "https://github.com/Julian/jsonschema")
- (synopsis "Implementation of JSON Schema for Python")
- (description
- "Jsonschema is an implementation of JSON Schema for Python.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-jsonschema))))))
-
(define-public python-schema
(package
(name "python-schema")
--
2.25.2
--
Perfection (in design) is achieved not when there is nothing more to
add, but rather when there is nothing more to take away.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl5zv/YACgkQfHr/vv7y
yyUnnwgAiLumSOQtYyN0tvaFLsncnVhkZcFPw28ZjKswzLBzhLHQek599yDdhM5j
5wX0IG0/ZBsS3iEI4NbxC9WvnoS/wJ76Zyw0A6ducQ4OGjU2C5C19sC5cQuNkWD1
Fd1wYSs/w7Gwvd6f/HfNsxyCmCG5h5HlDV5TghykdTEb8iDFapvwC9oA0QezNNej
whgcdKFnT3YqcxfWonY0eCsuLfm2VPNUCZz18cVCq1cgteETTMK1gJ0E7jbrx/b/
p5M2JkGgaXHXkb1SOyHXB39Aa0eI8sRijoWg/zIPMGymOojgDY6mZXxYeYvdhYXj
7sN/z1lxcR975k+Q9irpHwj/wmfcKQ==
=IAwc
-----END PGP SIGNATURE-----

D
D
Danny Milosavljevic wrote on 19 Mar 2020 20:45
(name . Michael Rohleder)(address . mike@rohleder.de)
20200319204544.40f7085e@scratchpost.org
Hi,

thanks for the patch!

Pushed to guix master as commit 15c3aa091100160bbe9c81650f9ab7a12bd7964e.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl5zy+gACgkQ5xo1VCww
uqXDbAf+KXtemjGpw01QN8hAVyAOhnFrYv8CximA8mh4/LBGAeQdNp5vFkzjWBg7
Uj+X+rIDdaVjMb0V9i4ihYtfnrzjKA2ZZEv9MwOalOgrxI6cihTEwD7jb2j8E/Fq
2VSPv3RK4/anKisdPVIO72KkkeWR8DPv0eJZsAHOJzj7C1zg44QFyS75nB7JultR
SjMuQvfkei/7a+Tp9DsEf5G1jXZYATV/PJTfdhPRgRDsZkKIv+EPghuYnQUndx0Q
KWuAE9WpNR6t3v+36jq8KsFVrCtovYbc/xQwqLs0uLD9nH3KcsEWsmaZQnuOJ+/K
FXLAX8azGG79jPKCw5a0RTxhmBqLyg==
=xA1C
-----END PGP SIGNATURE-----


Closed
?