[PATCH] gnu: git: Return #t in install-man-pages phase.

  • Done
  • quality assurance status badge
Details
4 participants
  • Brice Waegeneire
  • Danny Milosavljevic
  • Mathieu Othacehe
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 20 Mar 2020 10:20
(address . guix-patches@gnu.org)
20200320092005.22388-1-brice@waegenei.re
* gnu/packages/version-control.scm (git)[arguments]: Return #t in
install-man-pages phase.
---
gnu/packages/version-control.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d25df4c63d..7eb85cc749 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -441,7 +441,8 @@ as well as the classic centralized workflow.")
(manpages (assoc-ref inputs "git-manpages")))
(mkdir-p man)
(with-directory-excursion man
- (invoke "tar" "xvf" manpages))))))))
+ (invoke "tar" "xvf" manpages)))
+ #t)))))
(native-search-paths
;; For HTTPS access, Git needs a single-file certificate bundle, specified

base-commit: 837644b48a5107a28acbdb6d172aff0040a8247d
prerequisite-patch-id: b9e1cb7e09e15cac4d607e985e2a3b5e301828e5
prerequisite-patch-id: e22ea3f99fc3d9f3e11ddfa31ba60212f2ed4d62
--
2.25.1
D
D
Danny Milosavljevic wrote on 20 Mar 2020 10:54
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 40143@debbugs.gnu.org)
20200320105406.42ba348b@scratchpost.org
invoke already returns #t, so there's no technical bug.

That said, maybe for clarity? Not sure...
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl50kr4ACgkQ5xo1VCww
uqUA6Af/V72+dk8p9/pwjv2aWdMjQFwg8SLeIio5wCxTp4JTNtl+DK+nyD57ZRZz
c2I8flvOkmG5vijkiNL97e15fyHjTfD+aagTQClOM4oOIBkRrLciTnVk6LyJ4+ZC
eokiQRcU0tWLf5ZYQ6ZdEkdtmOxHFmC1MeTShivNoCnnrCV/pv2Wk0aSMAAkwDh3
vqNeqHwYJTgzbtcsw+CpmmDpAbRiUWMCRRH2oekbHaZlI9m7veN7Cj4x1JDov3EK
aczuoiJ+IqHbGGv9yS5SmlgPmD7EoiLdNinLSV6p2EyvAaNdivuCHcpkTRMKoKaH
uz+vaAvMZbnVND4TFwygwLT6+xTlEg==
=OkXj
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 20 Mar 2020 15:21
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
87blor3y5h.fsf@gmail.com
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (4 lines)
> invoke already returns #t, so there's no technical bug.
>
> That said, maybe for clarity? Not sure...

I don't see any technical nor clarity issue here. The vision laid out
by Mark more than two years ago (!) was to get rid of all the boolean
return codes and move to an exception based system entirely, which I
find much more elegant. The transition plan was outlined in this
message:

I think we should go back to work on finishing the missing bits :-).

Maxim
M
M
Mathieu Othacehe wrote on 21 Mar 2020 15:29
(name . Brice Waegeneire)(address . brice@waegenei.re)
877dzdkcgv.fsf@gmail.com
Hello Brice,

Toggle quote (6 lines)
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> invoke already returns #t, so there's no technical bug.
>>
>> That said, maybe for clarity? Not sure...

I agree with Danny and Maxim here, we already return a boolean, or
raise an exception in case of error, so I think we are fine :)

Closing this bug,

Thanks,

Mathieu
B
B
Brice Waegeneire wrote on 21 Mar 2020 15:43
Re: bug#40143: [PATCH] gnu: git: Return #t in install-man-pages phase.
(name . Brice Waegeneire)(address . brice@waegenei.re)
97f43fbba8a1b83caa53373c459a7639@waegenei.re
On 2020-03-21 14:29, Mathieu Othacehe wrote:
Toggle quote (17 lines)
> Hello Brice,
>
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>>
>>> invoke already returns #t, so there's no technical bug.
>>>
>>> That said, maybe for clarity? Not sure...
>
> I agree with Danny and Maxim here, we already return a boolean, or
> raise an exception in case of error, so I think we are fine :)
>
> Closing this bug,
>
> Thanks,
>
> Mathieu

Looks like a forgot to reply to all, I replied to Danny that it
should be closed. I missed the RTFM sign... I didn't knew about
Maxim's link and would like to know where are we in transitioning
away from getting rid of boolean return code in phases.
?