[PATCH] gnu: Add midori.

  • Done
  • quality assurance status badge
Details
3 participants
  • Mathieu Othacehe
  • Rene
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Rene
Severity
normal
R
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
1m205gLXKeQ3W9F5joFoSCD4vh-RQpGb_18VRS3xJm3D59Uqj5VPe7sf-anwojBOgbvaoPVne-RtB3XlcuJIk2dj79pYtJL_eecLeTHWBgQ=@protonmail.com
Hi Guix,

this patch is for adding midori, a web browser.


Thank you
Rene
From 58af41ec0a78d7146a45c74a2598035050cf6a92 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <pacoon@protonmail.com>
Date: Sat, 21 Mar 2020 02:47:21 -0600
Subject: [PATCH] gnu: Add midori.

* gnu/packages/web-browsers.scm (midori): New variable.
---
gnu/packages/web-browsers.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 8a6ffaeef1..21a5361bcd 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Rene Saavedra <pacoon@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,10 +31,12 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages libevent)
@@ -57,6 +60,7 @@
#:use-module (gnu packages gcc)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
@@ -630,3 +634,39 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" next))
+
+(define-public midori
+ (package
+ (name "midori")
+ (version "9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/midori-browser/core/releases/"
+ "download/v" version "/"
+ name "-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "05i04qa83dnarmgkx4xsk6fga5lw1lmslh4rb3vhyyy4ala562jy"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin")
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("gcr" ,gcr)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libarchive" ,libarchive)
+ ("libpeas" ,libpeas)
+ ("libsoup" ,libsoup)
+ ("sqlite" ,sqlite)
+ ("webkitgtk" ,webkitgtk)))
+ (home-page "https://www.midori-browser.org")
+ (synopsis "Lightweight graphical web browser")
+ (description
+ "Midori is a lightweight Webkit-based web browser. It features are support
+for integration with GTK+3, configurable web search engine, bookmark management,
+extensions such as advertisement blocker and colorful tabs.")
+ (license license:lgpl2.1+)))
--
2.21.0
M
M
Mathieu Othacehe wrote on 21 Mar 2020 14:59
(name . Rene)(address . pacoon@protonmail.com)(address . 40161@debbugs.gnu.org)
87d095kdv7.fsf@gmail.com
Hello Rene,

I was about to push your patch when I noticed that HTTPS urls don't
work. I tried to add:

Toggle snippet (3 lines)
("glib-networking" ,glib-networking)

to inputs without improving the situation.

Could you try to see what's going wrong?

Thanks,

Mathieu
R
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(name . 40161@debbugs.gnu.org)(address . 40161@debbugs.gnu.org)
4WlC2n2IrEuA_lW6Ic58Cvkp_zTdadlJcN3YyJZoHuUiqfxNREwqeYwGM9gz2--n2sWPlBp09em5odEb70n9zTkLtkUmiQmv2Dhn6-EZJJY=@protonmail.com
Hi Mathieu,

I use midori and I have not noticed this problem, I will continue testing.

Thank you
Rene



??????? Original Message ???????
On Saturday, March 21, 2020 7:59 AM, Mathieu Othacehe <m.othacehe@gmail.com> wrote:

Toggle quote (16 lines)
> Hello Rene,
>
> I was about to push your patch when I noticed that HTTPS urls don't
> work. I tried to add:
>
> --8<---------------cut here---------------start------------->8---
> ("glib-networking" ,glib-networking)
> --8<---------------cut here---------------end--------------->8---
>
> to inputs without improving the situation.
>
> Could you try to see what's going wrong?
>
> Thanks,
>
> Mathieu
R
R
Ricardo Wurmus wrote on 22 Mar 2020 11:30
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
87o8solm0x.fsf@elephly.net
Mathieu Othacehe <m.othacehe@gmail.com> writes:

Toggle quote (13 lines)
> Hello Rene,
>
> I was about to push your patch when I noticed that HTTPS urls don't
> work. I tried to add:
>
> --8<---------------cut here---------------start------------->8---
> ("glib-networking" ,glib-networking)
> --8<---------------cut here---------------end--------------->8---
>
> to inputs without improving the situation.
>
> Could you try to see what's going wrong?

This may be the same mechanism used by Epiphany and Eolie. You may need
to wrap the executable in GI_TYPELIB_PATH.

--
Ricardo
M
M
Mathieu Othacehe wrote on 20 Apr 2020 21:25
(name . Rene via Guix-patches via)(address . guix-patches@gnu.org)
874kteklij.fsf@gmail.com
Closing as resolved by 40712.

Thanks,

Mathieu
?