[PATCH] gnu: add python-gcovr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 21 Mar 2020 20:47
(name . Guix patches)(address . guix-patches@gnu.org)
36ac7ee63343e5aa26ce9cc8f248c80740317ca3.camel@zrythm.org
Hi,

This patch adds gcovr.

Thanks,
Alex
From c624e0ec8bb4ebe2bb7af6a2d86aafbf072c4891 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:45:14 +0000
Subject: [PATCH] gnu: add python-gcovr.

* gnu/packages/python-xyz.scm (python-gcovr): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0da9b36c3..9ede8b4c93 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -70,6 +70,7 @@
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
+;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18358,3 +18359,28 @@ sequences.")
(define-public python2-fuzzywuzzy
(package-with-python2 python-fuzzywuzzy))
+
+(define-public python-gcovr
+ (package
+ (name "python-gcovr")
+ (version "4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gcovr" version))
+ (sha256
+ (base32
+ "0gyady7x3v3l9fm1zan0idaggqqcm31y7g5vxk7h05p5h7f39bjs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-jinja2" ,python-jinja2)))
+ (home-page "https://gcovr.com/")
+ (synopsis
+ "Utility for generating code coverage results")
+ (description
+ "Gcovr provides a utility for managing the use of the GNU gcov
+utility and generating summarized code coverage results. It is inspired
+by the Python coverage.py package, which provides a similar utility for
+Python.")
+ (license license:bsd-3)))
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl52bzsACgkQAi6uQjE9
cPPPYwf/dAUsRZ/4wAiNfnd96TW0+j5DJhGP0rr8oIBJ6ZrKLeRjiWhXwfR1/9G3
ZNC76oPvx9cIE3cwADJo/TqKO8m+y+GBM5ch8Am32FAM1axI/ZI5y810Kss7+O+M
p9rQ+L8h2StVdg9oz2PzkOfkTjwCTuXSUCnOP8PS6/v3tLLQBw/xz6u3q9Yvs8tX
WoUb8+20lyxBewMzrlCSZXKzCSQCnkcTEsbuQ5+Bsg5hfCxmSgjOngKzLqQ//0MZ
yf88Gr7+SLwa+MT6pinm9YaBB1D+TqR4ppFnw0FWnUjsOfQUZr1mbLD1CHx6sMEV
5g4c2jy4ZcQ3yD00ROLg70oMQl4PUg==
=R8t7
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 23 Mar 2020 10:47
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40172-done@debbugs.gnu.org)
87tv2fqu62.fsf@gnu.org
Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From c624e0ec8bb4ebe2bb7af6a2d86aafbf072c4891 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Sat, 21 Mar 2020 19:45:14 +0000
> Subject: [PATCH] gnu: add python-gcovr.
>
> * gnu/packages/python-xyz.scm (python-gcovr): New variable.

Applied, thanks!
Closed
?