[PATCH] gnu: zrythm: update to 0.8.156.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 21 Mar 2020 21:01
(name . Guix patches)(address . guix-patches@gnu.org)
46c1ec993845f3742e5997469123d60bd7656d4f.camel@zrythm.org
Hi,

This patch updates Zrythm to 0.8.156.

I also added support for SDL2 (alternative audio backend to JACK) and
RtMidi (alternative MIDI backend to JACK) so Zrythm can be used without
JACK. SDL2 and RtMidi use ALSA and ALSA sequencer respectively, which
unlike JACK require no extra configuration to use them.

Thanks,
Alex
From ebbdffedd65f5d2d10f4ca2e6dc7d029eb00ca31 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 21 Mar 2020 19:56:43 +0000
Subject: [PATCH] gnu: zrythm: update to 0.8.156.

* gnu/packages/music.scm (zrythm): Update to 0.8.156.
---
gnu/packages/music.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 468be9937f..05f5ef5697 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5161,7 +5161,7 @@ and as an LV2 plugin.")
(define-public zrythm
(package
(name "zrythm")
- (version "0.7.573")
+ (version "0.8.156")
(source
(origin
(method url-fetch)
@@ -5169,13 +5169,14 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "075gq478xbzz5ql4fsrgfzhgxi7z26k6034lhlkmm0klfcb8j9mg"))))
+ "0m6052msvgrvs6zy3xiz0vjkf9mbq7w4dhikfmdwqry6c86gkd23"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:configure-flags
`("-Denable_tests=true" "-Dmanpage=true"
- "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true"
+ "-Denable_rtmidi=true" "-Denable_sdl=true")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-xdg-open
@@ -5194,18 +5195,19 @@ and as an LV2 plugin.")
("gettext" ,gettext-minimal)
("glibc" ,glibc)
("gtk+" ,gtk+)
+ ("libaudec" ,libaudec)
("libcyaml" ,libcyaml)
("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)
("libyaml" ,libyaml)
("lilv" ,lilv)
- ("xdg-utils" ,xdg-utils)
- ("rubberband" ,rubberband)))
+ ("rubberband" ,rubberband)
+ ("rtmidi" ,rtmidi)
+ ("sdl2" ,sdl2)
+ ("xdg-utils" ,xdg-utils)))
(native-inputs
`(("pkg-config" ,pkg-config)
("help2man" ,help2man)
- ("libaudec" ,libaudec)
- ("lv2" ,lv2)
("glib" ,glib "bin"))) ;for 'glib-compile-resources'
(synopsis "Digital audio workstation focusing on usability")
(description "Zrythm is a digital audio workstation designed to be
--
2.25.1
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl52crEACgkQAi6uQjE9
cPNY/Qf/WFbGMCPc1CcOc4HZQQj14LIf6Zke2bttwTysZdCz4hKIOWQLdR3n/qjr
Vq0ryKJ2bw9IXq6QZQCf6Rzt/J3i+u686e5hPBOco9vncqt+bPvvmsH3VdQsn4KL
9TDLljuC8vGB+vCiBo6fo8ej2rLqCjLwWVpmFwpMtHFzfvAyMFEWTVxUWC778QLF
TSu6jdIq3x6pBTTZirU1tVurvf9K0ifJbBkLr6yW9aHvTyUjtlVUxvqT+Ay5vRHw
FQisrpIYI0/STZn7EXoIfJiyNz4L2HbbtzsnC0QXj0vMpRuaLyv8YEnmhFqM6d69
Mk9aSgjpUcbC3I6ZwTrRv11KIUbLmw==
=vjGd
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 23 Mar 2020 21:05
(address . guix-patches@gnu.org)(address . 40174@debbugs.gnu.org)
871rpizvk0.fsf@gmail.com
Hello Alexandros,

Could you separate the update part from the rest and propose two
different patches?

Thanks,

Mathieu
A
A
Alexandros Theodotou wrote on 4 Apr 2020 23:48
(address . 40174@debbugs.gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
4accccf8d2d773ca540d2dded5a5a0bb7db864cd.camel@zrythm.org
Toggle quote (9 lines)
> Hello Alexandros,
>
> Could you separate the update part from the rest and propose two
> different patches?
>
> Thanks,
>
> Mathieu

Hi Mathieu,

I updated it to 0.8.200. The only change I made in this patch besides
the version is the mandatory guile dependency. This can't be split.

I will send the rest of the changes in another ticket when the next
version is released.

Thanks,
Alex
From 312ca1d579684c5a9ae327179c5337961f6e4bfd Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Sat, 4 Apr 2020 22:42:57 +0100
Subject: [PATCH] gnu: zrythm: Update to 0.8.200.

* gnu/packages/music.scm (zrythm): Update to 0.8.200.
---
gnu/packages/music.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7d0cfe8665..4ae51c48cd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5161,7 +5161,7 @@ and as an LV2 plugin.")
(define-public zrythm
(package
(name "zrythm")
- (version "0.7.573")
+ (version "0.8.200")
(source
(origin
(method url-fetch)
@@ -5169,7 +5169,7 @@ and as an LV2 plugin.")
version ".tar.xz"))
(sha256
(base32
- "075gq478xbzz5ql4fsrgfzhgxi7z26k6034lhlkmm0klfcb8j9mg"))))
+ "13ivxbrd44qnhyh46dcr94dvqxg8cn4bbd8xm77ljw0p9b4ks4zs"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -5194,6 +5194,7 @@ and as an LV2 plugin.")
("gettext" ,gettext-minimal)
("glibc" ,glibc)
("gtk+" ,gtk+)
+ ("guile" ,guile-2.2)
("libcyaml" ,libcyaml)
("libsamplerate" ,libsamplerate)
("libsndfile" ,libsndfile)
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6JAKwACgkQAi6uQjE9
cPMxNgf9FLm2MBs4g9MayY/ylVc1bxqOXZ+Y8Aa48UB6rgVWZ/PKyY1SuZv0fLw7
8EHogAirPOVddRMnqLkzwxZNJRvXd+pr5COYmMLuGFKuXhWTMtIejGW4rhAq3pRE
cdEFMsTRM+liAjbe9XYk1P3rq99+z5aC/FJvmh/5KzlE+WJkGwf6srvV3FTh3/0B
rE8n5rERLuK3KN9TuZbumTk/0WsNgKTAbW2mZCUgqObTY8CofewTyvOvIRFtuHko
jqWy1Gqj6+1UARGA0KzWWX8yM2FEJ8z1b1M6PZ3TJFML7ae8dP0qzDFoRJ5FoXWy
tHBbIEwzmrA2EdiND8GWVwLZqv/5zQ==
=1tCI
-----END PGP SIGNATURE-----


M
M
Mathieu Othacehe wrote on 5 Apr 2020 10:38
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40174-done@debbugs.gnu.org)
87d08mtji6.fsf@gmail.com
Hello,

Toggle quote (6 lines)
> I updated it to 0.8.200. The only change I made in this patch besides
> the version is the mandatory guile dependency. This can't be split.
>
> I will send the rest of the changes in another ticket when the next
> version is released.

Ok, pushed with a sligtly edited commit message.

Thanks,

Mathieu
Closed
?