[PATCH] gnu: Add emacs-dhall-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 29 Mar 2020 03:20
(address . guix-patches@gnu.org)
878sjk2byr.fsf@asu.edu
Hi Guix!

dhall-mode provides language support for the dhall configuration
language.

Thanks!

John
Toggle quote (1 lines)
>From 0dba0653113f6e880cb590fdfab473a8d74d5a5b Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:38:05 -0700
Subject: [PATCH] gnu: Add emacs-dhall-mode.

* gnu/packages/emacs-xyz.scm (emacs-dhall-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..1c7a3a4f6d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,27 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-dhall-mode
+ (package
+ (name "emacs-dhall-mode")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/psibi/dhall-mode")
+ (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))
+ (inputs
+ `(("emacs-reformatter" ,emacs-reformatter)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/psibi/dhall-mode")
+ (synopsis "Major mode for working with Dhall configuration language")
+ (description
+ "Emacs Major mode for working with Dhall configuration language.")
+ (license license:gpl2+)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Mar 2020 19:24
(name . John Soo)(address . jsoo1@asu.edu)(address . 40304@debbugs.gnu.org)
87wo7169il.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (3 lines)
> dhall-mode provides language support for the dhall configuration
> language.

Thank you.

Toggle quote (5 lines)
> +(define-public emacs-dhall-mode
> + (package
> + (name "emacs-dhall-mode")
> + (version "0.1.0")

This version is not accurate. The ".el" file mentions 0.1.3, but I think
we should use Github versioning, i.e., there is no versioning at all, so
we should do the commit + revision dance again, and use "0.1.3" as the
base of the version string.

Toggle quote (8 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/psibi/dhall-mode")
> + (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2")))

This should go in a dedicated variable.

Toggle quote (5 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))

Nitpick: I usually put `base32' on the same line as the string.

Toggle quote (2 lines)
> + (inputs

Nitpick: Emacs build system uses `propagated-inputs', although this is
the same.

Toggle quote (3 lines)
> + `(("emacs-reformatter" ,emacs-reformatter)))
> + (build-system emacs-build-system)

Nitpick: `build-system' is usually above

Toggle quote (6 lines)
> + (synopsis "Major mode for working with Dhall configuration language")
> + (description
> + "Emacs Major mode for working with Dhall configuration
> language.")

The description must be a full sentence.

Toggle quote (2 lines)
> + (license license:gpl2+)))

The license looks wrong. I see GPL3+ in this package.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
J
J
John Soo wrote on 30 Mar 2020 20:39
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40304@debbugs.gnu.org)
87y2rhvg96.fsf@asu.edu
Hi Nicolas,

Thanks again!

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (19 lines)
> Hello,
>
> John Soo <jsoo1@asu.edu> writes:
>
>> dhall-mode provides language support for the dhall configuration
>> language.
>
> Thank you.
>
>> +(define-public emacs-dhall-mode
>> + (package
>> + (name "emacs-dhall-mode")
>> + (version "0.1.0")
>
> This version is not accurate. The ".el" file mentions 0.1.3, but I think
> we should use Github versioning, i.e., there is no versioning at all, so
> we should do the commit + revision dance again, and use "0.1.3" as the
> base of the version string.

Done.

Toggle quote (10 lines)
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri
>> + (git-reference
>> + (url "https://github.com/psibi/dhall-mode")
>> + (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2")))
>
> This should go in a dedicated variable.

Did you mean the commit? If so that is also done.

Toggle quote (7 lines)
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))
>
> Nitpick: I usually put `base32' on the same line as the string.

Ok, I like that better. Done.

Toggle quote (5 lines)
>> + (inputs
>
> Nitpick: Emacs build system uses `propagated-inputs', although this is
> the same.

Oh! I think that's a bug, then. If the input is not propagated, there
will be an error when the user uses the package, right? Fixed.

Toggle quote (5 lines)
>> + `(("emacs-reformatter" ,emacs-reformatter)))
>> + (build-system emacs-build-system)
>
> Nitpick: `build-system' is usually above

No problem. Done.

Toggle quote (8 lines)
>> + (synopsis "Major mode for working with Dhall configuration language")
>> + (description
>> + "Emacs Major mode for working with Dhall configuration
>> language.")
>
> The description must be a full sentence.

Fixed and added some more detail.

Toggle quote (4 lines)
>> + (license license:gpl2+)))
>
> The license looks wrong. I see GPL3+ in this package.

Ah, fixed, sorry.

Toggle quote (2 lines)
> Could you send an updated patch?

Sure. Attached.

Thanks again,

John
From f964bffab06a381e6476410e5dd409ac5b690fd3 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:38:05 -0700
Subject: [PATCH] gnu: Add emacs-dhall-mode.

* gnu/packages/emacs-xyz.scm (emacs-dhall-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c029d1ed3d..fa64ef16bc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21965,3 +21965,37 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-dhall-mode
+ (let ((revision "0")
+ (commit "ef4d33debe224c6ba37e51a29b9dc8b74f20f1c2"))
+ (package
+ (name "emacs-dhall-mode")
+ (version (git-version "0.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/psibi/dhall-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1232y2k4l3bsz90pgis78zxmrw7jv09dfaip21yc1w4vpxfyr384"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-reformatter" ,emacs-reformatter)))
+ (home-page "https://github.com/psibi/dhall-mode")
+ (synopsis "Major mode for working with Dhall configuration language")
+ (description
+ "Dhall-mode provides an Emacs Major mode for working with the Dhall
+configuration language. It features:
+
+@itemize
+@item Syntax highlighting
+@item Multiline support for String
+@item Basic indendation, commenting
+@item Automatic formatting on save using dhall-format.
+@item Error highlighting.
+@end itemize")
+ (license license:gpl3+))))
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Mar 2020 22:43
(name . John Soo)(address . jsoo1@asu.edu)(address . 40304-done@debbugs.gnu.org)
87h7y560bg.fsf@nicolasgoaziou.fr
John Soo <jsoo1@asu.edu> writes:

Toggle quote (4 lines)
> Subject: [PATCH] gnu: Add emacs-dhall-mode.
>
> * gnu/packages/emacs-xyz.scm (emacs-dhall-mode): New variable.

Applied as 47fc5229eb8cda8c97801f71eb4bdb1fd9b26123. I added a comment
about the lack of proper versioning.

Thank you!
Closed
?