[PATCH] gnu: Add emacs-elf-mode

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 29 Mar 2020 03:23
(address . guix-patches@gnu.org)
875zeo2btu.fsf@asu.edu
Hi Guix!

This almost the last emacs package I use that I could not get from guix.

elf-mode shows symbol information in elf object files.

Thanks!

John
Toggle quote (1 lines)
>From 4c8a0421561f1d2325028563bcd0060edf5a3d25 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 24 Mar 2020 08:42:14 -0700
Subject: [PATCH] gnu: Add emacs-elf-mode.

* gnu/packages/emacs-xyz.scm (emacs-elf-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d40b8019e..499164ab13 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 6033fe7de85d <6033fe7de85d@airmail.cc>
+;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21776,3 +21777,24 @@ enables modal editing and composition of commands, too. It combines ideas of
other Editors like Vim or Kakoune and tries to align them with regular Emacs
conventions.")
(license license:gpl3+)))
+
+(define-public emacs-elf-mode
+ (package
+ (name "emacs-elf-mode")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/abo-abo/elf-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cbvjbk2893ag1iy8ggixpirfiyhssm7fii96hb9jqdz874cdl0k"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/elf-mode")
+ (synopsis "Show symbol list when opening a binary file in Emacs")
+ (description "Show symbol list when opening a binary file in Emacs.")
+ (license license:gpl2+)))
--
2.26.0
N
N
Nicolas Goaziou wrote on 1 Apr 2020 10:45
(name . John Soo)(address . jsoo1@asu.edu)(address . 40305-done@debbugs.gnu.org)
87sghn388d.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-elf-mode): New variable.

Thank you!

I fixed the license field, reworded the description, and applied it as
31e47945d37a738fccbb5c7e304f01ccfdd45a68.

Regards,

--
Nicolas Goaziou
Closed
?