[PATCH] ui: Mention that changes to package definitions can cause "upgrades".

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 31 Mar 2020 17:15
(address . guix-patches@gnu.org)
c2ca777e9b3e9dbdc80d85ef02b3d27407f1122a.1585667732.git.leo@famulari.name
* guix/ui.scm (show-manifest-transaction)[upgrade-string]: Use the
package name in UI message.
---
guix/ui.scm | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)

Toggle diff (31 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index 1e24fe5dca..20b1e79ca9 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1162,11 +1163,13 @@ separator between subsequent columns."
name
(string-append name ":" output)))
names outputs)
- (map (lambda (old new)
+ (map (lambda (old new name)
(if (string=? old new)
- (G_ "(dependencies changed)")
+ (format
+ (G_ "(dependencies or ~a package recipe changed)")
+ name)
(string-append old " " → " " new)))
- old-version new-version))
+ old-version new-version names))
#:initial-indent 3))
(let-values (((remove install upgrade downgrade)
--
2.26.0
L
L
Ludovic Courtès wrote on 1 Apr 2020 23:03
(name . Leo Famulari)(address . leo@famulari.name)(address . 40350@debbugs.gnu.org)
871rp6udet.fsf@gnu.org
Hi,

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (3 lines)
> * guix/ui.scm (show-manifest-transaction)[upgrade-string]: Use the
> package name in UI message.

[...]

Toggle quote (5 lines)
> (if (string=? old new)
> - (G_ "(dependencies changed)")
> + (format
> + (G_ "(dependencies or ~a package recipe changed)")

Is that not implied in a way?

If it is, how about something shorter like:

(dependencies or package changed)

?

Thanks,
Ludo’.
L
L
Leo Famulari wrote on 1 Apr 2020 23:13
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40350@debbugs.gnu.org)
20200401211352.GA9794@jasmine.lan
On Wed, Apr 01, 2020 at 11:03:22PM +0200, Ludovic Court�s wrote:
Toggle quote (2 lines)
> Is that not implied in a way?

It is, but I think we will still get some confused users asking about
it.

Toggle quote (4 lines)
> If it is, how about something shorter like:
>
> (dependencies or package changed)

Yeah, I think that's okay.
L
L
Ludovic Courtès wrote on 2 Apr 2020 10:05
(name . Leo Famulari)(address . leo@famulari.name)(address . 40350-done@debbugs.gnu.org)
87v9miqpn2.fsf@gnu.org
Hi,

Leo Famulari <leo@famulari.name> skribis:

Toggle quote (12 lines)
> On Wed, Apr 01, 2020 at 11:03:22PM +0200, Ludovic Courtès wrote:
>> Is that not implied in a way?
>
> It is, but I think we will still get some confused users asking about
> it.
>
>> If it is, how about something shorter like:
>>
>> (dependencies or package changed)
>
> Yeah, I think that's okay.

OK, done!

Thanks,
Ludo’.
Closed
?