[PATCH] gnu: mingw: Add mingw-w64 reproducibility patches.

  • Done
  • quality assurance status badge
Details
2 participants
  • Carl Dong
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Carl Dong
Severity
normal
C
C
Carl Dong wrote on 3 Apr 2020 21:00
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
TFJ3KFdzss8x3iIQDztktT8NyOvMJTqRASIqqlWzp5E6j77Z-sFmso0qq3F4s6AzsQzGYoG6Ow1exH0pKB1us698u8S6uMWv2gP6RegSPfw=@carldong.me
Round 2! Now for some patches applied to mingw-w64 itself, rather than just binutils.

I've checked:
- That the mode of the patches are correct
- guix build mingw-w64-{x86_64,i686}{,-winpthreads}
- guix build hello

-----

These patches were originally found at the debian mingw-w64 team's
mingw-w64 repo, and should improve the reproducibility of our mingw-w64
toolchain.

* gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file.
* gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file.
* gnu/local.mk (dist_patch_DATA): Update accordingly.
* gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
---
gnu/local.mk | 2 ++
gnu/packages/mingw.scm | 4 ++-
.../mingw-w64-dlltool-temp-prefix.patch | 26 +++++++++++++++++++
.../mingw-w64-reproducible-gendef.patch | 23 ++++++++++++++++
4 files changed, 54 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
create mode 100644 gnu/packages/patches/mingw-w64-reproducible-gendef.patch

Toggle diff (89 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 8328165e17..713d97da86 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1201,6 +1201,8 @@ dist_patch_DATA = \
%D%/packages/patches/metabat-fix-compilation.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
+ %D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
+ %D%/packages/patches/mingw-w64-reproducible-gendef.patch \
%D%/packages/patches/minisat-friend-declaration.patch \
%D%/packages/patches/minisat-install.patch \
%D%/packages/patches/mpc123-initialize-ao.patch \
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index d0785c5067..37726e5851 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -53,7 +53,9 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
(sha256
(base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
- (patches (search-patches "mingw-w64-6.0.0-gcc.patch"))))
+ (patches (search-patches "mingw-w64-6.0.0-gcc.patch"
+ "mingw-w64-dlltool-temp-prefix.patch"
+ "mingw-w64-reproducible-gendef.patch"))))
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
,@(if with-winpthreads?
diff --git a/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
new file mode 100644
index 0000000000..432cafc162
--- /dev/null
+++ b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
@@ -0,0 +1,26 @@
+This following patch was originally found at the debian mingw-w64 team's
+mingw-w64 repo located here:
+https://salsa.debian.org/mingw-w64-team/mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
+
+Description: Specify dlltool's temp prefix
+Author: Stephen Kitt <steve@sk2.org>
+
+By default dlltool uses its pid for the object files it generates.
+Enforcing its temp prefix allows the files it generates to be
+reproducible.
+
+--- a/mingw-w64-crt/Makefile.am
++++ b/mingw-w64-crt/Makefile.am
+@@ -36,7 +36,7 @@
+ DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
+ DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
+ else
+- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
++ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
+ DLLTOOLFLAGSARM32=-m arm
+ DLLTOOLFLAGSARM64=-m arm64
+ DLLTOOLFLAGS32=--as-flags=--32 -m i386
diff --git a/gnu/packages/patches/mingw-w64-reproducible-gendef.patch b/gnu/packages/patches/mingw-w64-reproducible-gendef.patch
new file mode 100644
index 0000000000..ee676af7a0
--- /dev/null
+++ b/gnu/packages/patches/mingw-w64-reproducible-gendef.patch
@@ -0,0 +1,23 @@
+This following patch was originally found at the debian mingw-w64 team's
+mingw-w64 repo located here:
+https://salsa.debian.org/mingw-w64-team/mingw-w64.git
+
+Invoke the following in the aforementioned repo to see the original patch:
+
+ $ git show 4974e2c:debian/patches/reproducible-gendef.patch
+
+Description: Drop __DATE__ from gendef
+Author: Stephen Kitt <skitt@debian.org>
+
+This allows gendef to be built reproducibly.
+
+--- a/mingw-w64-tools/gendef/src/gendef.c
++++ b/mingw-w64-tools/gendef/src/gendef.c
+@@ -196,7 +196,6 @@
+ " By default, the output files are named after their DLL counterparts\n"
+ " gendef MYDLL.DLL Produces MYDLL.def\n"
+ " gendef - MYDLL.DLL Prints the exports to stdout\n");
+- fprintf (stderr, "\nBuilt on %s\n", __DATE__);
+ fprintf (stderr, "\nReport bugs to <mingw-w64-public@lists.sourceforge.net>\n");
+ exit (0);
+ }
--
2.25.1

</mingw-w64-public@lists.sourceforge.net></skitt@debian.org></steve@sk2.org>
M
M
Mathieu Othacehe wrote on 4 Apr 2020 12:54
(name . Carl Dong)(address . contact@carldong.me)(address . 40414@debbugs.gnu.org)
871rp3v7vk.fsf@gmail.com
Hello Carl,

This patch LGTM. Do you know if there are plans to apply those patches
mainline?

Thanks,

Mathieu
M
M
Mathieu Othacehe wrote on 4 Apr 2020 13:00
(name . Carl Dong)(address . contact@carldong.me)(address . 40414@debbugs.gnu.org)
87wo6vtt0a.fsf@gmail.com
Toggle quote (4 lines)
> + (patches (search-patches "mingw-w64-6.0.0-gcc.patch"
> + "mingw-w64-dlltool-temp-prefix.patch"
> + "mingw-w64-reproducible-gendef.patch"))))

Also you can add a break after "patches" so that you respect the 78
columns limit, this way:

Toggle snippet (6 lines)
(patches
(search-patches "mingw-w64-6.0.0-gcc.patch"
"mingw-w64-dlltool-temp-prefix.patch"
"mingw-w64-reproducible-gendef.patch"))))

Thanks,

Mathieu
C
C
Carl Dong wrote on 4 Apr 2020 21:46
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)(address . 40414@debbugs.gnu.org)
D3C57379-D934-4212-8BDA-6EA1F491CD16@carldong.me
Great to hear Mathieu, I will push my changes along with the line break suggestion.

Not sure about plans to apply patches mainline… I will reach out to the original author to ask about this.

Cheers,
Carl Dong

Toggle quote (12 lines)
> On Apr 4, 2020, at 6:54 AM, Mathieu Othacehe <m.othacehe@gmail.com> wrote:
>
>
>
> Hello Carl,
>
> This patch LGTM. Do you know if there are plans to apply those patches
> mainline?
>
> Thanks,
>
> Mathieu
M
M
Mathieu Othacehe wrote on 5 Apr 2020 11:28
(name . Carl Dong)(address . contact@carldong.me)(address . 40414-done@debbugs.gnu.org)
87k12us2mb.fsf@gmail.com
Hey,

Toggle quote (2 lines)
> Not sure about plans to apply patches mainline… I will reach out to the original author to ask about this.

Great, don't forget to close the ticket once pushed :)

Thanks,

Mathieu
Closed
?