[PATCH] reconfigure: Don't call build-derivations for upgrade-services test

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 7 Apr 2020 23:14
(address . guix-patches@gnu.org)
20200407211433.1620-1-mail@cbaines.net
This commit adjusts the upgrade-services system test to not build anything
when computing the derivation for the system test. I came across this when
looking at issues computing the system test derivations to store in the Guix
Data Service.

* gnu/tests/reconfigure.scm (run-upgrade-services-test): Remove the use of,
and definition for ensure-service-file.
---
gnu/tests/reconfigure.scm | 16 +++++-----------
1 file changed, 5 insertions(+), 11 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/tests/reconfigure.scm b/gnu/tests/reconfigure.scm
index 8b85920979..928a210a94 100644
--- a/gnu/tests/reconfigure.scm
+++ b/gnu/tests/reconfigure.scm
@@ -136,14 +136,6 @@ Shepherd (PID 1) by unloading obsolete services and loading new services."
(stop #~(const #t))
(respawn? #f)))
- ;; Return the Shepherd service file for SERVICE, after ensuring that it
- ;; exists in the store.
- (define (ensure-service-file service)
- (let ((file (shepherd-service-file service)))
- (mlet* %store-monad ((store-object (lower-object file))
- (_ (built-derivations (list store-object))))
- (return file))))
-
(define (test enable-dummy disable-dummy)
(with-imported-modules '((gnu build marionette))
#~(begin
@@ -187,10 +179,12 @@ Shepherd (PID 1) by unloading obsolete services and loading new services."
(test-end)
(exit (= (test-runner-fail-count (test-runner-current)) 0)))))
- (mlet* %store-monad ((file (ensure-service-file dummy-service)))
- (let ((enable (upgrade-services-program (list file) '(dummy) '() '()))
+ (gexp->derivation
+ "upgrade-services"
+ (let* ((file (shepherd-service-file dummy-service))
+ (enable (upgrade-services-program (list file) '(dummy) '() '()))
(disable (upgrade-services-program '() '() '(dummy) '())))
- (gexp->derivation "upgrade-services" (test enable disable)))))
+ (test enable disable))))
(define* (run-install-bootloader-test)
"Run a test of an OS running INSTALL-BOOTLOADER-PROGRAM, which installs a
--
2.26.0
L
L
Ludovic Courtès wrote on 23 Apr 2020 23:49
(name . Christopher Baines)(address . mail@cbaines.net)(address . 40497@debbugs.gnu.org)
87r1wdlvom.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (8 lines)
> This commit adjusts the upgrade-services system test to not build anything
> when computing the derivation for the system test. I came across this when
> looking at issues computing the system test derivations to store in the Guix
> Data Service.
>
> * gnu/tests/reconfigure.scm (run-upgrade-services-test): Remove the use of,
> and definition for ensure-service-file.

LGTM, thanks!

Ludo’.
C
C
Christopher Baines wrote on 26 Apr 2020 20:44
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 40497-done@debbugs.gnu.org)
87368qnl30.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (12 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This commit adjusts the upgrade-services system test to not build anything
>> when computing the derivation for the system test. I came across this when
>> looking at issues computing the system test derivations to store in the Guix
>> Data Service.
>>
>> * gnu/tests/reconfigure.scm (run-upgrade-services-test): Remove the use of,
>> and definition for ensure-service-file.
>
> LGTM, thanks!

Great, I've pushed this as 53aa66c3dff8a59b5c596691d9126db6a2327983,
thanks for taking a look!

Chris
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl6l1oNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcnAxAApdeEJhDEGO3wux8rtE3K6ixHm1rX7Ep82qt16KgwPPMo8uK26F5DLJTW
eGYnlopZvW17MpC5fCNAee7IWzSxqea0LT1GFbYKaf0GaZWfDPyns1dhS5oXtUoV
6z6GXxgP25zlEiBEdodU5i+cTSVR8KI1f6nbqgNYyyemmJCaSUE92M28Pq0YEO7T
cKQYCOSeUDhnAcjvWbfnaw+oeS7AY6no3gaIPovmzbM1+AfNnkVQy183Hvrad6Ff
0MVTCoC4C0qC3atVaOWBISdvyLafSHhu2hixOvJnRSlf8/yqgrBGFUusuiw8iIpA
pGqDy29KnxNvu03x3bN03kFoZN3vUTwVs6LqHXcgJnD+waDBHkBNgUhX2AWR4/EZ
cJuh9nnenQX7/cD1ATOKfng0ySIsBY3QI5j1yNrw9VJAErryNlzeGcp+J4uFuIN3
HjFmbBsI1SbIDBt7VOqNxmmbKznaKvdpl2IXYiFNPcmoKTQTUu3Jb6CM3SETrVes
Ta+R4rJLA9+ZTmwUTpraH5y+cegSrhjW3t3DbxQWl4Sndxt2dgX8aMwNNM+WJHW1
5SIks84N1jHn+qDD/uOVhxF7NkwD9+UrF6dSf7aDV3SLII7IEwQS0wjy0GQ1u9Pi
6oxuYVhI3f/KK9h7zIK69WEjnTmxYM1RW6yljDbeyVTuQqfUaOc=
=ueNX
-----END PGP SIGNATURE-----

Closed
?