[PATCH] gnu: Add emacs-dired-git-info.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Nicolas Goaziou
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 8 Apr 2020 03:52
(address . guix-patches@gnu.org)
87blo2u4jo.fsf@asu.edu
Hi Guix,

emacs-dired-git-info shows the last commit message and commit date next
to each file in dired. I like it a lot.

This time I also remembered to lint and format the patch
correctly. Sorry about the previous flurry!

Thanks,

John
From 87367ebd35954f19c6a1b03791cc54581b5449dc Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 7 Apr 2020 01:05:47 -0700
Subject: [PATCH] gnu: Add emacs-dired-git-info.

* gnu/packages/emacs-xyz.scm (emacs-dired-git-info): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9e1160f0e1..ab7f9b8a18 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9178,6 +9178,28 @@ above over the network.")
in Org buffers and displays matching entries.")
(license license:gpl3+)))
+(define-public emacs-dired-git-info
+ (let ((commit "91d57e3a4c5104c66a3abc18e281ee55e8979176"))
+ (package
+ (name "emacs-dired-git-info")
+ (version (git-version "0.3.1" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/clemera/dired-git-info")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dr4iv95s4barxxj56znqkl9z0lg5jw731jmjr01s6vn8ar69gik"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/clemera/dired-git-info")
+ (synopsis "Show git info in Emacs dired")
+ (description "This Emacs packages provides a minor mode which shows git
+information inside the dired buffer.")
+ (license license:gpl3+))))
+
(define-public emacs-dired-toggle-sudo
(package
(name "emacs-dired-toggle-sudo")
--
2.26.0
N
N
Nicolas Goaziou wrote on 10 Apr 2020 18:31
(name . John Soo)(address . jsoo1@asu.edu)(address . 40500-done@debbugs.gnu.org)
877dyn4800.fsf@nicolasgoaziou.fr
Hello,

John Soo <jsoo1@asu.edu> writes:

Toggle quote (6 lines)
> emacs-dired-git-info shows the last commit message and commit date next
> to each file in dired. I like it a lot.
>
> This time I also remembered to lint and format the patch
> correctly. Sorry about the previous flurry!

This patch applied blissfully, as
757f2c1effe7d51d497f83c9d22bf8de066d8555.

Thank you.

Regards,
--
Nicolas Goaziou
Closed
?