[PATCH] gnu: Add wolf-shaper.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Apr 2020 18:31
(name . Guix patches)(address . guix-patches@gnu.org)
8bac4beb758b4ab138718cd0f9211da1b69e6d63.camel@zrythm.org
Hi,

These patches add wolf-spectrum and wolf-shaper, 2 LV2 plugins.

Thanks,
Alex
From ff5050712a95e5dc84325ecceac50f84cd71ee14 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:30:45 +0100
Subject: [PATCH 2/2] gnu: Add wolf-spectrum.

* gnu/packages/music.scm (wolf-spectrum): New variable.
---
gnu/packages/music.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1f9b1e543b..f16593ea6c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5479,3 +5479,26 @@ plugin and a standalone JACK application.")
It is provided as an LV2 plugin and as a standalone Jack application.")
(home-page "https://pdesaulniers.github.io/wolf-shaper/")
(license license:gpl3)))
+
+(define-public wolf-spectrum
+ (package
+ (inherit wolf-shaper)
+ (name "wolf-spectrum")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdesaulniers/wolf-spectrum")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17db1jlj7vb1xyvkdhhrsvdbwb7jqw6i4168cdvlj3yvn2ra8gpm"))))
+ (synopsis "2D spectrogram plugin")
+ (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+ (home-page "https://pdesaulniers.github.io/wolf-shaper/")
+ (license license:gpl3)))
--
2.26.0
From 80dbd4b8eea3beea8eb312acdb56374f486bb9b7 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:21:19 +0100
Subject: [PATCH 1/2] gnu: Add wolf-shaper.

* gnu/packages/music.scm (wolf-shaper): New variable.
---
gnu/packages/music.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 5257d9463a..1f9b1e543b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5422,3 +5422,60 @@ plugin and a standalone JACK application.")
offers an LV2 version ported by moddevices.")
(home-page "http://tap-plugins.sourceforge.net/")
(license license:gpl2))))
+
+(define-public wolf-shaper
+ (package
+ (name "wolf-shaper")
+ (version "0.1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdesaulniers/wolf-shaper.git")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lllgcbnnh1m95bp29hh17x170hl7170zizjrvy892qfkn36830d"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags (list "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure target
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lv2 (string-append out "/lib/lv2")))
+ ;; Install LV2.
+ (for-each
+ (lambda (file)
+ (copy-recursively file
+ (string-append lv2 "/" (basename file))))
+ (find-files "bin" "\\.lv2$" #:directories? #t))
+ ;; Install executables.
+ (for-each
+ (lambda (file)
+ (install-file file bin))
+ (find-files "bin"
+ (lambda (name stat)
+ (and
+ (equal? (dirname name) "bin")
+ (not (string-suffix? ".so" name))
+ (not (string-suffix? ".lv2" name))))))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)))
+ (synopsis "Waveshaper plugin")
+ (description "Wolf Shaper is a waveshaper plugin with a graph editor.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+ (home-page "https://pdesaulniers.github.io/wolf-shaper/")
+ (license license:gpl3)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6N/HIACgkQAi6uQjE9
cPPKUgf8DAqRE2ftRq30ImDs5zftqaL2xndwFiCjxFbfGg+uPLbIINHwSE3NLIEb
kFHtY1VOaLEz02zoUVr6y8IZTFOO1LjXTKsMoucaEafn+d2Ik8mKb58dttGLHChv
GAWwr84oShO5XyihbBxl7CDaerAP7v2iB51k19YMGLg7/99LCn6fsTLW2KXSpxB4
qjs/nfq8z3jmLCgqN8ywcOtPTIvD2X27eFsh2aqOTMrM13phaDkrZGoVzSJdLBXt
Yh11pw0F3eXf1yE4OzFfgiwRqGSrlhJTWglx+ySPBOcW+8F/Vk0tdaUSfggfZU/m
b5ENn4YWaTJ3/a32Cv/qWJzDdQrMcw==
=d7S/
-----END PGP SIGNATURE-----


A
A
Alexandros Theodotou wrote on 8 Apr 2020 18:37
(address . 40510@debbugs.gnu.org)
8f1ab59c54c7341189456a2d470b3e14b3a5a5ef.camel@zrythm.org
Reattaching wolf-spectrum (forgot to change the homepage).
From 0b0f8211055488a3f22fdc1114d6b43cfa983d33 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Wed, 8 Apr 2020 17:30:45 +0100
Subject: [PATCH 2/2] gnu: Add wolf-spectrum.

* gnu/packages/music.scm (wolf-spectrum): New variable.
---
gnu/packages/music.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 1f9b1e543b..c0f4e277cb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5479,3 +5479,26 @@ plugin and a standalone JACK application.")
It is provided as an LV2 plugin and as a standalone Jack application.")
(home-page "https://pdesaulniers.github.io/wolf-shaper/")
(license license:gpl3)))
+
+(define-public wolf-spectrum
+ (package
+ (inherit wolf-shaper)
+ (name "wolf-spectrum")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pdesaulniers/wolf-spectrum")
+ (commit (string-append "v" version))
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17db1jlj7vb1xyvkdhhrsvdbwb7jqw6i4168cdvlj3yvn2ra8gpm"))))
+ (synopsis "2D spectrogram plugin")
+ (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
+It is provided as an LV2 plugin and as a standalone Jack application.")
+ (home-page "https://github.com/pdesaulniers/wolf-spectrum")
+ (license license:gpl3)))
--
2.26.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl6N/cIACgkQAi6uQjE9
cPNVUgf6A9kunOckzvYZ85f8xLQ5ikck6Dq8S8V1KkaoUDj6/vxmz0NmrLrsUwTy
FBAjsbIfWgGbPIACHd+fK0npiDvtTB/wGWIB+BsAkVwipG4bJAl4y7RMQY59rKjU
HL3q8lKDf8JGvaK87hduHfHGEmweN/iv8HeFA/F3K/3Uz7l1vkYAbLINlDlN9KX1
acs3cx8Tw+0OI/5/CChkw31NHOewuB8DPEVpsuyo+ppFMUgUrqotQvQYLYMnXDPe
eun+2jLHeqFOTQIxbrObfdwQVKYkKMMghNc+9H7RHxM4xauVLTexMza1v1maN6kR
VMOvLfzMpWfER+fezzzHunCPgXjO+g==
=rWF5
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 23 Apr 2020 23:59
Re: [bug#40510] [PATCH] gnu: Add wolf-shaper.
(name . Alexandros Theodotou)(address . alex@zrythm.org)(address . 40510-done@debbugs.gnu.org)
87imhplv8a.fsf@gnu.org
Hi Alexandros,

Alexandros Theodotou <alex@zrythm.org> skribis:

Toggle quote (7 lines)
> From ff5050712a95e5dc84325ecceac50f84cd71ee14 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 8 Apr 2020 17:30:45 +0100
> Subject: [PATCH 2/2] gnu: Add wolf-spectrum.
>
> * gnu/packages/music.scm (wolf-spectrum): New variable.

[...]

Toggle quote (6 lines)
> + (synopsis "2D spectrogram plugin")
> + (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
> +It is provided as an LV2 plugin and as a standalone Jack application.")
> + (home-page "https://pdesaulniers.github.io/wolf-shaper/")
> + (license license:gpl3)))

[...]

Toggle quote (7 lines)
> From 80dbd4b8eea3beea8eb312acdb56374f486bb9b7 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Wed, 8 Apr 2020 17:21:19 +0100
> Subject: [PATCH 1/2] gnu: Add wolf-shaper.
>
> * gnu/packages/music.scm (wolf-shaper): New variable.

[...]

Toggle quote (6 lines)
> + (synopsis "Waveshaper plugin")
> + (description "Wolf Shaper is a waveshaper plugin with a graph editor.
> +It is provided as an LV2 plugin and as a standalone Jack application.")
> + (home-page "https://pdesaulniers.github.io/wolf-shaper/")
> + (license license:gpl3)))

Applied!

Two comments though:

1. I believe the license is really ‘gpl3+’ because I don’t see
anything saying “version 3 only”. However, the situation is a bit
confused because source files apparently still contain the ISC
license header, perhaps an omission since the projects were
apparently recently relicensed.

2. The synopses could be improved: plugin for what? What application
domain? The descriptions could also be expounded a bit, and this
would make ‘guix search’ happier. :-)

Could you follow up on these two things?

Thanks,
Ludo’.
Closed
?