[PATCH] Add ZBackup

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 10 Apr 2020 15:01
(address . guix-patches@gnu.org)
87sghb4hq3.fsf@nicolasgoaziou.fr
Hello,

The following patch adds zbackup.

Feedback welcome.

Regards,

--
Nicolas Goaziou
From 1591f91035de7e2c036ff7a608a729b4420ffa74 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Fri, 10 Apr 2020 14:58:47 +0200
Subject: [PATCH] gnu: Add zbackup.

* gnu/packages/backup.scm (zbackup): New variable.
---
gnu/packages/backup.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 4d24dff0a3..40dfce7094 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -976,6 +977,42 @@ precious backup space.
@end itemize")
(license license:bsd-2)))
+(define-public zbackup
+ (package
+ (name "zbackup")
+ (version "1.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zbackup/zbackup.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14l1kyxg7pccpax3d6qcpmdycb70kn3fxp1a59w64hqy2493hngl"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;no test
+ (inputs
+ `(("lzo" ,lzo)
+ ("libressl" ,libressl)
+ ("protobuf" ,protobuf)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (home-page "http://zbackup.org")
+ (synopsis "Versatile deduplicating backup tool")
+ (description
+ "ZBackup is a globally-deduplicating backup tool, based on the
+ideas found in Rsync. Feed a large @file{.tar} into it, and it will
+store duplicate regions of it only once, then compress and optionally
+encrypt the result. Feed another @file{.tar} file, and it will also
+re-use any data found in any previous backups. This way only new
+changes are stored, and as long as the files are not very different,
+the amount of storage required is very low. Any of the backup files
+stored previously can be read back in full at any time. The program
+is format-agnostic, so you can feed virtually any files to it.")
+ (license license:gpl2+)))
+
(define-public burp
(package
(name "burp")
--
2.26.0
N
N
Nicolas Goaziou wrote on 30 Apr 2020 14:05
Re: bug#40539: Acknowledgement ([PATCH] Add ZBackup)
(name . GNU bug Tracking System)(address . help-debbugs@gnu.org)(address . 40539-done@debbugs.gnu.org)
878sidch6z.fsf@nicolasgoaziou.fr
Applied. Closing.
Closed
R
R
Ricardo Wurmus wrote on 30 Apr 2020 15:35
Re: [bug#40539] [PATCH] Add ZBackup
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 40539@debbugs.gnu.org)
87mu6t5c63.fsf@elephly.net
Hi Nicolas,

Toggle quote (2 lines)
> The following patch adds zbackup.

This broke “guix pull” momentarily because your patch didn’t import two
modules: (guix build-system cmake) and (gnu packages protobuf).

It’s now fixed.

--
Ricardo
N
N
Nicolas Goaziou wrote on 30 Apr 2020 15:37
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 40539@debbugs.gnu.org)
87y2qdaycc.fsf@nicolasgoaziou.fr
Hello,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (3 lines)
> This broke “guix pull” momentarily because your patch didn’t import two
> modules: (guix build-system cmake) and (gnu packages protobuf).

Oh! Apparently, I forgot to "./pre-inst-env guix build" on this one.
Sorry about that.

Toggle quote (2 lines)
> It’s now fixed.

Thank you!

Regards,

--
Nicolas Goaziou
?