[PATCH] gnu: Add gtksheet.

  • Done
  • quality assurance status badge
Details
One participant
  • Arun Isaac
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 14 Apr 2020 17:45
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20200414154535.25800-1-arunisaac@systemreboot.net
* gnu/packages/gtk.scm (gtksheet): New variable.
---
gnu/packages/gtk.scm | 78 +++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 77 insertions(+), 1 deletion(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 4882a95eb8..8dd4901a98 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -1967,3 +1967,79 @@ popovers.")
library for drawing.")
(home-page "https://wiki.gnome.org/GooCanvas")
(license license:lgpl2.0)))
+
+(define-public gtksheet
+ (package
+ (name "gtksheet")
+ (version "4.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fpaquet/gtksheet")
+ (commit (string-append "V" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sa9q7w7q7620id1l9ci5favmcrm4y5yr99pbran4hd0sjka62gh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--enable-glade"
+ "--enable-introspection")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The "configure" script is present, but otherwise the project is
+ ;; not bootstrapped properly. Delete configure so the bootstrap phase
+ ;; will take over.
+ (add-after 'unpack 'delete-configure
+ (lambda _
+ (delete-file "configure")
+ #t))
+ ;; Fix glade install directories.
+ (add-before 'bootstrap 'configure-glade-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "configure.ac"
+ (("`\\$PKG_CONFIG --variable=catalogdir gladeui-2.0`")
+ (string-append (assoc-ref outputs "out") "/share/glade/catalogs"))
+ (("`\\$PKG_CONFIG --variable=moduledir gladeui-2.0`")
+ (string-append (assoc-ref outputs "out") "/lib/glade/modules"))
+ (("`\\$PKG_CONFIG --variable=pixmapdir gladeui-2.0`")
+ (string-append (assoc-ref outputs "out") "/share/pixmaps")))
+ #t))
+ ;; Fix incorrect typelib version. This is a known upstream bug. See
+ ;; https://github.com/fpaquet/gtksheet/issues/23
+ (add-after 'install 'fix-typelib-version
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((girepository (string-append (assoc-ref outputs "out")
+ "/lib/girepository-1.0")))
+ (rename-file (string-append girepository "/GtkSheet-4.0.typelib")
+ (string-append girepository "/GtkSheet-4.3.2.typelib")))
+ #t)))))
+ (inputs
+ `(("glade" ,glade3)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gobject-introspection" ,gobject-introspection)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://fpaquet.github.io/gtksheet/")
+ (synopsis "Spreadsheet widget for GTK+")
+ (description "GtkSheet is a matrix widget for GTK+. It consists of an
+scrollable grid of cells where you can allocate text. Cell contents can be
+edited interactively through a specially designed entry, GtkItemEntry. It is
+also a container subclass, allowing you to display buttons, images and any
+other widget in it. You can also set many attributes such as border,
+foreground and background colors, text justification and more.")
+ (native-search-paths
+ (list
+ (search-path-specification
+ (variable "GLADE_CATALOG_SEARCH_PATH")
+ (files '("share/glade/catalogs")))
+ (search-path-specification
+ (variable "GLADE_MODULE_SEARCH_PATH")
+ (files '("lib/glade/modules")))))
+ (license license:lgpl2.0+)))
--
2.26.0
A
A
Arun Isaac wrote on 9 May 2020 18:41
Re: bug#40627: Acknowledgement ([PATCH] gnu: Add gtksheet.)
(address . 40627-done@debbugs.gnu.org)
cu7o8qx2h7w.fsf@systemreboot.net
Pushed to master!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl623VMACgkQLiXui2GA
K7OxVgf+LfxJH0Xk+Ve//1Nen9jWU8yxAwFPru5tV6n5ilB3EUPtfdsbChZ+D048
cfDiP7l3x1v6HGM10vcvXxxaW0JUDD06MbUsg0S0FgwrxSkbDdQ2ze3XKjp5IIex
TmVOH6gdD9VrNzwfl9b55d2U4orDwjEyjZ4OuVGDnvTc7jlYiEzR3WRfVwxG656C
SVJO11HxAbxJe17fattjC3NpjXD8RCiET0fesVtfKTmo53O19YbqRA0iuIao7fZ+
bPqV8s/doxl20/l/xXiZDRHPuTwz8CdSE4vkA6wo6syWLNFYc92u3C6jz6re2sJg
J7EzIrCx6lLmIZdqrcg2PGtSD81DkA==
=X34z
-----END PGP SIGNATURE-----

Closed
?