[PATCH]: typos & small fixes in guix/ui.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal
V
V
Vincent Legoll wrote on 16 Apr 2020 23:44
(address . guix-patches@gnu.org)
8e729c60-13db-32d7-c96c-a2087c64ed62@gmail.com
Hello,

here is a patch to fix a few fairly trivial things.

I saw the first one (s/IDENT/INDENT/) reading a patch
in the ML, and while I was in that file, searched
for other ones.

The line-length fix (1st hunk) may not be suitable...

The grammar fix (last hunk) may not be a real english
fix, dunno.

Will this create merge conflicts for others ?

WDYT ?

--
Vincent Legoll
From b1c5e90d85a15e87d075d2547c02bb49fe5a54a6 Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@gmail.com>
Date: Thu, 16 Apr 2020 23:17:16 +0200
Subject: [PATCH] guix: ui: Fix typos, 80-col & grammar in comments &
docstrings

* guix/ui.scm (load*): Fix comment line length.
(leave-on-EPIPE): Fix typo in docstring.
(substitutable-info): Fix typo in comment.
(indented-string): Fix typo in docstring.
(%package-metrics): Fix typo in comment.
(run-guix): Fix grammar in docstring.
---
guix/ui.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (62 lines)
diff --git a/guix/ui.scm b/guix/ui.scm
index 1ccc80a000..ea5f460865 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -234,8 +234,8 @@ information, or #f if it could not be found."
;; Give 'load' an absolute file name so that it doesn't try to
;; search for FILE in %LOAD-PATH. Note: use 'load', not
- ;; 'primitive-load', so that FILE is compiled, which then allows us
- ;; to provide better error reporting with source line numbers.
+ ;; 'primitive-load', so that FILE is compiled, which then allows
+ ;; us to provide better error reporting with source line numbers.
(load (canonicalize-path file)))
(const #f))))))
(lambda _
@@ -796,7 +796,7 @@ directories:~{ ~a~}~%")
(apply format #f format-string format-args))))))
(define-syntax-rule (leave-on-EPIPE exp ...)
- "Run EXP... in a context when EPIPE errors are caught and lead to 'exit'
+ "Run EXP... in a context where EPIPE errors are caught and lead to 'exit'
with successful exit code. This is useful when writing to the standard output
may lead to EPIPE, because the standard output is piped through 'head' or
similar."
@@ -925,7 +925,7 @@ download."
drv))
(define substitutable-info
- ;; Call 'substitutation-oracle' upfront so we don't end up launching the
+ ;; Call 'substitution-oracle' upfront so we don't end up launching the
;; substituter many times. This makes a big difference, especially when
;; DRV is a long list as is the case with 'guix environment'.
(if use-substitutes?
@@ -1251,7 +1251,7 @@ separator between subsequent columns."
(define* (indented-string str indent
#:key (initial-indent? #t))
- "Return STR with each newline preceded by IDENT spaces. When
+ "Return STR with each newline preceded by INDENT spaces. When
INITIAL-INDENT? is true, the first line is also indented."
(define indent-string
(make-list indent #\space))
@@ -1534,7 +1534,7 @@ score, the more relevant OBJ is to REGEXPS."
(,(lambda (package)
(filter (lambda (output)
(not (member output
- ;; Some common outpus shared by many packages.
+ ;; Some common outputs shared by many packages.
'("out" "doc" "debug" "lib" "include" "bin"))))
(package-outputs package)))
. 1)
@@ -1942,7 +1942,7 @@ found."
(define (run-guix . args)
"Run the 'guix' command defined by command line ARGS.
Unlike 'guix-main', this procedure assumes that locale, i18n support,
-and signal handling has already been set up."
+and signal handling have already been set up."
(define option? (cut string-prefix? "-" <>))
;; The default %LOAD-EXTENSIONS includes the empty string, which doubles the
--
2.26.0
L
L
Ludovic Courtès wrote on 17 Apr 2020 23:09
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 40674-done@debbugs.gnu.org)
87eeslakfs.fsf@gnu.org
Hi,

Vincent Legoll <vincent.legoll@gmail.com> skribis:

Toggle quote (2 lines)
> Will this create merge conflicts for others ?

No, I think it’s fine.

Toggle quote (13 lines)
>>From b1c5e90d85a15e87d075d2547c02bb49fe5a54a6 Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@gmail.com>
> Date: Thu, 16 Apr 2020 23:17:16 +0200
> Subject: [PATCH] guix: ui: Fix typos, 80-col & grammar in comments &
> docstrings
>
> * guix/ui.scm (load*): Fix comment line length.
> (leave-on-EPIPE): Fix typo in docstring.
> (substitutable-info): Fix typo in comment.
> (indented-string): Fix typo in docstring.
> (%package-metrics): Fix typo in comment.
> (run-guix): Fix grammar in docstring.

Applied, thanks!

Ludo’.
Closed
?