[PATCH] services: rottlog: Append '.gz' to rotated file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 29 Apr 2020 09:37
(address . guix-patches@gnu.org)
20200429073750.25435-1-brice@waegenei.re
* gnu/services/admin.scm (%default-rotations): Add option 'storefile'.
---
gnu/services/admin.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/services/admin.scm b/gnu/services/admin.scm
index df3cb01646..89fa73920d 100644
--- a/gnu/services/admin.scm
+++ b/gnu/services/admin.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,8 +72,11 @@
(list (log-rotation ;syslog files
(files %rotated-files)
+ (options '(;; Run post-rotate once per rotation
+ "sharedscripts"
+ ;; Append .gz to rotated files
+ "storefile @FILENAME.@COMP_EXT"))
;; Restart syslogd after rotation.
- (options '("sharedscripts"))
(post-rotate #~(let ((pid (call-with-input-file "/var/run/syslog.pid"
read)))
(kill pid SIGHUP))))
--
2.26.0
B
L
L
Ludovic Courtès wrote on 2 May 2020 00:01
Re: [bug#40953] [PATCH] services: rottlog: Append '.gz' to rotated file.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 40953@debbugs.gnu.org)
87h7wzb9hd.fsf@gnu.org
Hi,

Brice Waegeneire <brice@waegenei.re> skribis:

Toggle quote (2 lines)
> * gnu/services/admin.scm (%default-rotations): Add option 'storefile'.

Please add “Fixes https://bugs.gnu.org/....”

LGTM! That problem had always annoyed me.

Ludo’.
B
B
Brice Waegeneire wrote on 6 May 2020 11:17
(no subject)
(address . 40953-done@debbugs.gnu.org)
791ac2a4f366554ff173be1e1ca3ac84@waegenei.re
Pushed as ab034adfe86333fccd6afe476806f169e2074d69.
Closed
?