[PATCH] gnu: emacs-next: Upgrade to 27.0.91.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 2 May 2020 06:26
(address . guix-patches@gnu.org)(name . Jack Hill)(address . jackhill@jackhill.us)
20200502042656.14461-1-jackhill@jackhill.us
* gnu/packages/emacs.scm (emacs-next): Upgrade to 27.0.91.
[inputs]: Remove imagemagick.
---
gnu/packages/emacs.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ab7cc20d10..039d0d16b2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix utils)
+ #:use-module (ice-9 match)
#:use-module (srfi srfi-1))
(define-public emacs
@@ -242,9 +244,9 @@ languages.")
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "36abf6864604b3061c2e070f8997491fa2bce44c")
+ (let ((commit "c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c")
(revision "0")
- (emacs-version "27.0.50"))
+ (emacs-version "27.0.91"))
(package
(inherit emacs)
(name "emacs-next")
@@ -256,7 +258,7 @@ languages.")
(url "https://git.savannah.gnu.org/git/emacs.git")
(commit commit)))
(sha256
- (base32 "1ckn607p0clz0dhhlizvv7l03p4nminy48h53xrpz55w4rcrcm2l"))
+ (base32 "0mlrg2npy1r79laahkgzhxd1qassfcdz8qk1cpw7mqgf6y5x505h"))
(file-name (git-file-name name version))
(patches (search-patches "emacs27-exec-path.patch"
"emacs-fix-scheme-indent-function.patch"
@@ -321,7 +323,13 @@ languages.")
(inputs
`(("jansson" ,jansson)
("harfbuzz" ,harfbuzz)
- ,@(package-inputs emacs)))
+ ;; Emacs no longer uses ImageMagick by default
+ ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-27.0.91&id=c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c#n102
+ ,@(let ((package-eq? (lambda (symbol input-item)
+ (match input-item
+ ((name package)
+ (eq? symbol package))))))
+ (delete imagemagick (package-inputs emacs) package-eq?))))
(native-inputs
`(("autoconf" ,autoconf) ; needed when building from trunk
,@(package-native-inputs emacs)))
--
2.26.2
L
L
Ludovic Courtès wrote on 4 May 2020 23:00
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41016@debbugs.gnu.org)
87a72npg9r.fsf@gnu.org
Hi Jack,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (3 lines)
> * gnu/packages/emacs.scm (emacs-next): Upgrade to 27.0.91.
> [inputs]: Remove imagemagick.

[...]

Toggle quote (9 lines)
> - ,@(package-inputs emacs)))
> + ;; Emacs no longer uses ImageMagick by default
> + ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-27.0.91&id=c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c#n102
> + ,@(let ((package-eq? (lambda (symbol input-item)
> + (match input-item
> + ((name package)
> + (eq? symbol package))))))
> + (delete imagemagick (package-inputs emacs) package-eq?))))

For simplicity, we’d typically write:

(alist-delete "imagemagick" (package-inputs emacs))

I can do it for you if you want, thanks!

Ludo’.
J
J
Jack Hill wrote on 4 May 2020 23:03
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41016@debbugs.gnu.org)
alpine.DEB.2.20.2005041701030.5735@marsh.hcoop.net
Ludo’

On Mon, 4 May 2020, Ludovic Courtès wrote:

[…]

Toggle quote (13 lines)
>> - ,@(package-inputs emacs)))
>> + ;; Emacs no longer uses ImageMagick by default
>> + ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-27.0.91&id=c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c#n102
>> + ,@(let ((package-eq? (lambda (symbol input-item)
>> + (match input-item
>> + ((name package)
>> + (eq? symbol package))))))
>> + (delete imagemagick (package-inputs emacs) package-eq?))))
>
> For simplicity, we’d typically write:
>
> (alist-delete "imagemagick" (package-inputs emacs))

Thanks for the tip!

Toggle quote (2 lines)
> I can do it for you if you want, thanks!

Sure, please go ahead.

Best,
Jack
L
L
Ludovic Courtès wrote on 5 May 2020 23:47
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41016-done@debbugs.gnu.org)
87mu6mjbqj.fsf@gnu.org
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (23 lines)
> On Mon, 4 May 2020, Ludovic Courtès wrote:
>
> […]
>
>>> - ,@(package-inputs emacs)))
>>> + ;; Emacs no longer uses ImageMagick by default
>>> + ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-27.0.91&id=c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c#n102
>>> + ,@(let ((package-eq? (lambda (symbol input-item)
>>> + (match input-item
>>> + ((name package)
>>> + (eq? symbol package))))))
>>> + (delete imagemagick (package-inputs emacs) package-eq?))))
>>
>> For simplicity, we’d typically write:
>>
>> (alist-delete "imagemagick" (package-inputs emacs))
>
> Thanks for the tip!
>
>> I can do it for you if you want, thanks!
>
> Sure, please go ahead.

Done, thanks!

Ludo’.
Closed
J
J
Jack Hill wrote on 6 May 2020 00:51
Re: bug#41016: [PATCH] gnu: emacs-next: Upgrade to 27.0.91.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41016-done@debbugs.gnu.org)
alpine.DEB.2.20.2005051848470.5735@marsh.hcoop.net
On Tue, 5 May 2020, Ludovic Courtès wrote:

Toggle quote (24 lines)
> Jack Hill <jackhill@jackhill.us> skribis:
>> On Mon, 4 May 2020, Ludovic Courtès wrote:
>>
>> […]
>>
>>>> - ,@(package-inputs emacs)))
>>>> + ;; Emacs no longer uses ImageMagick by default
>>>> + ;; https://git.savannah.gnu.org/cgit/emacs.git/tree/etc/NEWS?h=emacs-27.0.91&id=c36c5a3dedbb2e0349be1b6c3b7567ea7b594f1c#n102
>>>> + ,@(let ((package-eq? (lambda (symbol input-item)
>>>> + (match input-item
>>>> + ((name package)
>>>> + (eq? symbol package))))))
>>>> + (delete imagemagick (package-inputs emacs) package-eq?))))
>>>
>>> For simplicity, we’d typically write:
>>>
>>> (alist-delete "imagemagick" (package-inputs emacs))
>>>
>>> I can do it for you if you want, thanks!
>>
>> Sure, please go ahead.
>
> Done, thanks!

Ludo’

I guess we can take (ice-9 match) out of the imports now that we're using
alist-delete. Should I propose another patch, or do you want to do that?

Best,
Jack
Closed
L
L
Ludovic Courtès wrote on 10 May 2020 22:15
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41016-done@debbugs.gnu.org)
87o8qv8s38.fsf@gnu.org
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (4 lines)
> I guess we can take (ice-9 match) out of the imports now that we're
> using alist-delete. Should I propose another patch, or do you want to
> do that?

I went ahead and removed the import, thanks!

Ludo’.
Closed
?