[PATCH] gnu: Add python-websockets

  • Done
  • quality assurance status badge
Details
2 participants
  • Edouard Klein
  • Efraim Flashner
Owner
unassigned
Submitted by
Edouard Klein
Severity
normal
E
E
Edouard Klein wrote on 12 May 2020 10:46
(address . guix-patches@gnu.org)
87eerpilqx.fsf@alice.lan
---
gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6d48b0146a..9be92053b1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3721,3 +3722,27 @@ and serve updated contents upon changes to the directory.")
(description "@code{VF-1} is a command line gopher client with
@acronym{TLS, Transport Layer Security} support.")
(license license:bsd-2)))
+
+(define-public python-websockets
+ (package
+ (name "python-websockets")
+ (version "8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "websockets" version))
+ (sha256
+ (base32
+ "03s3ml6sbki24aajllf8aily0xzrn929zxi84p50zkkbikdd4raw"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/aaugustin/websockets")
+ (synopsis
+ "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
+ (description
+ "@code{websockets} is a library for building WebSocket servers and clients
+in Python with a focus on correctness and simplicity.
+
+Built on top of @code{asyncio}, Python's standard asynchronous I/O framework,
+it provides an elegant coroutine-based API.")
+ (license license:bsd-3)))
--
2.26.2
E
E
Efraim Flashner wrote on 13 May 2020 08:48
(name . Edouard Klein)(address . edk@beaver-labs.com)(address . 41203-done@debbugs.gnu.org)
20200513064818.GC918@E5400
I disabled the tests since they're not shipped in the release tarball
and changed the commit message to fit the conventions better.

Patch pushed. Thanks!


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl67mDIACgkQQarn3Mo9
g1Gajw/+OdN5YUTKtvsdDWbzsUl2MY3ZIC3PGGv6dTeWc0GnkbdiClRfjiw3rESn
DQnG9T7wRV0Hthd8vDYX/6zPZfxsAUh127+JWw8B1/OrFuMRX+Yr7zJ5u+SCavUH
FdKpiEeYJ6OxkEK5+yebgsHE0ldIe2KPJYDRREqEnhkSejBw/kWCSb6n4srOkd7Q
xrIMBSeCgH4nElKbgXFxSNmZIDb0mnviA6Nzroe7ldR6gkHyVoaB2tckQWSzoG7n
SpUHRteb08p7M/dH/4TGDzCyFyGUyCWhcOGcY1B3LxnfA4Sg7D4dJDiNgaXkAdcd
onFcMLrJV97dCzAGHy/vW2apvHdH0pJwwuvp4xWSXTRUEsvGDflRz2L3WekpyQZY
O0wtbC1KFOP49gbTVwA/3nHCAvIe9cTrqMwk9ljdl4kjNXOFRd7UW5S1PWqOVnnJ
awLcV3QAf+UYKDmTBOdlcGc1bbmMzVtmsW9FbC3B8UtsnWlaogA5KZPP1G7iUrL6
Ktrd182nDgLRiLRBW0vnJNOsv+dW1UDkZ65WVsOCrtdVto1yOpSMa0WHSl799Sg8
4I2Q51C/iJ4fJWMq21//UzFpv+6gOXTQckq3lr/2MaYg9nVbtwVhVavSD8rOcSvh
bAdT8b/RQWh+GN2BD5Gv05Yd7BMe/0smVC3NlzJK8L+gUCXZmZc=
=ZSBh
-----END PGP SIGNATURE-----


Closed
?