[PATCH] gnu: Add python-random-user-agent.

  • Done
  • quality assurance status badge
Details
2 participants
  • Edouard Klein
  • Marius Bakke
Owner
unassigned
Submitted by
Edouard Klein
Severity
normal
E
E
Edouard Klein wrote on 13 May 2020 09:52
(address . guix-patches@gnu.org)
87mu6cgtkj.fsf@alice.lan
* gnu/packages/python-web.scm (python-random-user-agent): New variable.
---
gnu/packages/python-web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 32a4d2b756..c6d8c3744b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3769,3 +3769,24 @@ Selenium specifically provides infrastructure for the W3C WebDriver specificatio
— a platform and language-neutral coding interface compatible with all
major web browsers.")
(license license:asl2.0)))
+
+(define-public python-random-user-agent
+ (package
+ (name "python-random-user-agent")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "random_user_agent" version))
+ (sha256
+ (base32
+ "04nhzdh2ki7ybhjrmghxci6hcm6i03vvin2q2ynj87fbr1pa534g"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/Luqman-Ud-Din/random_user_agent")
+ (synopsis
+ "Random user agents based on filters provided by the user")
+ (description
+ "Provides list of user agents, from a collection of more than
+ 326,000 user agents, based on filters.")
+ (license license:expat)))
--
2.26.2
M
M
Marius Bakke wrote on 20 May 2020 23:35
87lflm9tn1.fsf@devup.no
Edouard Klein <edk@beaver-labs.com> writes:

Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-random-user-agent): New variable.

Thanks!

A few cosmetic comments:

Toggle quote (3 lines)
> + (home-page
> + "https://github.com/Luqman-Ud-Din/random_user_agent")

This line break is unnecessary.

Toggle quote (3 lines)
> + (synopsis
> + "Random user agents based on filters provided by the user")

I shortened this to "List of user agents".

Toggle quote (4 lines)
> + (description
> + "Provides list of user agents, from a collection of more than
> + 326,000 user agents, based on filters.")

And expanded on this a bit, to turn it into a full sentence and provide
a little more context.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl7ForIACgkQoqBt8qM6
VPoriwf/aLCXGj0hv9f1uShJ6066GY9pc3W/3mGCzJca7Ij5yFJaLapr76kOBf5E
WYMlXPJI4hO5hSpKhCh2GMx5CwILNHsXIud+LA4tOzpfMZGGmY/8wj4QUv+vc7yp
ZLEpP9PKwXcMuhXXp671n35HNFm6fov8Y9iCSpR26WilnTQvkUHq5DENWjt/TuUq
WBazv4xASbvdJm1p6uPcSie+wQWR1Jb8dZRsQMwRqPvDY+YnW6s0hEPkfXc/7Dzp
x66DIrI6qd8+0ulhZacmEWqXC9nKaBOT/Fxgk5HQp0Vey+F1dpI9/KgGqVFbXgYa
dgNx59SfvFv1bp8/kMchkX0hi5p1ZA==
=8t+r
-----END PGP SIGNATURE-----

Closed
?