[PATCH] gnu: exo: Fix exo-compose-mail.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal
J
J
Jonathan Brielmaier wrote on 14 May 2020 12:28
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200514102846.309-1-jonathan.brielmaier@web.de

* gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri.
---
gnu/packages/xfce.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..ce26c62857 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -213,6 +213,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
--
2.26.2
J
J
Jonathan Brielmaier wrote on 14 May 2020 12:53
[v2 PATCH] gnu: exo: Fix exo-compose-mail.
(address . 41255@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20200514105341.1195-1-jonathan.brielmaier@web.de

* gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail phase so it can find URI::Escape from perl-uri.
---
gnu/packages/xfce.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4217023cf8..61b64ef553 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 L p R n d n <guix@lprndn.info>
;;; Copyright © 2019 Ingo Ruhnke <grumbel@gmail.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -213,6 +214,19 @@ to share commonly used Xfce widgets among the Xfce applications.")
(base32
"1dp5s64g6572h9zvx9js7qc72s728qsd9y7hl7hg6rwaq0cjb2gc"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; exo won't find URI::Escape otherwise
+ (add-after 'install 'wrap-exo-compose-mail
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (perl5lib (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/lib/xfce4/exo/exo-compose-mail")
+ `("PERL5LIB" ":" prefix
+ (,(string-append perl5lib ":" out
+ "/lib/perl5/site_perl")))))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)))
--
2.26.2
R
R
Ricardo Wurmus wrote on 14 May 2020 16:49
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 41255-done@debbugs.gnu.org)
871rnmk1vi.fsf@elephly.net
Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

Toggle quote (5 lines)
>
> * gnu/packages/xfce.scm (exo)[arguments]: Add wrap-exo-compose-mail
> phase so it can find URI::Escape from perl-uri.

Applied and pushed with commit 5c7e477c6cfe89aa4dfce557ea181e5aa8ba8a05.
Thanks!

--
Ricardo
Closed
?