[PATCH] gnu: guile-dsv: Wrap script.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 19 May 2020 06:14
(address . guix-patches@gnu.org)
20200519041421.10704-1-jackhill@jackhill.us
* gnu/packages/guile-xyz.scm (guile-dsv)[arguments]: Add "wrap program" phase.
---
gnu/packages/guile-xyz.scm | 27 ++++++++++++++++++++++++++-
1 file changed, 26 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 674b1f922b..ee2e44653e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -467,7 +468,9 @@ you send to a FIFO file.")
(inputs `(("guile" ,guile-2.2)))
(propagated-inputs `(("guile2.2-lib" ,guile2.2-lib)))
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:modules ((ice-9 match) (ice-9 ftw)
+ ,@%gnu-build-system-modules)
+ #:phases (modify-phases %standard-phases
(add-before 'configure 'set-guilesitedir
(lambda _
(substitute* "Makefile.in"
@@ -482,6 +485,28 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
(("^guilesitedir =.*$")
"guilesitedir = \
$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (site (string-append out "/share/guile/site"))
+ (guile-lib (assoc-ref inputs "guile2.2-lib")))
+ (match (scandir site)
+ (("." ".." version)
+ (let ((modules (string-append site "/" version))
+ (compiled-modules (string-append
+ out "/lib/guile/" version
+ "/site-ccache")))
+ (wrap-program (string-append bin "/dsv")
+ `("GUILE_LOAD_PATH" prefix
+ (,modules
+ ,(string-append guile-lib "/share/guile/site")))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,compiled-modules
+ ,(string-append guile-lib "/lib/guile/"
+ version
+ "/site-ccache"))))))))
#t)))))
(home-page "https://github.com/artyom-poptsov/guile-dsv")
(synopsis "DSV module for Guile")
--
2.26.2
L
L
Ludovic Courtès wrote on 23 May 2020 16:28
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41389@debbugs.gnu.org)
87ftbq680b.fsf@gnu.org
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-dsv)[arguments]: Add "wrap program" phase.

[...]

Toggle quote (7 lines)
> + (add-after 'install 'wrap-program
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin"))
> + (site (string-append out "/share/guile/site"))
> + (guile-lib (assoc-ref inputs "guile2.2-lib")))

We should eventually rename it to “guile-lib” and switch to Guile 3.0,
but that’s another story.

Toggle quote (3 lines)
> + (match (scandir site)
> + (("." ".." version)

I recommend ‘target-guile-effective-version’ from (guix build
guile-build-system) instead of this trick.

Could you send an updated patch?

Thanks in advance!

Ludo’.
J
J
Jack Hill wrote on 24 May 2020 00:48
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41389@debbugs.gnu.org)
alpine.DEB.2.20.2005231842130.5735@marsh.hcoop.net
Ludo’,

Thanks for the review!

On Sat, 23 May 2020, Ludovic Courtès wrote:

Toggle quote (18 lines)
> Hi,
>
> Jack Hill <jackhill@jackhill.us> skribis:
>
>> * gnu/packages/guile-xyz.scm (guile-dsv)[arguments]: Add "wrap program" phase.
>
> [...]
>
>> + (add-after 'install 'wrap-program
>> + (lambda* (#:key inputs outputs #:allow-other-keys)
>> + (let* ((out (assoc-ref outputs "out"))
>> + (bin (string-append out "/bin"))
>> + (site (string-append out "/share/guile/site"))
>> + (guile-lib (assoc-ref inputs "guile2.2-lib")))
>
> We should eventually rename it to “guile-lib” and switch to Guile 3.0,
> but that’s another story.

I had some time today, so I've done this in the second patch. This
required substituting configure.ac as discussed at:

Could the regular expression I used be improved?

Toggle quote (8 lines)
>> + (match (scandir site)
>> + (("." ".." version)
>
> I recommend ‘target-guile-effective-version’ from (guix build
> guile-build-system) instead of this trick.
>
> Could you send an updated patch?

Thanks for the tip. I did this, and cleaned up the up the let binding and
wrap-program calls while I was at it. I hope it makes it clearer.

Toggle quote (2 lines)
> Thanks in advance!

You're welcome!

Best,
Jack
J
J
Jack Hill wrote on 24 May 2020 00:50
[PATCH 1/2] gnu: guile-dsv: Wrap script.
(address . 41389@debbugs.gnu.org)(address . ludo@gnu.org)
20200523225039.3207-1-jackhill@jackhill.us
* gnu/packages/guile-xyz.scm (guile-dsv)[arguments]: Add "wrap program"
phase. Import target-guile-effective-version from guile-build-system for use
in new phase.
---
gnu/packages/guile-xyz.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a1deee32d1..b1c1fd0f62 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -467,7 +468,12 @@ you send to a FIFO file.")
(inputs `(("guile" ,guile-2.2)))
(propagated-inputs `(("guile2.2-lib" ,guile2.2-lib)))
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:modules (((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules ((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases (modify-phases %standard-phases
(add-before 'configure 'set-guilesitedir
(lambda _
(substitute* "Makefile.in"
@@ -482,6 +488,24 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
(("^guilesitedir =.*$")
"guilesitedir = \
$(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (guile-lib (assoc-ref inputs "guile2.2-lib"))
+ (version (target-guile-effective-version))
+ (scm (string-append "/share/guile/site/"
+ version))
+ (go (string-append "/lib/guile/"
+ version "/site-ccache")))
+ (wrap-program (string-append bin "/dsv")
+ `("GUILE_LOAD_PATH" prefix
+ (,(string-append out scm)
+ ,(string-append guile-lib scm)))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
+ (,(string-append out go)
+ ,(string-append guile-lib go)))))
#t)))))
(home-page "https://github.com/artyom-poptsov/guile-dsv")
(synopsis "DSV module for Guile")
--
2.26.2
J
J
Jack Hill wrote on 24 May 2020 00:50
[PATCH 2/2] gnu: guile-dsv: Build with Guile 3.0.
(address . 41389@debbugs.gnu.org)(address . ludo@gnu.org)
20200523225039.3207-2-jackhill@jackhill.us
* gnu/packages/guile-xyz.scm (guile-dsv)[inputs]: Replace guile-2.2 with
guile-3.0.
[propagated-inputs]: Replace guile2.2-lib with guile-lib.
[arguments]: Add "configure support guile3.0" phase.
(guile2.2-dsv): New variable.
---
gnu/packages/guile-xyz.scm | 21 ++++++++++++++++++---
1 file changed, 18 insertions(+), 3 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b1c1fd0f62..8dfce091ef 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -465,8 +465,8 @@ you send to a FIFO file.")
("automake" ,automake)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
- (inputs `(("guile" ,guile-2.2)))
- (propagated-inputs `(("guile2.2-lib" ,guile2.2-lib)))
+ (inputs `(("guile" ,guile-3.0)))
+ (propagated-inputs `(("guile-lib" ,guile-lib)))
(arguments
`(#:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
@@ -474,6 +474,14 @@ you send to a FIFO file.")
#:imported-modules ((guix build guile-build-system)
,@%gnu-build-system-modules)
#:phases (modify-phases %standard-phases
+ ;; Support Guile 3.0 in configure from upstream commit
+ ;; 4c724577ccf19bb88580f72f2f6b166a0447ce3f
+ (add-before 'bootstrap 'configure-support-guile3.0
+ (lambda _
+ (substitute* "configure.ac"
+ (("GUILE_PKG.*")
+ "GUILE_PKG([3.0 2.0 2.2])"))
+ #t))
(add-before 'configure 'set-guilesitedir
(lambda _
(substitute* "Makefile.in"
@@ -493,7 +501,7 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (guile-lib (assoc-ref inputs "guile2.2-lib"))
+ (guile-lib (assoc-ref inputs "guile-lib"))
(version (target-guile-effective-version))
(scm (string-append "/share/guile/site/"
version))
@@ -515,6 +523,13 @@ delimiter-separated values (DSV) data format. Guile-DSV supports the
Unix-style DSV format and RFC 4180 format.")
(license license:gpl3+)))
+(define-public guile2.2-dsv
+ (package
+ (inherit guile-dsv)
+ (name "guile2.2-dsv")
+ (inputs `(("guile" ,guile-2.2)))
+ (propagated-inputs `(("guile-lib" ,guile2.2-lib)))))
+
(define-public guile-fibers
(package
(name "guile-fibers")
--
2.26.2
L
L
Ludovic Courtès wrote on 24 May 2020 21:56
Re: [PATCH 1/2] gnu: guile-dsv: Wrap script.
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41389-done@debbugs.gnu.org)
87a71x3y4s.fsf@gnu.org
Hello,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (4 lines)
> * gnu/packages/guile-xyz.scm (guile-dsv)[arguments]: Add "wrap program"
> phase. Import target-guile-effective-version from guile-build-system for use
> in new phase.

[...]

Toggle quote (6 lines)
> * gnu/packages/guile-xyz.scm (guile-dsv)[inputs]: Replace guile-2.2 with
> guile-3.0.
> [propagated-inputs]: Replace guile2.2-lib with guile-lib.
> [arguments]: Add "configure support guile3.0" phase.
> (guile2.2-dsv): New variable.

Applied both, thank you!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 24 May 2020 21:58
Re: [bug#41389] [PATCH] gnu: guile-dsv: Wrap script.
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41389@debbugs.gnu.org)
875zcl3y1g.fsf@gnu.org
Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (4 lines)
> I had some time today, so I've done this in the second patch. This
> required substituting configure.ac as discussed at:
> https://github.com/artyom-poptsov/guile-dsv/pull/8

Great.

Toggle quote (2 lines)
> Could the regular expression I used be improved?

I had overlooked this question, what regexp are you referring to?

Ludo’.
J
J
Jack Hill wrote on 24 May 2020 23:30
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 41389@debbugs.gnu.org)
alpine.DEB.2.20.2005241647380.5735@marsh.hcoop.net
On Sun, 24 May 2020, Ludovic Courtès wrote:

Toggle quote (12 lines)
> Jack Hill <jackhill@jackhill.us> skribis:
>
>> I had some time today, so I've done this in the second patch. This
>> required substituting configure.ac as discussed at:
>> https://github.com/artyom-poptsov/guile-dsv/pull/8
>
> Great.
>
>> Could the regular expression I used be improved?
>
> I had overlooked this question, what regexp are you referring to?

"GUILE_PKG.*" to match the line in configure.ac to be modified for Guile
3.0 support. I think it's readable as is, and avoids the need to escape
special characters, but it's very broad. Perhaps it should be more
specific.

Best,
Jack
L
L
Ludovic Courtès wrote on 25 May 2020 09:41
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 41389@debbugs.gnu.org)
87pnaswjg0.fsf@gnu.org
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (19 lines)
> On Sun, 24 May 2020, Ludovic Courtès wrote:
>
>> Jack Hill <jackhill@jackhill.us> skribis:
>>
>>> I had some time today, so I've done this in the second patch. This
>>> required substituting configure.ac as discussed at:
>>> https://github.com/artyom-poptsov/guile-dsv/pull/8
>>
>> Great.
>>
>>> Could the regular expression I used be improved?
>>
>> I had overlooked this question, what regexp are you referring to?
>
> "GUILE_PKG.*" to match the line in configure.ac to be modified for
> Guile 3.0 support. I think it's readable as is, and avoids the need to
> escape special characters, but it's very broad. Perhaps it should be
> more specific.

I think it’s fine this way. It’s unlikely to match anything else.

Ludo’.
J
J
Jack Hill wrote on 25 May 2020 18:00
(name . Ludovic Courtès)(address . ludo@gnu.org)
alpine.DEB.2.20.2005251159120.5735@marsh.hcoop.net
On Mon, 25 May 2020, Ludovic Courtès wrote:

Toggle quote (2 lines)
> Jack Hill <jackhill@jackhill.us> skribis:

[…]

Toggle quote (7 lines)
>> "GUILE_PKG.*" to match the line in configure.ac to be modified for
>> Guile 3.0 support. I think it's readable as is, and avoids the need to
>> escape special characters, but it's very broad. Perhaps it should be
>> more specific.
>
> I think it’s fine this way. It’s unlikely to match anything else.

Ok, makes sense. Thanks again for the review and applying the patches.

Best,
Jack
?