[PATCH] Update emacs-magit to latest commit.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 19 May 2020 19:26
(name . guix-patches)(address . guix-patches@gnu.org)
87imgral9n.fsf@gmail.com
This updates our emacs-magit package to the latest version, which
has the following benefits:

1) The test suite is now enabled.
2) The libgit2 C library is now accelerating some of the Magit tasks
3) Using the emacs-build-system means the Magit autoload file is
now byte compiled.
4) No custom patching is done.

The other updates were required to prevent breaking some of the packages
which had a dependency on emacs-magit.

Maxim
From 84710de8f80d33363b1f570e33ea2c0fc6d147d4 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 19 May 2020 11:09:16 -0400
Subject: [PATCH 3/5] gnu: emacs-evil-magit: Update to commit 253c644.

This resolves tests failures that appeared with the update to emacs-magit.

* gnu/packages/emacs-xyz.scm (emacs-evil-magit): Update to commit 253c644.
---
gnu/packages/emacs-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 93c7686174..c34d8b7914 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16082,8 +16082,8 @@ Org-mode file, and citations of Zotero items in Pandoc Markdown files.")
(license license:gpl3+)))
(define-public emacs-evil-magit
- (let ((commit "4b66a1db8285457147a5436f209391016a819ea1")
- (revision "3"))
+ (let ((commit "253c644807013fe92429acdef418748794b8f254")
+ (revision "4"))
(package
(name "emacs-evil-magit")
(version (git-version "0.4.2" revision commit))
@@ -16096,7 +16096,7 @@ Org-mode file, and citations of Zotero items in Pandoc Markdown files.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kkmbswfh34k3amfl3v140vsnz1gq4n4mg9g4khjd9yjph3zms4h"))))
+ "08mh7phxsdb9w4dfs0pmr4l4fdzzr2rm88z2s8karfi5j5ik2ag5"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-evil" ,emacs-evil)
--
2.26.2
From bc2c5ddcb97e10291fe59bcf7c525389102af28a Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 24 Mar 2020 21:43:55 -0400
Subject: [PATCH 4/5] gnu: emacs-transient: Update to commit a6e4cced.

This is necessary to build a recent version of emacs-forge.

* gnu/packages/emacs-xyz.scm (emacs-transient): Update to commit a6e4cced.
[build-system]: Switch to the emacs-build-system.
[arguments]: Remove the #:modules, #:imported-modules and #:make-flags
arguments.
[phases]{configure}: Do not delete.
{install}: Do not replace.
{build-info-manual}: New phase.
{enter-lisp-directory}: New phase.
[native-inputs]: Remove emacs-minimal, which is implicitly provided by the
emacs-build-system.
---
gnu/packages/emacs-xyz.scm | 56 ++++++++++++++++----------------------
1 file changed, 24 insertions(+), 32 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c34d8b7914..5be5c097e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19222,11 +19222,11 @@ as Emacs Lisp.")
(license license:gpl3+))))
(define-public emacs-transient
- ;; 0.1.0 depends on lv.el but not later versions.
- (let ((commit "7e45a57ec81185631fe763733f64c99021df2a06"))
+ (let ((revision "1")
+ (commit "a6e4cced303b3febd59412b24a97eaf1e855e6d7"))
(package
(name "emacs-transient")
- (version (git-version "0.1.0" "1" commit))
+ (version (git-version "0.2.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -19235,41 +19235,33 @@ as Emacs Lisp.")
(file-name (git-file-name name version))
(sha256
(base32
- "0r6d4c1lga3bk0s7q7y4v4hbpxnd9h40cjxybqvax2z902931fz1"))))
- (build-system gnu-build-system)
- (native-inputs `(("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
- (propagated-inputs
- `(("dash" ,emacs-dash)))
+ "01xsw9sxr50valc2q590ngy3ra2ll01p39l9cbzvqqz6mxyymxmd"))))
+ (build-system emacs-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (srfi srfi-26)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-utils))
- #:tests? #f ; tests are not included in the release
- #:make-flags (list "lisp" "info")
+ `(#:tests? #f ;no test suite
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lisp (string-append out "/share/emacs/site-lisp"))
- (info (string-append out "/share/info")))
- (for-each (cut install-file <> lisp)
- (find-files "." "\\.elc*$"))
- (install-file "docs/transient.info" (string-append info)))
+ (add-after 'unpack 'build-info-manual
+ (lambda _
+ (invoke "make" "info")
+ ;; Move the info file to lisp so that it gets installed by the
+ ;; emacs-build-system.
+ (rename-file "docs/transient.info" "lisp/transient.info")))
+ (add-after 'build-info-manual 'enter-lisp-directory
+ (lambda _
+ (chdir "lisp")
#t)))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (propagated-inputs
+ `(("dash" ,emacs-dash)))
(home-page "https://magit.vc/manual/transient")
(synopsis "Transient commands in Emacs")
- (description
- "Taking inspiration from prefix keys and prefix arguments in Emacs,
-Transient implements a similar abstraction involving a prefix command, infix
-arguments and suffix commands. We could call this abstraction a \"transient
-command\", but because it always involves at least two commands (a prefix and
-a suffix) we prefer to call it just a \"transient\".")
+ (description "Taking inspiration from prefix keys and prefix arguments
+in Emacs, Transient implements a similar abstraction involving a prefix
+command, infix arguments and suffix commands. We could call this abstraction
+a \"transient command\", but because it always involves at least two
+commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
(license license:gpl3+))))
(define-public emacs-forge
--
2.26.2
From 0dc89992266fcfcd3ebd93f2a7f2e16eaa14e388 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 19 May 2020 11:55:17 -0400
Subject: [PATCH 5/5] gnu: emacs-forge: Update to commit 09bf8ad.

* gnu/packages/emacs-xyz.scm (emacs-forge): Update to 09bf8ad.
[native-inputs]: Remove emacs-minimal, which is implicitly provided by the
emacs-build-system.
---
gnu/packages/emacs-xyz.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5be5c097e3..733b8ca7af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19265,10 +19265,10 @@ commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
(license license:gpl3+))))
(define-public emacs-forge
- (let ((commit "63cbf81f166fc71861d8e3d246df8e5ccedcb9bb"))
+ (let ((commit "09bf8adc9c9afb492632e612f51f39e1cc15fca0"))
(package
(name "emacs-forge")
- (version (git-version "0.1.0" "3" commit))
+ (version (git-version "0.1.0" "4" commit))
(source
(origin
(method git-fetch)
@@ -19278,11 +19278,10 @@ commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
(file-name (git-file-name name version))
(sha256
(base32
- "1yf2xjx3459py6rji740jm8bmh2pv66ghnbjxsvjd4jf9kcdav83"))))
+ "148h1rvmfmxyrfy2q5l0vzblr7lpsyw1si30hfwhzsj8fvj21qcr"))))
(build-system emacs-build-system)
(native-inputs
- `(("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
+ `(("texinfo" ,texinfo)))
(propagated-inputs
`(("emacs-closql" ,emacs-closql)
("emacs-dash" ,emacs-dash)
--
2.26.2
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEJ9WGpPiQCFQyn/CfEmDkZILmNWIFAl7EFtUACgkQEmDkZILm
NWJFSQ//YWvIgfuHX1o3tsCeVo6LMnpaj9pUOsSbI68geVyMpmL0fGHqgipU977J
qSvJWVStnFpC1Beg3xcaPXKWulLZmpVUEWFzURGmMWknRJadyMoTvazW+CuuL4lU
+uUqVJtiuffpT2hsxPpx5cXzI42/m5Ulbs8MH9qBSZ7G1vSkAPekHWdX5nXcNSg0
j0bIFZQvNV5mfl8iFgWGUVdtYTbwJsYHcOENh/dsvEbQbXEqNbVP8nIDQdUHn9Oa
Jtw/xGQlIUzouSu0IBT60HeTdqWggMUcf2fLdPzYqij4DGv80L3ig51HhlYIp8QA
OcxnQmfG6TmthdwMON+0i4pcP5LtGcxJXWAklNIyZyKiAWzJZ4QExCLRTV1+3hvx
rvP5AvwOTRNa1i/VWNJOxz+xH6yzZpOMV3kNhA1vtSA2VMJGjvqKYvYfKCqUWM02
U3MRjbxoFlmDIacUxyxc04R5l27YCzDQ80wHjSgmkQg85PymnocDtPreuzjLEV89
KBz3vbimGwA6MknVqh401i9zO/eTF8VHdl8ODEPld8U2rSP30ziOKs7CzN+3LqFc
ZH16SsmtLDgGLNkNL8JJYfy79f93XLm9Ciup2AwQKrwDUWXjOrihUaz5XgyHPKc2
A+VQQ60BezHs+qSxb0rrBpMoXyOCoF5tpkK+sSzlEn/0IdAd+WU=
=xLEW
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 26 May 2020 23:53
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 41405@debbugs.gnu.org)
875zci5poh.fsf@nicolasgoaziou.fr
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (12 lines)
> This updates our emacs-magit package to the latest version, which
> has the following benefits:
>
> 1) The test suite is now enabled.
> 2) The libgit2 C library is now accelerating some of the Magit tasks
> 3) Using the emacs-build-system means the Magit autoload file is
> now byte compiled.
> 4) No custom patching is done.
>
> The other updates were required to prevent breaking some of the packages
> which had a dependency on emacs-magit.

LGTM!

Regards,

--
Nicolas Goaziou
M
M
Maxim Cournoyer wrote on 27 May 2020 19:49
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 41405-done@debbugs.gnu.org)
87d06p6zf0.fsf@gmail.com
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (18 lines)
> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This updates our emacs-magit package to the latest version, which
>> has the following benefits:
>>
>> 1) The test suite is now enabled.
>> 2) The libgit2 C library is now accelerating some of the Magit tasks
>> 3) Using the emacs-build-system means the Magit autoload file is
>> now byte compiled.
>> 4) No custom patching is done.
>>
>> The other updates were required to prevent breaking some of the packages
>> which had a dependency on emacs-magit.
>
> LGTM!

Thanks for the review! I pushed the series to master with commit
ffd2696bd8c898cb69b8b443db5584d84986d419.

Maxim
Closed
?